aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dpkg
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/dpkg')
-rwxr-xr-xmeta/recipes-devtools/dpkg/run-postinsts/run-postinsts2
-rw-r--r--meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk2
-rw-r--r--meta/recipes-devtools/dpkg/run-postinsts_1.0.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts b/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts
index f632d1c7d3..584a92ebfd 100755
--- a/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts
+++ b/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts
@@ -5,7 +5,7 @@
# Author: Richard Purdie <rpurdie@openedhand.com>
#
-PKGSYSTEM=/var/dpkg
+PKGSYSTEM=/var/lib/dpkg
if [ ! -e $PKGSYSTEM/status ]; then
if [ -e /usr/lib/opkg/status ]; then
diff --git a/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk b/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk
index 09a1400cf4..d92200b4f0 100644
--- a/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk
+++ b/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk
@@ -9,7 +9,7 @@
BEGIN {
rc=system("test -d /usr/dpkg/info/")
if (rc==0)
- pkgdir="/var/dpkg/info"
+ pkgdir="/var/lib/dpkg/info"
else
pkgdir="/usr/lib/opkg/info"
package=""
diff --git a/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb b/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
index f15243b60a..f8f3368729 100644
--- a/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
+++ b/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Run postinstall scripts on device using awk"
SECTION = "devel"
-PR = "r6"
+PR = "r7"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"