summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.07.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.07.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.07.bb b/meta/recipes-devtools/nasm/nasm_2.07.bb
new file mode 100644
index 0000000000..4e482a04d6
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.07.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "General-purpose x86 assembler"
+SECTION = "devel"
+LICENSE = "simplifiedBSD"
+LIC_CHKSUM_FILES = "file://LICENSE;md5=d89d124974e487e5d64da6f1cd8acfbb"
+COMPATIBLE_HOST = '(x86_64|i.86.*)-(linux|freebsd.*)'
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nasm/nasm-${PV}.tar.bz2 "
+
+inherit autotools
+
+do_configure_prepend () {
+ mv aclocal.m4 acinclude.m4
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+
+ oe_runmake 'INSTALLROOT=${D}' install
+}
+
+BBCLASSEXTEND = "native"