summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-pycairo_1.8.10.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycairo_1.8.10.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycairo_1.8.10.bb b/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
new file mode 100644
index 0000000000..1ff603875a
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Python Bindings for the Cairo canvas library"
+HOMEPAGE = "http://cairographics.org/pycairo"
+BUGTRACKER = "http://bugs.freedesktop.org"
+SECTION = "python-devel"
+LICENSE = "LGPLv2.1 & MPLv1.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f2e071ab72978431b294a0d696327421"
+# cairo >= 1.8.8
+DEPENDS = "cairo"
+PR = "ml0"
+
+SRC_URI = "http://cairographics.org/releases/py2cairo-${PV}.tar.gz"
+S = "${WORKDIR}/pycairo-${PV}"
+
+inherit distutils pkgconfig
+
+do_install_append () {
+ install -d ${D}${includedir}
+ install -d ${D}${libdir}
+ mv ${D}${datadir}/include/* ${D}${includedir}
+ mv ${D}${datadir}/lib/* ${D}${libdir}
+ sed -i -e 's#prefix=.*#prefix=${prefix}#' ${D}${libdir}/pkgconfig/pycairo.pc
+}