summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-hypothesis_6.50.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-hypothesis_6.50.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-hypothesis_6.50.1.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta/recipes-devtools/python/python3-hypothesis_6.50.1.bb b/meta/recipes-devtools/python/python3-hypothesis_6.50.1.bb
deleted file mode 100644
index 0c93c12493..0000000000
--- a/meta/recipes-devtools/python/python3-hypothesis_6.50.1.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-SUMMARY = "A library for property-based testing"
-HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
-LICENSE = "MPL-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
-
-PYPI_PACKAGE = "hypothesis"
-
-inherit pypi setuptools3 ptest
-
-SRC_URI += " \
- file://run-ptest \
- file://test_binary_search.py \
- file://test_rle.py \
- "
-
-SRC_URI[sha256sum] = "1a19ade3b27825cab622c95fcf25182a27a42f97589c163173fcbdafb8621d1e"
-
-RDEPENDS:${PN} += " \
- python3-attrs \
- python3-compression \
- python3-core \
- python3-json \
- python3-sortedcontainers \
- python3-statistics \
- python3-unittest \
- "
-
-RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- "
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/examples
- install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/
- install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/
-}
-
-BBCLASSEXTEND = "native nativesdk"