aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.7.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.7.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.7.bb b/meta/recipes-extended/grep/grep_2.7.bb
new file mode 100644
index 0000000000..c3e098688e
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.7.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "grep GNU utility"
+HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
+BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
+SECTION = "console/utils"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
+
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "e848f07e3e79aa7899345d17c7e4115e"
+SRC_URI[sha256sum] = "ad14831015a79cea36785aa47415f6c0653a6ac4eaf9c15456f0d9d09c9e1bad"
+
+inherit autotools gettext
+
+EXTRA_OECONF = "--disable-perl-regexp"
+
+do_configure_prepend () {
+ rm -f ${S}/m4/init.m4
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN}
+ mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN}
+ mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
+ update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
+ update-alternatives --install ${base_bindir}/fgrep fgrep fgrep.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove grep grep.${PN}
+ update-alternatives --remove egrep egrep.${PN}
+ update-alternatives --remove fgrep fgrep.${PN}
+}