aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter/clutter
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/clutter/clutter')
-rw-r--r--meta/recipes-graphics/clutter/clutter/build-fix.patch16
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch40
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests-0.8.patch50
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests-1.0.patch32
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch32
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests.patch32
-rw-r--r--meta/recipes-graphics/clutter/clutter/symconflict.patch31
7 files changed, 233 insertions, 0 deletions
diff --git a/meta/recipes-graphics/clutter/clutter/build-fix.patch b/meta/recipes-graphics/clutter/clutter/build-fix.patch
new file mode 100644
index 0000000000..68cf84ec22
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter/build-fix.patch
@@ -0,0 +1,16 @@
+Installing the same file twice causes an error in Automake 1.11
+
+JL 19/03/10
+
+Index: git/clutter/Makefile.am
+===================================================================
+--- git.orig/clutter/Makefile.am 2010-03-19 11:37:51.000000000 +0000
++++ git/clutter/Makefile.am 2010-03-19 11:50:46.744042007 +0000
+@@ -219,7 +219,6 @@
+ $(source_h) \
+ clutter-json.h \
+ clutter-enum-types.h \
+- clutter-version.h \
+ clutter.h
+
+ DISTCLEANFILES = \
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch b/meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch
new file mode 100644
index 0000000000..544a7e588c
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch
@@ -0,0 +1,40 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter-0-6/tests/Makefile.am
+===================================================================
+--- clutter.orig/tests/Makefile.am 2007-11-06 12:29:17.000000000 +0000
++++ clutter-0-6/tests/Makefile.am 2007-11-06 12:30:11.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-boxes test-perspective test-rotate test-depth \
+ test-threads test-timeline test-score test-script
+@@ -26,4 +26,9 @@ test_timeline_SOURCES = test-timeline.c
+ test_score_SOURCES = test-score.c
+ test_script_SOURCES = test-script.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png test-script.json
+Index: clutter-0-6/tests/test-actors.c
+===================================================================
+--- clutter.orig/tests/test-actors.c 2007-11-06 12:29:17.000000000 +0000
++++ clutter-0-6/tests/test-actors.c 2007-11-06 12:29:21.000000000 +0000
+@@ -143,7 +143,7 @@ main (int argc, char *argv[])
+ stage = clutter_stage_get_default ();
+ clutter_actor_set_size (stage, 800, 600);
+
+- pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
++ pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
+
+ if (!pixbuf)
+ g_error("pixbuf load failed");
+
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests-0.8.patch b/meta/recipes-graphics/clutter/clutter/enable_tests-0.8.patch
new file mode 100644
index 0000000000..4f449b1177
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter/enable_tests-0.8.patch
@@ -0,0 +1,50 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter/tests/Makefile.am
+===================================================================
+--- clutter.orig/tests/Makefile.am 2008-06-26 16:46:26.000000000 +0100
++++ clutter/tests/Makefile.am 2008-06-26 16:46:50.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-perspective test-rotate test-depth \
+ test-threads test-timeline test-timeline-dup-frames \
+@@ -17,8 +17,8 @@
+ test-invariants
+
+ if X11_TESTS
+-noinst_PROGRAMS += test-pixmap
+-noinst_PROGRAMS += test-devices
++bin_PROGRAMS += test-pixmap
++bin_PROGRAMS += test-devices
+ endif
+
+ INCLUDES = -I$(top_srcdir)/ -I$(top_srcdir)/clutter -I$(top_builddir)/clutter
+@@ -73,4 +73,9 @@
+ test_invariants_SOURCES = test-invariants.c
+ test_devices_SOURCES = test-devices.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png test-script.json
+Index: clutter/tests/test-actors.c
+===================================================================
+--- clutter.orig/tests/test-actors.c 2008-06-26 16:46:26.000000000 +0100
++++ clutter/tests/test-actors.c 2008-06-26 16:46:31.000000000 +0100
+@@ -195,7 +195,7 @@
+ /* Create a texture from file, then clone in to same resources */
+ if (i == 0)
+ {
+- if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
++ if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
+ &error)) == NULL)
+ {
+ g_error ("image load failed: %s", error->message);
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests-1.0.patch b/meta/recipes-graphics/clutter/clutter/enable_tests-1.0.patch
new file mode 100644
index 0000000000..953edf6bbc
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter/enable_tests-1.0.patch
@@ -0,0 +1,32 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: git/tests/interactive/Makefile.am
+===================================================================
+--- git.orig/tests/interactive/Makefile.am 2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/Makefile.am 2009-03-12 11:04:12.000000000 +0000
+@@ -77,7 +77,7 @@
+ AM_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
+ AM_LDFLAGS = $(CLUTTER_LIBS)
+
+-noinst_PROGRAMS = test-interactive
++bin_PROGRAMS = test-interactive
+
+ test_interactive_SOURCES = \
+ test-main.c \
+Index: git/tests/interactive/test-actors.c
+===================================================================
+--- git.orig/tests/interactive/test-actors.c 2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/test-actors.c 2009-03-12 11:06:32.000000000 +0000
+@@ -182,7 +182,7 @@
+ oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0);
+ oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5);
+
+- real_hand = clutter_texture_new_from_file ("redhand.png", &error);
++ real_hand = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png", &error);
+ if (real_hand == NULL)
+ {
+ g_error ("image load failed: %s", error->message);
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch b/meta/recipes-graphics/clutter/clutter/enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch
new file mode 100644
index 0000000000..953edf6bbc
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter/enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch
@@ -0,0 +1,32 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: git/tests/interactive/Makefile.am
+===================================================================
+--- git.orig/tests/interactive/Makefile.am 2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/Makefile.am 2009-03-12 11:04:12.000000000 +0000
+@@ -77,7 +77,7 @@
+ AM_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
+ AM_LDFLAGS = $(CLUTTER_LIBS)
+
+-noinst_PROGRAMS = test-interactive
++bin_PROGRAMS = test-interactive
+
+ test_interactive_SOURCES = \
+ test-main.c \
+Index: git/tests/interactive/test-actors.c
+===================================================================
+--- git.orig/tests/interactive/test-actors.c 2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/test-actors.c 2009-03-12 11:06:32.000000000 +0000
+@@ -182,7 +182,7 @@
+ oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0);
+ oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5);
+
+- real_hand = clutter_texture_new_from_file ("redhand.png", &error);
++ real_hand = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png", &error);
+ if (real_hand == NULL)
+ {
+ g_error ("image load failed: %s", error->message);
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests.patch b/meta/recipes-graphics/clutter/clutter/enable_tests.patch
new file mode 100644
index 0000000000..f4af7c94f6
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter/enable_tests.patch
@@ -0,0 +1,32 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: git/tests/interactive/Makefile.am
+===================================================================
+--- git.orig/tests/interactive/Makefile.am 2009-11-30 17:39:46.000000000 +0000
++++ git/tests/interactive/Makefile.am 2009-11-30 17:42:30.000000000 +0000
+@@ -88,7 +88,7 @@
+
+ common_ldadd = $(top_builddir)/clutter/libclutter-@CLUTTER_WINSYS@-@CLUTTER_API_VERSION@.la
+
+-noinst_PROGRAMS = test-interactive
++bin_PROGRAMS = test-interactive
+
+ test_interactive_SOURCES = test-main.c $(UNIT_TESTS)
+ test_interactive_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
+Index: git/tests/interactive/test-actors.c
+===================================================================
+--- git.orig/tests/interactive/test-actors.c 2009-11-30 17:39:46.000000000 +0000
++++ git/tests/interactive/test-actors.c 2009-11-30 17:43:03.000000000 +0000
+@@ -178,7 +178,7 @@
+ oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0);
+ oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5);
+
+- file = g_build_filename (TESTS_DATADIR, "redhand.png", NULL);
++ file = g_build_filename (TESTS_DATADIR, "/usr/share/clutter/redhand.png", NULL);
+ real_hand = clutter_texture_new_from_file (file, &error);
+ if (real_hand == NULL)
+ g_error ("image load failed: %s", error->message);
diff --git a/meta/recipes-graphics/clutter/clutter/symconflict.patch b/meta/recipes-graphics/clutter/clutter/symconflict.patch
new file mode 100644
index 0000000000..7685c21161
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter/symconflict.patch
@@ -0,0 +1,31 @@
+Index: git/tests/test-depth.c
+===================================================================
+--- git.orig/tests/test-depth.c 2009-05-24 14:54:40.000000000 +0100
++++ git/tests/test-depth.c 2009-05-24 14:55:13.000000000 +0100
+@@ -11,13 +11,13 @@
+ clutter_timeline_start (timeline);
+ }
+
+-static ClutterActor *raise[2];
++static ClutterActor *clutterraise[2];
+ static gboolean raise_no = 0;
+
+ static gboolean
+ raise_top (gpointer ignored)
+ {
+- clutter_actor_raise_top (raise[raise_no]);
++ clutter_actor_raise_top (clutterraise[raise_no]);
+ raise_no = !raise_no;
+ return TRUE;
+ }
+@@ -202,8 +202,8 @@
+
+ clutter_timeline_start (timeline);
+
+- raise[0] = rect;
+- raise[1] = hand;
++ clutterraise[0] = rect;
++ clutterraise[1] = hand;
+ g_timeout_add (2000, raise_top, NULL);
+
+ clutter_main ();