aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/settings-daemon
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/settings-daemon')
-rw-r--r--meta/recipes-sato/settings-daemon/files/70settings-daemon.sh1
-rw-r--r--meta/recipes-sato/settings-daemon/files/addsoundkeys.patch47
-rw-r--r--meta/recipes-sato/settings-daemon/settings-daemon_svn.bb26
3 files changed, 74 insertions, 0 deletions
diff --git a/meta/recipes-sato/settings-daemon/files/70settings-daemon.sh b/meta/recipes-sato/settings-daemon/files/70settings-daemon.sh
new file mode 100644
index 0000000000..95374135f2
--- /dev/null
+++ b/meta/recipes-sato/settings-daemon/files/70settings-daemon.sh
@@ -0,0 +1 @@
+/usr/bin/settings-daemon &
diff --git a/meta/recipes-sato/settings-daemon/files/addsoundkeys.patch b/meta/recipes-sato/settings-daemon/files/addsoundkeys.patch
new file mode 100644
index 0000000000..e06f02917b
--- /dev/null
+++ b/meta/recipes-sato/settings-daemon/files/addsoundkeys.patch
@@ -0,0 +1,47 @@
+Index: settings-daemon/settings-daemon.c
+===================================================================
+--- settings-daemon.orig/settings-daemon.c 2009-05-22 14:57:05.000000000 +0100
++++ settings-daemon/settings-daemon.c 2009-05-22 14:58:22.000000000 +0100
+@@ -187,6 +187,10 @@
+ GCONF_VALUE_STRING, translate_string_string },
+ { "/desktop/poky/interface/gtk_color_scheme", "Gtk/ColorScheme",
+ GCONF_VALUE_STRING, translate_string_string },
++ { "/desktop/gnome/sound/theme_name", "Net/SoundThemeName",
++ GCONF_VALUE_STRING, translate_string_string },
++ { "/desktop/gnome/sound/event_sounds", "Net/EnableEventSounds" ,
++ GCONF_VALUE_BOOL, translate_bool_int },
+ };
+
+ static const TranslationEntry*
+Index: settings-daemon/settings-daemon.schemas
+===================================================================
+--- settings-daemon.orig/settings-daemon.schemas 2009-05-22 15:49:17.000000000 +0100
++++ settings-daemon/settings-daemon.schemas 2009-05-22 15:51:31.000000000 +0100
+@@ -196,6 +196,27 @@
+ </locale>
+ </schema>
+
++ <schema>
++ <key>/schemas/desktop/gnome/sound/theme_name</key>
++ <applyto>/desktop/gnome/sound/theme_name</applyto>
++ <owner>gnome</owner>
++ <type>string</type>
++ <default>freedesktop</default>
++ <locale name="C">
++ <short>Sound Theme Name</short>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/desktop/gnome/sound/event_sounds</key>
++ <applyto>/desktop/gnome/sound/event_sounds</applyto>
++ <owner>gnome</owner>
++ <type>bool</type>
++ <default>true</default>
++ <locale name="C">
++ <short>Enable Sound Events</short>
++ </locale>
++ </schema>
+
+ </schemalist>
+ </gconfschemafile>
diff --git a/meta/recipes-sato/settings-daemon/settings-daemon_svn.bb b/meta/recipes-sato/settings-daemon/settings-daemon_svn.bb
new file mode 100644
index 0000000000..4d1d9baf40
--- /dev/null
+++ b/meta/recipes-sato/settings-daemon/settings-daemon_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Settings-daemon provides a bridge between gconf and xsettings"
+HOMEPAGE = "http://svn.o-hand.com/view/matchbox/trunk/settings-daemon/"
+BUGTRACKER = "http://bugzilla.openedhand.com/"
+LICENSE = "MIT-style"
+LIC_FILES_CHKSUM = "file://xsettings-manager.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
+ file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
+DEPENDS = "gconf glib-2.0 gtk+"
+SECTION = "x11"
+PV = "0.0+svnr${SRCREV}"
+
+PR = "r3"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
+ file://addsoundkeys.patch;apply=yes \
+ file://70settings-daemon.sh"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig gconf
+
+FILES_${PN} = "${bindir}/* ${sysconfdir}"
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d
+ install -m 755 ${WORKDIR}/70settings-daemon.sh ${D}/${sysconfdir}/X11/Xsession.d/
+}