aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/images/core-image-sato.bb2
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb39
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11.bb45
3 files changed, 2 insertions, 84 deletions
diff --git a/meta/recipes-sato/images/core-image-sato.bb b/meta/recipes-sato/images/core-image-sato.bb
index 76f90817ad..6b6c7611bc 100644
--- a/meta/recipes-sato/images/core-image-sato.bb
+++ b/meta/recipes-sato/images/core-image-sato.bb
@@ -7,3 +7,5 @@ IMAGE_FEATURES += "apps-console-core package-management x11-base x11-sato ssh-se
LICENSE = "MIT"
inherit core-image
+
+IMAGE_INSTALL += "packagegroup-core-x11-sato-games"
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb
deleted file mode 100644
index 432d99d0ca..0000000000
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb
+++ /dev/null
@@ -1,39 +0,0 @@
-#
-# Copyright (C) 2011 Intel Corporation
-#
-
-DESCRIPTION = "Tasks for core X11 applications"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r1"
-
-inherit packagegroup
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
-
-ROOTLESS_X = "1"
-
-# xserver-common, x11-common
-VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
-
-# elsa, xserver-nodm-init
-VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
-
-
-RDEPENDS_packagegroup-core-x11-mini = "\
- dbus \
- pointercal \
- matchbox-terminal \
- matchbox-wm \
- mini-x-session \
- ${XSERVER} \
- ${VIRTUAL-RUNTIME_xserver_common} \
- ${VIRTUAL-RUNTIME_graphical_init_manager} \
- liberation-fonts \
- xauth \
- xhost \
- xset \
- xrandr"
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
deleted file mode 100644
index b69cc50d33..0000000000
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
+++ /dev/null
@@ -1,45 +0,0 @@
-#
-# Copyright (C) 2011 Intel Corporation
-#
-
-DESCRIPTION = "Tasks for core X11 applications"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r36"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-core-x11-base \
- "
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
-
-# xserver-common, x11-common
-VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
-
-# elsa, xserver-nodm-init
-VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
-
-
-RDEPENDS_packagegroup-core-x11-base = "\
- dbus \
- pointercal \
- matchbox-wm \
- matchbox-keyboard \
- matchbox-keyboard-applet \
- matchbox-keyboard-im \
- matchbox-panel-2 \
- matchbox-desktop \
- matchbox-session \
- ${XSERVER} \
- ${VIRTUAL-RUNTIME_xserver_common} \
- ${VIRTUAL-RUNTIME_graphical_init_manager} \
- liberation-fonts \
- xauth \
- xhost \
- xset \
- xrandr"