aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnome-desktop-testing
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnome-desktop-testing')
-rw-r--r--meta/recipes-support/gnome-desktop-testing/files/no-introspection.patch19
-rw-r--r--meta/recipes-support/gnome-desktop-testing/gnome-desktop-testing_2013.1.bb18
2 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-support/gnome-desktop-testing/files/no-introspection.patch b/meta/recipes-support/gnome-desktop-testing/files/no-introspection.patch
new file mode 100644
index 0000000000..67b64f28b8
--- /dev/null
+++ b/meta/recipes-support/gnome-desktop-testing/files/no-introspection.patch
@@ -0,0 +1,19 @@
+Introspection is a hard requirement to build gnome-desktop-testing upstream, but
+it isn't needed anymore.
+
+Upstream-Status: Submitted
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/configure.ac b/configure.ac
+index 7460c69..6249caf 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -27,8 +27,6 @@ AC_SUBST(WARN_CFLAGS)
+ LT_PREREQ([2.2.4])
+ LT_INIT([disable-static])
+
+-GOBJECT_INTROSPECTION_REQUIRE([1.34.0])
+-
+ PKG_CHECK_MODULES(GIO_UNIX, [gio-unix-2.0 >= 2.34.0])
+ GIO_UNIX_CFLAGS="$GIO_UNIX_CFLAGS -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_36 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_36"
+
diff --git a/meta/recipes-support/gnome-desktop-testing/gnome-desktop-testing_2013.1.bb b/meta/recipes-support/gnome-desktop-testing/gnome-desktop-testing_2013.1.bb
new file mode 100644
index 0000000000..36e13b1e65
--- /dev/null
+++ b/meta/recipes-support/gnome-desktop-testing/gnome-desktop-testing_2013.1.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Test runner for GNOME-style installed tests"
+HOMEPAGE = "https://wiki.gnome.org/GnomeGoals/InstalledTests"
+LICENSE = "LGPLv2+"
+
+SRC_URI = "${GNOME_MIRROR}/${BPN}/${PV}/${BPN}-${PV}.tar.xz \
+ file://no-introspection.patch"
+SRC_URI[md5sum] = "c6824f7bfac95bf0fcf6ed0c255979c1"
+SRC_URI[sha256sum] = "632e7224de8614a8e4b7cdf87fc32551531efa9290fba0da4dae56234c584b7b"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
+ file://src/gnome-desktop-testing-runner.c;endline=19;md5=ab86a2e00ab9cbb94f008d785004b181"
+
+DEPENDS = "glib-2.0"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[journald] = "--with-systemd-journal,--without-systemd-journal,systemd,systemd"