summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/files/pcre-cross.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/files/pcre-cross.patch')
-rw-r--r--meta/recipes-support/libpcre/files/pcre-cross.patch53
1 files changed, 37 insertions, 16 deletions
diff --git a/meta/recipes-support/libpcre/files/pcre-cross.patch b/meta/recipes-support/libpcre/files/pcre-cross.patch
index 2ae05a12ca..83880f7098 100644
--- a/meta/recipes-support/libpcre/files/pcre-cross.patch
+++ b/meta/recipes-support/libpcre/files/pcre-cross.patch
@@ -1,23 +1,19 @@
-Upstream-Status: Inappropriate [configuration]
+Upstream-Status: Pending
-To be upstreamable, this patch requires check for *_FOR_BUILD, otherwise
-it needs to pass special variables.
-
-It would be nice to implement per-target compiler specification to
-automake, as it is done for linker.
-
-Even better it would be nice to implement native build time targets in
-automake.
-
-Index: pcre-7.6/Makefile.am
-===================================================================
---- pcre-7.6.orig/Makefile.am 2008-01-23 17:58:28.000000000 +0000
-+++ pcre-7.6/Makefile.am 2008-04-03 22:32:00.000000000 +0000
-@@ -147,6 +147,11 @@
+--- pcre-8.32.orig/Makefile.am
++++ pcre-8.32/Makefile.am
+@@ -197,8 +197,18 @@ bin_SCRIPTS = pcre-config
+
++CC_FOR_BUILD = @CC_FOR_BUILD@
++CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
++CCLD_FOR_BUILD = @CCLD_FOR_BUILD@
++LDFLAGS_FOR_BUILD = @LDFLAGS_FOR_BUILD@
++
+ if WITH_REBUILD_CHARTABLES
noinst_PROGRAMS += dftables
dftables_SOURCES = dftables.c
-+dftables_LINK = $(LINK_FOR_BUILD) -o $@
++dftables_LINK = $(CCLD_FOR_BUILD) -o $@
+dftables_LDFLAGS = $(LDFLAGS_FOR_BUILD)
+
+dftables.o: $(srcdir)/dftables.c
@@ -25,3 +21,28 @@ Index: pcre-7.6/Makefile.am
pcre_chartables.c: dftables$(EXEEXT)
./dftables$(EXEEXT) $@
+--- pcre-8.32.orig/configure.ac
++++ pcre-8.32/configure.ac
+@@ -72,6 +72,22 @@ then
+ fi
+ fi
+
++if test x"$cross_compiling" = xyes; then
++ CC_FOR_BUILD="${CC_FOR_BUILD-gcc}"
++ CCLD_FOR_BUILD="${CCLD_FOR_BUILD-gcc}"
++ CFLAGS_FOR_BUILD="${CFLAGS_FOR_BUILD}"
++ LDFLAGS_FOR_BUILD="${LDFLAGS_FOR_BUILD}"
++else
++ CC_FOR_BUILD="${CC_FOR_BUILD-\$(CC)}"
++ CCLD_FOR_BUILD="${CCLD_FOR_BUILD-\$(CCLD)}"
++ CFLAGS_FOR_BUILD="${CFLAGS_FOR_BUILD-\$(CFLAGS)}"
++ LDFLAGS_FOR_BUILD="${LDFLAGS_FOR_BUILD-\$(LDFLAGS)}"
++fi
++AC_ARG_VAR(CC_FOR_BUILD, [build system C compiler])
++AC_ARG_VAR(CCLD_FOR_BUILD, [build system C linker frontend])
++AC_ARG_VAR(CFLAGS_FOR_BUILD, [build system C compiler arguments])
++AC_ARG_VAR(LDFLAGS_FOR_BUILD, [build system C linker frontend arguments])
++
+ # AC_PROG_CXX will return "g++" even if no c++ compiler is installed.
+ # Check for that case, and just disable c++ code if g++ doesn't run.
+ AC_LANG_PUSH(C++)