summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libxslt')
-rw-r--r--meta/recipes-support/libxslt/libxslt/pkgconfig_fix.patch22
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.26.bb26
2 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt/pkgconfig_fix.patch b/meta/recipes-support/libxslt/libxslt/pkgconfig_fix.patch
new file mode 100644
index 0000000000..d21663896f
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt/pkgconfig_fix.patch
@@ -0,0 +1,22 @@
+Index: libxslt-1.1.22/libexslt.pc.in
+===================================================================
+--- libxslt-1.1.22.orig/libexslt.pc.in 2008-03-19 16:52:20.000000000 +0000
++++ libxslt-1.1.22/libexslt.pc.in 2008-03-19 16:55:49.000000000 +0000
+@@ -8,5 +8,5 @@
+ Version: @LIBEXSLT_VERSION@
+ Description: EXSLT Extension library
+ Requires: libxml-2.0
+-Libs: @EXSLT_LIBDIR@ @EXSLT_LIBS@
++Libs: -lexslt @EXSLT_LIBDIR@ @M_LIBS@
+ Cflags: @EXSLT_INCLUDEDIR@
+Index: libxslt-1.1.22/libxslt.pc.in
+===================================================================
+--- libxslt-1.1.22.orig/libxslt.pc.in 2008-03-19 16:52:20.000000000 +0000
++++ libxslt-1.1.22/libxslt.pc.in 2008-03-19 16:55:38.000000000 +0000
+@@ -8,5 +8,5 @@
+ Version: @VERSION@
+ Description: XSLT library version 2.
+ Requires: libxml-2.0
+-Libs: @XSLT_LIBDIR@ @XSLT_LIBS@
++Libs: -lxslt @XSLT_LIBDIR@ @M_LIBS@
+ Cflags: @XSLT_INCLUDEDIR@
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.26.bb b/meta/recipes-support/libxslt/libxslt_1.1.26.bb
new file mode 100644
index 0000000000..b5726974f1
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.26.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GNOME XSLT library"
+HOMEPAGE = "http://xmlsoft.org/XSLT/"
+BUGTRACKER = "https://bugzilla.gnome.org/"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0cd9a07afbeb24026c9b03aecfeba458"
+
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2 (>=2.6.27)"
+PR = "r0"
+
+SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
+ file://pkgconfig_fix.patch;patch=1"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"
+
+BBCLASSEXTEND = "native"