aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-05-02 23:18:38 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-05-02 23:27:34 +0200
commit75599d20f988ecfbb2a9a62d1c7097a0c454179e (patch)
tree857722512ad0c93bbf6d240a7c1c5a59cefea457
parent7aec50b0696a1cd3ed21173cf6fa06ef0c00db2c (diff)
downloadopenembedded-75599d20f988ecfbb2a9a62d1c7097a0c454179e.tar.gz
prboom: fix compilation
Without that fix we have: arm-oe-linux-gnueabi-gcc [...] -o prboom [...] -L/usr/lib -lSDL -lpng -lm /usr/lib/libSDL.so: file not recognized: File format not recognized This commit was inspired by commit ba5581f2258fccaf87245f5672c20d3cc43d1849 : smpeg svn: fix compilation It was tested at runtime too(Distro:SHR,machine nokia900) Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
-rw-r--r--recipes/prboom/prboom_2.5.0.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/prboom/prboom_2.5.0.bb b/recipes/prboom/prboom_2.5.0.bb
index 13f3623c9c..ef6bb57b51 100644
--- a/recipes/prboom/prboom_2.5.0.bb
+++ b/recipes/prboom/prboom_2.5.0.bb
@@ -4,7 +4,7 @@ PRIORITY = "optional"
DEPENDS = "virtual/libsdl libsdl-mixer libsdl-net"
LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
RRECOMMENDS_${PN} = "freedoom"
SRC_URI = "${SOURCEFORGE_MIRROR}/prboom/prboom-${PV}.tar.gz \
@@ -13,7 +13,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/prboom/prboom-${PV}.tar.gz \
inherit autotools
-EXTRA_OECONF = " --disable-gl --disable-cpu-opt --without-x --disable-sdltest"
+EXTRA_OECONF = " --disable-gl --disable-cpu-opt --without-x --disable-sdltest \
+ SDL_CONFIG=${STAGING_BINDIR_CROSS}/sdl-config"
do_install() {
install -d ${D}${bindir} \