aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2010-11-05 00:34:44 +0100
committerFlorian Boor <florian.boor@kernelconcepts.de>2011-05-03 17:05:04 +0200
commit95bf5692c5553458ac90676db97092bb20ade2e8 (patch)
treeff830fa56835dfbbebcb77606059e8324cb237cb
parent35393002bb5aa476e281a004f7dc64aeefcb2c9e (diff)
downloadopenembedded-95bf5692c5553458ac90676db97092bb20ade2e8.tar.gz
ubootchart: Add recipe for SVN version
A small and easy to use boot process profiler generating bootchart compatible output. From µCross, tested on armv5te platforms and other. Signed-off-by: Florian Boor <florian@kernelconcepts.de>
-rw-r--r--recipes/ubootchart/ubootchart_svn.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/ubootchart/ubootchart_svn.bb b/recipes/ubootchart/ubootchart_svn.bb
new file mode 100644
index 0000000000..835638c273
--- /dev/null
+++ b/recipes/ubootchart/ubootchart_svn.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A boot profiling tool"
+HOMEPAGE = "http://code.google.com/p/ubootchart/"
+LICENSE="GPLv3"
+PV = "0.1.0+svnr${SRCREV}"
+PR = "r0"
+SRCREV_pn-ubootchart ?= "12"
+
+SRC_URI="svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk"
+S = "${WORKDIR}/trunk"
+
+
+do_patch() {
+ sed -i "s/@VERSION@/${PV}-${PR}/" ${S}/ubootchartd
+}
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
+}
+
+do_install() {
+ install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart ${D}${docdir}/ubootchart
+ install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
+ install -m 0755 ${S}/ubootchartd ${D}/sbin
+ install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
+ install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
+ install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
+}