aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-17 12:39:38 +0000
committerKhem Raj <raj.khem@gmail.com>2010-06-18 11:17:15 -0700
commit097131c401034fa2c2e3f7c912cf058fe8eaed15 (patch)
tree53e2f1de049c9b6d75164eda0cc041b1c03326b9
parent19bd6d851cdefbe6be0b9766980a7338fe6ff82d (diff)
downloadopenembedded-097131c401034fa2c2e3f7c912cf058fe8eaed15.tar.gz
busybox_1.15.3.bb: Work around the gcc 4.5 ICE on thumb
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/busybox/busybox_1.15.3.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/recipes/busybox/busybox_1.15.3.bb b/recipes/busybox/busybox_1.15.3.bb
index 07103e855f..6f2e4ec076 100644
--- a/recipes/busybox/busybox_1.15.3.bb
+++ b/recipes/busybox/busybox_1.15.3.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
@@ -29,6 +29,14 @@ SRC_URI = "\
SRC_URI[tarball.md5sum] = "6059ac9456de6fb18dc8ee4cd0ec9240"
SRC_URI[tarball.sha256sum] = "d74020ad2cc5a4dcc5109c44dbd0e22582d6ce42954b0f1ff29763c8c0ff03cb"
+# gcc 4.5 has this bug on thumb
+# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=44557
+# so add -fomit-frame-pointer
+# this will be removed once the above bug is fixed.
+
+
+CFLAGS_append = " -fomit-frame-pointer"
+
EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
do_configure_prepend () {