aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-23 19:18:41 -0700
committerChris Larson <chris_larson@mentor.com>2010-11-08 07:59:21 -0700
commit4e8c767f3fc281e26472e66ccde07419a2c092fc (patch)
treea38c5386676c69450f099579a6d069be6079ca28
parent058ad87c02dd7f05dc02a06aae43dda43ea47e90 (diff)
downloadopenembedded-4e8c767f3fc281e26472e66ccde07419a2c092fc.tar.gz
jack: use the svn repository to fetch
Signed-off-by: Chris Larson <chris_larson@mentor.com>
-rw-r--r--recipes/jack/jack_0.118.0.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/recipes/jack/jack_0.118.0.bb b/recipes/jack/jack_0.118.0.bb
index 22c814378b..1c9ff42a28 100644
--- a/recipes/jack/jack_0.118.0.bb
+++ b/recipes/jack/jack_0.118.0.bb
@@ -10,16 +10,14 @@ DEPENDS = "alsa-lib"
PR = "r2"
-# Original has disappeared. Use Angstrom mirror for now.
-#SRC_URI = "http://jackaudio.org/downloads/jack-audio-connection-kit-${PV}.tar.gz"
-SRC_URI = "http://www.angstrom-distribution.org/unstable/sources/jack-audio-connection-kit-${PV}.tar.gz"
-SRC_URI[md5sum] = "d58e29a55f285d54e75134cec8e02a10"
-SRC_URI[sha256sum] = "6aadf38ca98104772fd675bba7adecf72d2a600e17cccfc5d1f7c50f19b722c2"
+SVNPV = "${@'${PV}'.replace('.', '_')}"
+SRCREV = "${AUTOREV}"
+SRC_URI = "svn://subversion.jackaudio.org/jack/tags;module=RELEASE_${SVNPV};proto=http"
# This is not omap3 specific, but there is a strong correlation between using twl4030 and using omap3
SRC_URI_append_omap3 = " file://jack_fix_TWL4030_alsa_capture.patch"
-S = "${WORKDIR}/jack-audio-connection-kit-${PV}"
+S = "${WORKDIR}/RELEASE_${SVNPV}"
inherit autotools
@@ -38,4 +36,3 @@ FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
FILES_jack-server = "${bindir}/jackd"
FILES_jack-examples = "${bindir}/*"
FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/* "
-