aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-30 16:25:11 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-30 16:25:11 +0000
commit2c35367f8c979b629bb2ae5c464d34eeb9af3a8d (patch)
treedc2daa83785e6f4a0148049015e1669063a3202f
parent885277209e0653dcb15b44f64ccf49adb87d6e7d (diff)
downloadopenembedded-2c35367f8c979b629bb2ae5c464d34eeb9af3a8d.tar.gz
add numptyphysics (ugly ugly build), an insanely cool crayon game
-rw-r--r--conf/distro/include/sane-srcrevs.inc1
-rw-r--r--packages/numptyphysics/.mtn2git_empty0
-rw-r--r--packages/numptyphysics/numptyphysics_svn.bb38
3 files changed, 39 insertions, 0 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index 4cc84b326f..6eb26b9375 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -93,6 +93,7 @@ SRCREV_pn-neod ?= "4336"
SRCREV_pn-netsurf ?= "3859"
SRCREV_pn-networkmanager ?= "3202"
SRCREV_pn-networkmanager-applet ?= "200"
+SRCREV_pn-numptyphysics = "45"
SRCREV_pn-oh-puzzles ?= "22"
SRCREV_pn-osb-browser ?= "125"
SRCREV_pn-osb-jscore ?= "117"
diff --git a/packages/numptyphysics/.mtn2git_empty b/packages/numptyphysics/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/numptyphysics/.mtn2git_empty
diff --git a/packages/numptyphysics/numptyphysics_svn.bb b/packages/numptyphysics/numptyphysics_svn.bb
new file mode 100644
index 0000000000..976028befe
--- /dev/null
+++ b/packages/numptyphysics/numptyphysics_svn.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Numpty Physics is a drawing puzzle game in the spirit (and style?) \
+of Crayon Physics using the same excellent Box2D engine."
+DEPENDS = "virtual/libsdl libsdl-image"
+LICENSE = "GPL"
+HOMEPAGE = "http://numptyphysics.garage.maemo.org/"
+SECTION = "x11/games"
+PV = "0.2+svnr${SRCREV}"
+
+SRC_URI = "\
+ svn://garage.maemo.org/svn/${PN};module=trunk;proto=https \
+ http://wwwpub.zih.tu-dresden.de/~mkluge/numptyphysics_setup.tgz \
+"
+S = "${WORKDIR}/trunk"
+
+EXTRA_S = "${WORKDIR}/local/packages/numptyphysics"
+
+# what an ugly buildsystem... handcrafted Makefiles... back to the stoneage
+export CCOPTS = "${CFLAGS} -I Box2D/Include"
+export LDOPTS = "${LDFLAGS} -lSDL -lSDL_image"
+
+do_configure() {
+ for i in Config.h Makefile Game.cpp; do
+ install -m 0644 ${EXTRA_S}/$i ${S}
+ done
+}
+
+do_install() {
+ install -d ${D}${datadir}/numptyphysics
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/pixmaps
+ install -d ${D}${datadir}/applications
+ install -m 0755 ${S}/arm/Game ${D}${bindir}/numptyphysics
+ install -m 0644 ${EXTRA_S}/star.png ${D}${datadir}/pixmaps
+ install -m 0644 ${EXTRA_S}/numptyphysics.desktop ${D}/${datadir}/applications
+ cp -a ${EXTRA_S}/data/* ${D}/${datadir}/numptyphysics/
+}
+
+FILES_${PN} += "${datadir}"