aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Kurzmann <mok@fluxnetz.de>2009-07-11 16:39:41 +0200
committerAngus Ainslie <nytowl@openmoko.org>2009-07-15 20:48:43 -0600
commit6c639fd45c2a8fe30d3933ad8e6cb3f742a45456 (patch)
treec6b0c060b2cfc030aff237c2ff3fcdcbbe466d39
parent990e45e1c2fedec0f1eee2daa0561b10ed903a3d (diff)
downloadopenembedded-6c639fd45c2a8fe30d3933ad8e6cb3f742a45456.tar.gz
mokonnect: new recipe
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
-rw-r--r--recipes/connman/mokonnect/mokonnect.desktop13
-rw-r--r--recipes/connman/mokonnect_svn.bb42
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes/connman/mokonnect/mokonnect.desktop b/recipes/connman/mokonnect/mokonnect.desktop
new file mode 100644
index 0000000000..0f2408749c
--- /dev/null
+++ b/recipes/connman/mokonnect/mokonnect.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=Mokonnect
+TryExec=/usr/bin/mokonnect.py
+GenericName=Mokonnect
+Comment=Connection Manager for Openmoko Phone
+StartupNotify=true
+Exec=/usr/bin/mokonnect.py
+Terminal=false
+Type=Application
+Categories=Settings;
+Icon=mokonnect.png
diff --git a/recipes/connman/mokonnect_svn.bb b/recipes/connman/mokonnect_svn.bb
new file mode 100644
index 0000000000..1daf575352
--- /dev/null
+++ b/recipes/connman/mokonnect_svn.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "mokonnect is an e17 frontend to connmand"
+HOMEPAGE = "http://www.assembla.com/wiki/show/shrdev"
+AUTHOR = "Fate"
+LICENSE = "GPLv2"
+SECTION = "e/apps"
+RDEPENDS = "python-elementary"
+
+PV = "0.2+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "svn://subversion.assembla.com/svn/shrdev;module=Mokonnect/trunk;proto=http \
+file://mokonnect.desktop"
+
+S = "${WORKDIR}/Mokonnect/trunk"
+
+inherit distutils-base
+
+
+PY_FILES = "mkbase.py mkdev_usbnet.py mkdev_wifi.py mkmenu.py qdbus.py"
+
+do_install() {
+ install -d ${D}${libdir}
+ install -d ${D}${libdir}/${PYTHON_DIR}
+ install -d ${D}${libdir}/${PYTHON_DIR}/site-packages
+
+ for f in ${PY_FILES}
+ do
+ install -m 0644 $f ${D}${libdir}/${PYTHON_DIR}/site-packages/
+ done
+
+ install -d ${D}${bindir}
+ install -m 755 mokonnect.py ${D}${bindir}/
+
+ install -d ${D}${datadir}/applications
+ install -m 644 ${WORKDIR}/mokonnect.desktop ${D}${datadir}/applications/
+
+ install -d ${D}${datadir}/pixmaps
+ install -m 644 mokonnect.png ${D}${datadir}/pixmaps/
+}
+
+FILES_${PN} += " ${datadir}/*/*"
+