aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-23 17:39:14 -0700
committerSteffen Sledz <sledz@dresearch.de>2011-02-25 08:49:00 +0100
commit07c88e4db4ce8125b96d702884ec508b290da21c (patch)
tree8664722f083c55843cf8e27e854b0c928f0409d8
parent8c7f77010d1f146cd482bd12675a65b5239d4748 (diff)
downloadopenembedded-07c88e4db4ce8125b96d702884ec508b290da21c.tar.gz
libnl2: Finish fixing the build race on lib/route/pktloc.c
Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/libnl/libnl2/fix-pktloc-dep-race.patch (renamed from recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch)8
-rw-r--r--recipes/libnl/libnl2_2.0.bb2
-rw-r--r--recipes/libnl/libnl2_git.bb2
3 files changed, 7 insertions, 5 deletions
diff --git a/recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch b/recipes/libnl/libnl2/fix-pktloc-dep-race.patch
index d396f963b4..50acee4d26 100644
--- a/recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch
+++ b/recipes/libnl/libnl2/fix-pktloc-dep-race.patch
@@ -6,15 +6,17 @@ Index: libnl-2.0/lib/Makefile.am
===================================================================
--- libnl-2.0.orig/lib/Makefile.am
+++ libnl-2.0/lib/Makefile.am
-@@ -27,11 +27,14 @@ CLEANFILES = \
+@@ -27,11 +27,15 @@ CLEANFILES = \
route/pktloc_grammar.c route/pktloc_grammar.h \
route/pktloc_syntax.c route/pktloc_syntax.h
-+BUILT_SOURCES = route/pktloc_syntax.h
++BUILT_SOURCES = route/pktloc_syntax.h route/pktloc_grammar.h
+
# Hack to avoid using ylwrap. It does not function correctly in combination
# with --header-file=
- route/pktloc_grammar.c: route/pktloc_grammar.l
+-route/pktloc_grammar.c: route/pktloc_grammar.l
++route/pktloc_grammar.h: route/pktloc_grammar.c
++route/pktloc_grammar.c: route/pktloc_grammar.y
$(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+route/pktloc_syntax.h: route/pktloc_syntax.c
diff --git a/recipes/libnl/libnl2_2.0.bb b/recipes/libnl/libnl2_2.0.bb
index 7e50f3b4d1..3484f24543 100644
--- a/recipes/libnl/libnl2_2.0.bb
+++ b/recipes/libnl/libnl2_2.0.bb
@@ -13,7 +13,7 @@ S = "${WORKDIR}/libnl-${PV}"
SRC_URI = "\
http://www.infradead.org/~tgr/libnl/files/libnl-${PV}.tar.gz \
file://fix-pc-file.patch \
- file://fix-pktloc_syntax_h-race.patch \
+ file://fix-pktloc-dep-race.patch \
"
SRC_URI[md5sum] = "6aaf1e9802a17a7d702bb0638044ffa7"
SRC_URI[sha256sum] = "5a40dc903d3ca1074da7424b908bec8ff16936484798c7e46e53e9db8bc87a9c"
diff --git a/recipes/libnl/libnl2_git.bb b/recipes/libnl/libnl2_git.bb
index a04ac3b805..9c6ff42032 100644
--- a/recipes/libnl/libnl2_git.bb
+++ b/recipes/libnl/libnl2_git.bb
@@ -14,7 +14,7 @@ includedir = ${prefix}/include/libnl2
SRC_URI = "\
git://git.kernel.org/pub/scm/libs/netlink/libnl.git;protocol=git \
file://fix-pc-file.patch \
- file://fix-pktloc_syntax_h-race.patch \
+ file://fix-pktloc-dep-race.patch \
"
S = "${WORKDIR}/git"