aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-01 14:24:29 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-01 14:30:59 +0200
commit3d875160a753c6e2497ba0e73746a6d5fe7643cd (patch)
tree0523e7d3fa5a8b1ef50ff82bd7963600ddc9cb6d
parenta2834c64fb3ed535fca51c25547754fa907e4ca5 (diff)
downloadopenembedded-3d875160a753c6e2497ba0e73746a6d5fe7643cd.tar.gz
xfce46: remove checksum name atribute from bbclass
* ie xfce-base/libxfce4util_4.6.1.bb cannot find it's checksums anymore * commit e3df76459f7710af61d1b51066e0685c822dbe7b introduced name=archive in xfce46.bbclass without adding archive name to all recipes using xfce46 * I agree that in case someone will need additional SRC_URI item in recipe inheriting xfce46 he will have to add it to this bbclass AND update all recipes using it. * Feel free to fix it the other way around if you expect more SRC_URIs/recipe. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--classes/xfce46.bbclass2
-rw-r--r--recipes/xfce-base/xfce4-panel_4.6.3.bb4
-rw-r--r--recipes/xfce-base/xfce4-settings_4.6.4.bb4
3 files changed, 5 insertions, 5 deletions
diff --git a/classes/xfce46.bbclass b/classes/xfce46.bbclass
index 7e3e41877b..c24dfa4d8c 100644
--- a/classes/xfce46.bbclass
+++ b/classes/xfce46.bbclass
@@ -11,7 +11,7 @@ SECTION ?= "x11/xfce"
XFCE_VERSION = ${PV}
-SRC_URI = "http://mocha.xfce.org/archive/src/xfce/${PN}/${@'${PV}'[0:3]}/${PN}-${PV}.tar.bz2;name=archive"
+SRC_URI = "http://mocha.xfce.org/archive/src/xfce/${PN}/${@'${PV}'[0:3]}/${PN}-${PV}.tar.bz2"
inherit autotools gtk-icon-cache pkgconfig
diff --git a/recipes/xfce-base/xfce4-panel_4.6.3.bb b/recipes/xfce-base/xfce4-panel_4.6.3.bb
index bdfa7d687f..a592efe1c5 100644
--- a/recipes/xfce-base/xfce4-panel_4.6.3.bb
+++ b/recipes/xfce-base/xfce4-panel_4.6.3.bb
@@ -7,8 +7,8 @@ PR = "r2"
inherit xfce46
-SRC_URI[archive.md5sum] = "0b715abb929220f136483ccd7303ff62"
-SRC_URI[archive.sha256sum] = "4f5e19187ddf9f812303b77479124562079d25c6263674040aba4395c6b2e41c"
+SRC_URI[md5sum] = "0b715abb929220f136483ccd7303ff62"
+SRC_URI[sha256sum] = "4f5e19187ddf9f812303b77479124562079d25c6263674040aba4395c6b2e41c"
EXTRA_OECONF += " --enable-startup-notification"
diff --git a/recipes/xfce-base/xfce4-settings_4.6.4.bb b/recipes/xfce-base/xfce4-settings_4.6.4.bb
index 121098896d..037a43b488 100644
--- a/recipes/xfce-base/xfce4-settings_4.6.4.bb
+++ b/recipes/xfce-base/xfce4-settings_4.6.4.bb
@@ -9,8 +9,8 @@ inherit xfce46
SRC_URI += "file://0001-Port-to-libxklavier-5.0-API.patch"
-SRC_URI[archive.md5sum] = "04985407e8e5b916c44780314a177e96"
-SRC_URI[archive.sha256sum] = "a5e3f0d959b0d424355414769250473785043c3977446a73b36fa3a5ce44ecdb"
+SRC_URI[md5sum] = "04985407e8e5b916c44780314a177e96"
+SRC_URI[sha256sum] = "a5e3f0d959b0d424355414769250473785043c3977446a73b36fa3a5ce44ecdb"
RDEPENDS_${PN} = "xfconf exo"