aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-03-31 10:10:22 -0700
committerSteffen Sledz <sledz@dresearch-fe.de>2011-04-29 14:08:39 +0200
commit431d0b181a9f2ebd9e6f89d9a4289b8de100ad74 (patch)
tree829b0ca15ce32ea966bfe03d9d66592eb7cb15a4
parent8bb91080742b2fa7c55c2416f694e8ada8a9394d (diff)
downloadopenembedded-431d0b181a9f2ebd9e6f89d9a4289b8de100ad74.tar.gz
xqt2: Switch to patchdir rather than applying in do_configure
Signed-off-by: Tom Rini <tom_rini@mentor.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes/xqt2/xqt2_20060509.bb19
1 files changed, 4 insertions, 15 deletions
diff --git a/recipes/xqt2/xqt2_20060509.bb b/recipes/xqt2/xqt2_20060509.bb
index 627c9179a8..3435b6472b 100644
--- a/recipes/xqt2/xqt2_20060509.bb
+++ b/recipes/xqt2/xqt2_20060509.bb
@@ -20,26 +20,15 @@ SRC_URI = "cvs://anonymous@cvs.sourceforge.jp/cvsroot/xqt;module=xqt2;method=pse
file://fephack.patch \
file://xchar2b.patch \
file://xqt-make.patch \
- file://KeyMap.patch;apply=false \
- file://moc_call.patch;apply=false \
- file://fix_qtscreen_HACK.patch;apply=false \
- file://fix_seqfault_qtscreen.patch;apply=false"
+ file://KeyMap.patch;patchdir=../xqt2 \
+ file://moc_call.patch;patchdir=../xqt2 \
+ file://fix_qtscreen_HACK.patch;patchdir=../xqt2 \
+ file://fix_seqfault_qtscreen.patch;patchdir=../xqt2"
S = "${WORKDIR}/xc"
QT_LIBRARY = '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "qte-mt", "qte",d)}'
QT_LIBRARY_append_c7x0 = " -laticore"
-do_patch_xqt2() {
- # Apply xqt2 patches.
- cd ${WORKDIR}/xqt2
- patch -p1 -i ${WORKDIR}/KeyMap.patch
- patch -p1 -i ${WORKDIR}/moc_call.patch
- patch -p1 -i ${WORKDIR}/fix_qtscreen_HACK.patch
- patch -p1 -i ${WORKDIR}/fix_seqfault_qtscreen.patch
-}
-
-addtask patch_xqt2 after do_unpack before do_configure
-
do_configure() {
#general config