aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-04 11:10:13 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-04 11:10:13 +0200
commit7759f821b5b2912156a953d50b4819340da1977b (patch)
tree8369b04265d410d0f9f696bd9d061c894ad3b4f3
parent5a90bc8ba10650f5f92dabfcc4ac7d91bfd0aaa6 (diff)
downloadopenembedded-7759f821b5b2912156a953d50b4819340da1977b.tar.gz
gstreamer-ti: fix path to codec combos
* if it's going to hardcode the codec locations it should hardcode the locations where OE installs them to instead of './*.x64P'
-rw-r--r--recipes/dsplink/gstreamer-ti_svn.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/recipes/dsplink/gstreamer-ti_svn.bb b/recipes/dsplink/gstreamer-ti_svn.bb
index e14f26208c..ab705f3622 100644
--- a/recipes/dsplink/gstreamer-ti_svn.bb
+++ b/recipes/dsplink/gstreamer-ti_svn.bb
@@ -4,7 +4,7 @@ SRC_URI = "svn://gforge.ti.com/svn/gstreamer_ti/trunk;module=gstreamer_ti;proto=
"
SRCREV = "160"
-PR = "r6"
+PR = "r7"
# Again, no '.' in PWD allowed :(
PV = "0+svnr${SRCREV}"
@@ -32,6 +32,14 @@ export XDC_PLATFORM
#GCArmv5T.cc.opts = "SEDME_CCARCH";
#GCArmv5T.cc.$seal("opts");
+do_configure_prepend() {
+ for i in ${S}/src/*.cfg ; do
+ sed -i -e s:\./encodeCombo.x64P:${datadir}/ti-codec-combos/encodeCombo.x64P:g \
+ -e s:\./decodeCombo.x64P:${datadir}/ti-codec-combos/decodeCombo.x64P:g \
+ $i
+ done
+}
+
do_compile_prepend() {
for i in $(find ${S} -name "config.bld") ; do
sed -i -e s:SEDME_CCARCH:'${TARGET_CCARCH}': $i