aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-10-20 19:31:22 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-10-20 19:31:22 +0200
commit7bc8adad26908b97e412e8665d757efad111aac0 (patch)
tree03335be0d13a898d14105662d82b40de9e818eb1
parent1a78669bebc967c941e35f8213588e56e123794d (diff)
downloadopenembedded-7bc8adad26908b97e412e8665d757efad111aac0.tar.gz
samba: added 3.3.9 recipe
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/samba/samba_3.3.9.bb35
2 files changed, 39 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 7cfe8a3f42..bd33872dc1 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -22762,6 +22762,10 @@ sha256=7e7fb53d6ff05993dcb8b871e3c3016bd4d161d72ded8f8760a4439e9d76aa3b
md5=adb048dc3988055533e1ea5d91d81f99
sha256=b00ca360e9b414744eff33ca4567f3eb1a28d32914e20f00b6672fbc141c9beb
+[http://samba.org/samba/ftp/stable/samba-3.3.9.tar.gz]
+md5=d99c3ccc3066d1c6a0dba4de02aad24b
+sha256=41a8919e3a32cf7523c49473edb478f3a7ec7d4ae4d125297a18d48f79e17f91
+
[ftp://ftp.sane-project.org/pub/sane/old-versions/sane-backends-1.0.15/sane-backends-1.0.15.tar.gz]
md5=3b804f35cdfbc5ad2d201ffe078bbac9
sha256=89106b5bc5a66ca0eaf4553371c89ac8542a757964d7a91c07b8fb77e040eebe
diff --git a/recipes/samba/samba_3.3.9.bb b/recipes/samba/samba_3.3.9.bb
new file mode 100644
index 0000000000..87a7c5e7f7
--- /dev/null
+++ b/recipes/samba/samba_3.3.9.bb
@@ -0,0 +1,35 @@
+require samba.inc
+require samba-basic.inc
+LICENSE = "GPLv3"
+
+# 3.3.0 and newer will upgrade your tdb database to a
+# new version that you can not downgrade to use with older
+# releases. More testing will happen before this is removed
+# should there be further issues. Appears to work though :)
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI += "file://configure-3.3.0.patch;patch=1 \
+ file://config-h.patch;patch=1 \
+ file://mtab.patch;patch=1 \
+ file://tdbheaderfix.patch;patch=1 "
+
+PR = "r3"
+
+EXTRA_OECONF += "\
+ SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
+ samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
+ linux_getgrouplist_ok=no \
+ samba_cv_HAVE_BROKEN_GETGROUPS=no \
+ samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
+ samba_cv_have_setresuid=yes \
+ samba_cv_have_setresgid=yes \
+ samba_cv_HAVE_WRFILE_KEYTAB=yes \
+ "
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile () {
+ base_do_compile
+}