aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-04 16:39:36 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-04 16:39:36 +0100
commit82721f868895944823e34eb7c3e56f4bedb2a4ca (patch)
tree808279aa8028c40006bbc9608478023c094ea187
parentcea3d55fd2638484e9a560d0c04d9e8b8e80806c (diff)
parent8fedaafb39b5664ea964e8aabf2c22795e4fff3c (diff)
downloadopenembedded-82721f868895944823e34eb7c3e56f4bedb2a4ca.tar.gz
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
-rw-r--r--classes/e.bbclass2
-rw-r--r--classes/efl.bbclass9
-rw-r--r--conf/distro/include/sane-srcrevs.inc9
-rw-r--r--conf/machine/am3517-evm.conf1
-rw-r--r--conf/machine/beagleboard.conf1
-rw-r--r--conf/machine/igep0020.conf1
-rw-r--r--conf/machine/include/omap3.inc2
-rw-r--r--conf/machine/omap3-pandora.conf1
-rw-r--r--conf/machine/omap3-touchbook.conf1
-rw-r--r--conf/machine/omap3evm.conf1
-rw-r--r--conf/machine/omapzoom.conf1
-rw-r--r--conf/machine/omapzoom2.conf1
-rw-r--r--conf/machine/palmpre.conf1
-rw-r--r--recipes/e17/exalt-client_svn.bb23
-rw-r--r--recipes/e17/exalt_svn.bb33
-rw-r--r--recipes/eglibc/eglibc_2.10.bb2
-rw-r--r--recipes/eglibc/eglibc_2.9.bb2
-rw-r--r--recipes/eglibc/eglibc_svn.bb2
-rw-r--r--recipes/eglibc/files/armv4t-interworking.patch27
-rw-r--r--recipes/exalt/exalt-daemon/init37
-rw-r--r--recipes/exalt/exalt-daemon_svn.bb13
-rw-r--r--recipes/exalt/exalt-module/autotools-fix.patch12
-rw-r--r--recipes/exalt/exalt-module_svn.bb19
-rw-r--r--recipes/exalt/exalt.inc12
-rw-r--r--recipes/exalt/exalt_svn.bb4
-rw-r--r--recipes/exalt/libexalt-dbus_svn.bb9
-rw-r--r--recipes/exalt/libexalt_svn.bb8
-rw-r--r--recipes/gnome/gnome-themes_2.22.2.bb31
-rw-r--r--recipes/gnome/gnome-themes_2.24.0.bb31
-rw-r--r--recipes/gnome/gnome-themes_2.6.2.bb31
-rw-r--r--recipes/linux/linux-omap-2.6.29/2.6.29_relocation_1.patch11
-rw-r--r--recipes/linux/linux-omap-2.6.29/2.6.29_relocation_2.patch33
-rw-r--r--recipes/linux/linux-omap_2.6.29.bb2
-rw-r--r--recipes/opencv/opencv-samples_svn.bb4
-rw-r--r--recipes/opencv/opencv_svn.bb4
-rw-r--r--recipes/u-boot/files/beagleboard/fw_env.config2
-rw-r--r--recipes/u-boot/u-boot-utils_1.2.0.bb2
-rw-r--r--recipes/u-boot/u-boot_git.bb2
38 files changed, 148 insertions, 239 deletions
diff --git a/classes/e.bbclass b/classes/e.bbclass
index a6fa1d0d78..fca9aa0010 100644
--- a/classes/e.bbclass
+++ b/classes/e.bbclass
@@ -23,7 +23,7 @@ export FREETYPE_CONFIG = "${STAGING_BINDIR_CROSS}/freetype-config"
# This construction is stupid, someone with more E knowledge should change it to =+ or something
# And it's in efl.bbclass as well....
-PACKAGES = "${PN}-dbg ${PN}-themes ${PN} ${PN}-dev ${PN}-doc ${PN}-lib"
+PACKAGES = "${PN}-dbg ${PN}-themes ${PN} ${PN}-dev ${PN}-doc ${PN}-lib ${PN}-static"
FILES_${PN}-lib = "${libdir}/lib*.so.*"
FILES_${PN}-themes = "${datadir}/${PN}/themes ${datadir}/${PN}/data ${datadir}/${PN}/fonts ${datadir}/${PN}/pointers ${datadir}/${PN}/images ${datadir}/${PN}/users ${datadir}/${PN}/images ${datadir}/${PN}/styles"
FILES_${PN}-dev += "${includedir} ${libdir}/lib*.so"
diff --git a/classes/efl.bbclass b/classes/efl.bbclass
index 22e664ce01..d4c3baa9cf 100644
--- a/classes/efl.bbclass
+++ b/classes/efl.bbclass
@@ -24,7 +24,7 @@ do_stage() {
}
# This construction is stupid, someone with more E knowledge should change it to =+ or something
-PACKAGES = "${PN}-dbg ${PN} ${PN}-themes ${PN}-dev ${PN}-doc ${PN}-tests"
+PACKAGES = "${PN}-dbg ${PN} ${PN}-themes ${PN}-dev ${PN}-doc ${PN}-tests ${PN}-static"
FILES_${PN} = "${libdir}/*.so.*"
@@ -40,13 +40,14 @@ FILES_${PN}-themes = "${datadir}/${PN}/themes \
FILES_${PN}-dev += "${bindir}/${PN}-config \
${libdir}/pkgconfig/* \
${libdir}/lib*.la \
- ${libdir}/lib*.a \
${libdir}/*.so \
- ${libdir}/${PN}/*.a \
${libdir}/${PN}/*.la \
- ${libdir}/${PN}/*/*.a \
${libdir}/${PN}/*/*.la"
+FILES_${PN}-static += "${libdir}/${PN}/*.a \
+ ${libdir}/${PN}/*/*.a \
+"
+
FILES_${PN}-dbg += "${libdir}/${PN}/.debug \
${libdir}/${PN}/*/.debug"
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index f0a064232b..b57ea4d673 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -42,9 +42,6 @@ SRCREV_pn-diversity-radar ?= "453"
SRCREV_pn-eds-dbus ?= "736"
SRCREV_pn-enlazar ?= "37"
SRCREV_pn-essential-dialer ?= "194"
-SRCREV_pn-exalt ?= "79"
-SRCREV_pn-exalt-daemon ?= "78"
-SRCREV_pn-exalt-module ?= "78"
SRCREV_pn-ezx-boot-usb-native ?= "2371"
SRCREV_pn-ezx-gen-blob ?= "2426"
SRCREV_pn-ezxd ?= "2074"
@@ -81,8 +78,6 @@ SRCREV_pn-kismet ?= "2285"
SRCREV_pn-kismet-newcore ?= "2285"
SRCREV_pn-libcalenabler2 ?= "1410"
SRCREV_pn-libefso ?= "194"
-SRCREV_pn-libexalt ?= "78"
-SRCREV_pn-libexalt-dbus ?= "76"
SRCREV_pn-libfakekey ?= "1455"
SRCREV_pn-libgdbus ?= "aeab6e3c0185b271ca343b439470491b99cc587f"
SRCREV_pn-libgee ?= "0bddeeefb3bd5b003d77301705dbad181cddcaf6"
@@ -316,4 +311,8 @@ SRCREV_pn-illume ?= "${EFL_SRCREV}"
SRCREV_pn-illume-theme-illume ?= "${EFL_SRCREV}"
SRCREV_pn-waker ?= "${EFL_SRCREV}"
+#exalt
+SRCREV_pn-exalt ?= "${EFL_SRCREV}"
+SRCREV_pn-exalt-client ?= "${EFL_SRCREV}"
+
require conf/distro/include/sane-srcrevs-fso.inc
diff --git a/conf/machine/am3517-evm.conf b/conf/machine/am3517-evm.conf
index f7a60b4be4..0ee57c407f 100644
--- a/conf/machine/am3517-evm.conf
+++ b/conf/machine/am3517-evm.conf
@@ -18,7 +18,6 @@ require conf/machine/include/omap3.inc
PACKAGE_EXTRA_ARCHS += "omap3517-evm"
# Ship all kernel modules
-MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules kernel-modules"
IMAGE_FSTYPES ?= "jffs2 tar.bz2"
EXTRA_IMAGECMD_jffs2 = "-lnp -e 0x20000 -s 2048"
diff --git a/conf/machine/beagleboard.conf b/conf/machine/beagleboard.conf
index 69cdec6f1f..a5de68e0af 100644
--- a/conf/machine/beagleboard.conf
+++ b/conf/machine/beagleboard.conf
@@ -41,6 +41,5 @@ UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
PREFERRED_VERSION_u-boot = "git"
-MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules "
# and sdio
MACHINE_FEATURES = "kernel26 screen apm usbgadget usbhost vfat alsa"
diff --git a/conf/machine/igep0020.conf b/conf/machine/igep0020.conf
index deb17233cc..55c18507c3 100644
--- a/conf/machine/igep0020.conf
+++ b/conf/machine/igep0020.conf
@@ -41,5 +41,4 @@ MKUBIFS_ARGS = "-m 2048 -e 129024 -c 1996"
# UBI: sub-page size: 512
UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
-# MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules "
MACHINE_FEATURES = "kernel26 screen apm usbgadget usbhost vfat alsa"
diff --git a/conf/machine/include/omap3.inc b/conf/machine/include/omap3.inc
index bb750aad98..e87b56c282 100644
--- a/conf/machine/include/omap3.inc
+++ b/conf/machine/include/omap3.inc
@@ -11,8 +11,6 @@ UBOOT_LOADADDRESS = "0x80008000"
# Only build u-boot, xload is optional
EXTRA_IMAGEDEPENDS += "u-boot"
-MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules "
-
# TI DVSDK stuff:
CODEC_INSTALL_DIR ?= "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-combo"
CODEC ?= "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-combo"
diff --git a/conf/machine/omap3-pandora.conf b/conf/machine/omap3-pandora.conf
index 8729715513..c896fa0b02 100644
--- a/conf/machine/omap3-pandora.conf
+++ b/conf/machine/omap3-pandora.conf
@@ -5,7 +5,6 @@
TARGET_ARCH = "arm"
-MACHINE_EXTRA_RRECOMMENDS = "omap3-sgx-modules "
PREFERRED_PROVIDER_u-boot = "u-boot-omap3pandora"
diff --git a/conf/machine/omap3-touchbook.conf b/conf/machine/omap3-touchbook.conf
index 3595383f03..2839b7ddf6 100644
--- a/conf/machine/omap3-touchbook.conf
+++ b/conf/machine/omap3-touchbook.conf
@@ -45,6 +45,5 @@ UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
PREFERRED_VERSION_u-boot = "git"
-MACHINE_EXTRA_RRECOMMENDS = " rt3070 omap3-sgx-modules "
# and sdio
MACHINE_FEATURES = "kernel26 screen apm usbgadget usbhost vfat alsa touchscreen"
diff --git a/conf/machine/omap3evm.conf b/conf/machine/omap3evm.conf
index ad410fae4c..097904d886 100644
--- a/conf/machine/omap3evm.conf
+++ b/conf/machine/omap3evm.conf
@@ -16,7 +16,6 @@ GUI_MACHINE_CLASS = "smallscreen"
require conf/machine/include/omap3.inc
# Ship all kernel modules
-MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules kernel-modules"
IMAGE_FSTYPES ?= "jffs2 tar.bz2"
EXTRA_IMAGECMD_jffs2 = "-lnp "
diff --git a/conf/machine/omapzoom.conf b/conf/machine/omapzoom.conf
index 4ca164e633..4732f68c98 100644
--- a/conf/machine/omapzoom.conf
+++ b/conf/machine/omapzoom.conf
@@ -52,6 +52,5 @@ UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
PREFERRED_VERSION_u-boot = "git"
#EXTRA_IMAGEDEPENDS += "u-boot x-load"
-#MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules "
# and sdio
MACHINE_FEATURES = "kernel26 touchscreen phone screen apm usbgadget usbhost vfat alsa"
diff --git a/conf/machine/omapzoom2.conf b/conf/machine/omapzoom2.conf
index 7d0a72b5d7..749339faea 100644
--- a/conf/machine/omapzoom2.conf
+++ b/conf/machine/omapzoom2.conf
@@ -50,7 +50,6 @@ UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
PREFERRED_VERSION_u-boot = "git"
#EXTRA_IMAGEDEPENDS += "u-boot x-load"
-#MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules "
MACHINE_EXTRA_RRECOMMENDS = ""
# and sdio
MACHINE_FEATURES = "kernel26 touchscreen phone screen apm usbgadget usbhost vfat alsa"
diff --git a/conf/machine/palmpre.conf b/conf/machine/palmpre.conf
index c7baaedd2d..dccc892472 100644
--- a/conf/machine/palmpre.conf
+++ b/conf/machine/palmpre.conf
@@ -26,6 +26,5 @@ IMAGE_FSTYPES += "tar.bz2"
# Let's keep the following three from the beagleboard machine config
UBOOT_MACHINE = "omap3_beagle_config"
PREFERRED_VERSION_u-boot = "git"
-#MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules "
MACHINE_FEATURES = "kernel26 screen apm usbgadget usbhost vfat alsa phone bluetooth touchscreen keyboard wifi"
diff --git a/recipes/e17/exalt-client_svn.bb b/recipes/e17/exalt-client_svn.bb
new file mode 100644
index 0000000000..469a95554a
--- /dev/null
+++ b/recipes/e17/exalt-client_svn.bb
@@ -0,0 +1,23 @@
+LICENSE = "LGPLv2"
+PV = "0.0.1+svnr${SRCREV}"
+
+require e-module.inc
+
+DEPENDS += "elementary exalt edje-native"
+
+CFLAGS += " -I${STAGING_INCDIR}/exalt -I${STAGING_INCDIR}/exalt_dbus"
+
+do_configure_prepend() {
+ sed -i -e /po/d configure.ac
+ sed -i -e s:\ po::g Makefile.am
+}
+
+FILES_${PN} += "${libdir}/enlightenment/modules/*/*.desktop \
+ ${libdir}/enlightenment/modules/*/*.edj \
+ ${libdir}/enlightenment/modules/*/*/*.so"
+
+FILES_${PN}-static += "${libdir}/enlightenment/modules/*/*/*.a"
+FILES_${PN}-dev += "${libdir}/enlightenment/modules/*/*/*.la"
+FILES_${PN}-dbg += "${libdir}/enlightenment/modules/*/*/.debug"
+
+
diff --git a/recipes/e17/exalt_svn.bb b/recipes/e17/exalt_svn.bb
new file mode 100644
index 0000000000..8868296736
--- /dev/null
+++ b/recipes/e17/exalt_svn.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Exalt is a network manager for the windows manager Enlightenment DR17."
+HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
+
+LICENSE = "LGPLv2"
+DEPENDS = "elementary vpnc wpa-supplicant ecore eet edbus"
+RDEPENDS = "vpnc wpa-supplicant"
+
+PV = "0.9+svnr${SRCREV}"
+
+inherit e
+
+EXTRA_OECONF = " \
+--with-wpa_supplicant=${sbindir}/wpa_supplicant \
+--with-vpnc=${sbindir}/vpnc \
+--with-vpnc-disconnect=${sbindir}/vpnc-disconnect \
+"
+
+do_install_append() {
+ # install dbus config file
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0644 data/daemon/dbus/exalt.conf ${D}${sysconfdir}/dbus-1/system.d/exalt.conf
+
+ # install dbus service file
+ install -d ${D}${datadir}/dbus-1/system-services/
+ install -m 0644 org.e.Exalt.service ${D}${datadir}/dbus-1/system-services/
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/dbus-1"
+
diff --git a/recipes/eglibc/eglibc_2.10.bb b/recipes/eglibc/eglibc_2.10.bb
index d143b0ad0c..2a62fe3828 100644
--- a/recipes/eglibc/eglibc_2.10.bb
+++ b/recipes/eglibc/eglibc_2.10.bb
@@ -3,7 +3,7 @@ require eglibc.inc
DEPENDS += "gperf-native"
FILESPATHPKG =. "eglibc-svn:"
PV = "2.10"
-PR = "${INC_PR}.4"
+PR = "${INC_PR}.5"
SVN_REV="9124"
EGLIBC_BRANCH="eglibc-2_10"
SRC_URI = "svn://svn.eglibc.org/branches;module=eglibc-2_10;rev=${SVN_REV};proto=svn \
diff --git a/recipes/eglibc/eglibc_2.9.bb b/recipes/eglibc/eglibc_2.9.bb
index 3efcb36d37..7a8262783e 100644
--- a/recipes/eglibc/eglibc_2.9.bb
+++ b/recipes/eglibc/eglibc_2.9.bb
@@ -3,7 +3,7 @@ require eglibc.inc
DEPENDS += "gperf-native"
FILESPATHPKG =. "eglibc-svn:"
PV = "2.9"
-PR = "${INC_PR}.5"
+PR = "${INC_PR}.6"
SVN_REV="8690"
EGLIBC_BRANCH="eglibc-2_9"
SRC_URI = "svn://svn.eglibc.org/branches;module=eglibc-2_9;rev=${SVN_REV};proto=svn \
diff --git a/recipes/eglibc/eglibc_svn.bb b/recipes/eglibc/eglibc_svn.bb
index 1a91af88d8..3376839040 100644
--- a/recipes/eglibc/eglibc_svn.bb
+++ b/recipes/eglibc/eglibc_svn.bb
@@ -5,7 +5,7 @@ SRCREV = "9170"
DEFAULT_PREFERENCE = "-1"
FILESPATHPKG =. "eglibc-svn:"
PV = "2.10+svnr${SRCREV}"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
EGLIBC_BRANCH="trunk"
SRC_URI = "svn://svn.eglibc.org;module=trunk \
file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \
diff --git a/recipes/eglibc/files/armv4t-interworking.patch b/recipes/eglibc/files/armv4t-interworking.patch
index 55ee8565d7..6ab306180c 100644
--- a/recipes/eglibc/files/armv4t-interworking.patch
+++ b/recipes/eglibc/files/armv4t-interworking.patch
@@ -40,7 +40,7 @@ Index: libc/ports/sysdeps/unix/sysv/linux/arm/clone.S
#endif
@ pick the function arg and call address off the stack and execute
ldr r0, [sp, #4]
-+#if defined(__ARM_ARCH_V4T__) && defined(__THUMB_INTERWORK__)
++#if defined(__ARM_ARCH_4T__) && defined(__THUMB_INTERWORK__)
+ ldr ip, [sp], #8
+ mov lr, pc
+ bx ip
@@ -51,3 +51,28 @@ Index: libc/ports/sysdeps/unix/sysv/linux/arm/clone.S
@ and we are done, passing the return value through r0
b PLTJMP(HIDDEN_JUMPTARGET(_exit))
+Index: libc/ports/sysdeps/unix/sysv/linux/arm/sysdep.h
+===================================================================
+--- libc.orig/ports/sysdeps/unix/sysv/linux/arm/sysdep.h 2009-09-16 13:58:18.000000000 +0100
++++ libc/ports/sysdeps/unix/sysv/linux/arm/sysdep.h 2009-11-03 19:17:16.000000000 +0000
+@@ -129,6 +129,11 @@
+ DO_RET(lr); \
+ 1: .word C_SYMBOL_NAME(rtld_errno) - 0b - 8;
+ # else
++#if defined(__ARM_ARCH_4T__) && defined(__THUMB_INTERWORK__)
++#define POP_PC ldr lr, [sp], #4; bx lr
++#else
++#define POP_PC ldr pc, [sp], #4
++#endif
+ # define SYSCALL_ERROR_HANDLER \
+ __local_syscall_error: \
+ str lr, [sp, #-4]!; \
+@@ -138,7 +143,7 @@
+ rsb r1, r1, #0; \
+ str r1, [r0]; \
+ mvn r0, #0; \
+- ldr pc, [sp], #4;
++ POP_PC;
+ # endif
+ #else
+ # define SYSCALL_ERROR_HANDLER /* Nothing here; code in sysdep.S is used. */
diff --git a/recipes/exalt/exalt-daemon/init b/recipes/exalt/exalt-daemon/init
deleted file mode 100644
index cbceed1793..0000000000
--- a/recipes/exalt/exalt-daemon/init
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-set -e
-
-#need dbus and hald
-
-start() {
- echo -n "Starting Exalt daemon..."
- start-stop-daemon --start --exec /usr/sbin/exalt-daemon \
- --pidfile /var/run/exaltd.pid
- echo "done."
-}
-
-stop() {
- echo -n "Stopping Exalt daemon..."
- start-stop-daemon --stop --exec /usr/sbin/exalt-daemon \
- --pidfile /var/run/exaltd.pid
- echo "done."
-}
-
-case "$1" in
- start)
- start
- ;;
- stop)
- stop
- ;;
- restart)
- stop
- sleep 2
- start
- ;;
- *)
- echo "Usage: $(basename $0) {start|stop|restart}"
- exit 1
-esac
-
-exit 0
diff --git a/recipes/exalt/exalt-daemon_svn.bb b/recipes/exalt/exalt-daemon_svn.bb
deleted file mode 100644
index 8f5e9afa29..0000000000
--- a/recipes/exalt/exalt-daemon_svn.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require exalt.inc
-
-DEPENDS = "evas edbus libexalt"
-
-SRC_URI += "file://init"
-
-do_install_append() {
- install -D -m 0755 "${WORKDIR}/init" "${D}${sysconfdir}/dbus-1/event.d/40exaltd"
-}
-
-FILES_${PN} += "${sysconfdir}/dbus-1/event.d/"
-
-EXALT_MODULE = "daemon"
diff --git a/recipes/exalt/exalt-module/autotools-fix.patch b/recipes/exalt/exalt-module/autotools-fix.patch
deleted file mode 100644
index 8f3b3deb51..0000000000
--- a/recipes/exalt/exalt-module/autotools-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: module/Makefile.am
-===================================================================
---- module.orig/Makefile.am 2008-04-16 17:39:03.000000000 +0800
-+++ module/Makefile.am 2008-04-16 17:39:05.000000000 +0800
-@@ -26,7 +26,6 @@
- # the module .so file
- INCLUDES = -I. \
- -I$(top_srcdir) \
-- -I$(includedir) \
- @EXALT_CFLAGS@ \
- @e_cflags@
-
diff --git a/recipes/exalt/exalt-module_svn.bb b/recipes/exalt/exalt-module_svn.bb
deleted file mode 100644
index 0a28a1a206..0000000000
--- a/recipes/exalt/exalt-module_svn.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-require exalt.inc
-
-DEPENDS = "edbus libexalt-dbus"
-RDEPENDS_${PN} = "exalt"
-
-SRC_URI += "file://autotools-fix.patch;patch=1;minrev=78"
-
-EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
-
-FILES_${PN} += "${libdir}/enlightenment/modules/module_exalt/*.edj \
- ${libdir}/enlightenment/modules/module_exalt/*/*.so \
- ${libdir}/enlightenment/modules/module_exalt/*.desktop \
- ${libdir}/enlightenment/modules/module_exalt/module_exalt"
-FILES_${PN}-dev += "${libdir}/enlightenment/modules/module_exalt/*/*.a \
- ${libdir}/enlightenment/modules/module_exalt/*/*.la"
-FILES_${PN}-dbg += "${libdir}/enlightenment/modules/module_exalt/*/.debug"
-FILES_${PN}-locale += "${libdir}/enlightenment/modules/module_exalt/locale"
-
-EXALT_MODULE = "module"
diff --git a/recipes/exalt/exalt.inc b/recipes/exalt/exalt.inc
deleted file mode 100644
index 2e82be2d82..0000000000
--- a/recipes/exalt/exalt.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-DESCRIPTION = "Exalt is a network manager for the windows manager Enlightenment DR17."
-AUTHOR = "John Lee <john_lee@openmoko.com>"
-HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
-PV = "0.0.0+svnr${SRCREV}"
-
-SRC_URI = "svn://svn.berlios.de/exalt/trunk;module=${EXALT_MODULE};proto=svn"
-
-S = "${WORKDIR}/${EXALT_MODULE}"
-
-inherit autotools pkgconfig
-
-EXALT_MODULE ?= "${PN}"
diff --git a/recipes/exalt/exalt_svn.bb b/recipes/exalt/exalt_svn.bb
deleted file mode 100644
index 0ed46a2e96..0000000000
--- a/recipes/exalt/exalt_svn.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require exalt.inc
-
-DEPENDS = "ecore etk edbus libexalt libexalt-dbus"
-RDEPENDS_${PN} = "exalt-daemon"
diff --git a/recipes/exalt/libexalt-dbus_svn.bb b/recipes/exalt/libexalt-dbus_svn.bb
deleted file mode 100644
index e40766bfe5..0000000000
--- a/recipes/exalt/libexalt-dbus_svn.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require exalt.inc
-
-DEPENDS = "ecore edbus libexalt"
-
-do_stage() {
- autotools_stage_all
-}
-
-EXALT_MODULE = "libexalt_dbus"
diff --git a/recipes/exalt/libexalt_svn.bb b/recipes/exalt/libexalt_svn.bb
deleted file mode 100644
index cd70d52c77..0000000000
--- a/recipes/exalt/libexalt_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require exalt.inc
-
-DEPENDS = "ecore eet ecore edbus evas wpa-supplicant dhcp"
-RDEPENDS_${PN} = "wpa-supplicant dhclient"
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/recipes/gnome/gnome-themes_2.22.2.bb b/recipes/gnome/gnome-themes_2.22.2.bb
deleted file mode 100644
index 1b45ab4d05..0000000000
--- a/recipes/gnome/gnome-themes_2.22.2.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-LICENSE = "GPL"
-SECTION = "x11/gnome"
-DEPENDS = "gtk-engines icon-naming-utils-native glib-2.0 intltool-native"
-RDEPENDS = "gnome-icon-theme"
-
-EXTRA_OECONF = "--enable-all-themes --disable-hicolor-check"
-
-inherit gnome
-
-PACKAGE_ARCH = "all"
-
-PACKAGES =+ " gtk-engine-crux gtk-engine-hc gtk-engine-lighthouseblue gtk-engine-mist gtk-engine-thinice"
-FILES_gtk-engine-crux = "${libdir}/gtk-2.0/*/engines/libcrux-engine.so"
-FILES_gtk-engine-hc = "${libdir}/gtk-2.0/*/engines/libhcengine.so"
-FILES_gtk-engine-lighthouseblue = "${libdir}/gtk-2.0/*/engines/liblighthouseblue.so"
-FILES_gtk-engine-mist = "${libdir}/gtk-2.0/*/engines/libmist.so"
-FILES_gtk-engine-thinice = "${libdir}/gtk-2.0/*/engines/libthinice.so"
-
-PACKAGES =+ " gnome-theme-crux gnome-theme-grand-canyon gnome-theme-highcontrast gnome-theme-highcontrastinverse gnome-theme-highcontrastlargeprint gnome-theme-highcontrastlargeprintinverse gnome-theme-largeprint gnome-theme-lighthouseblue gnome-theme-mist gnome-theme-traditional"
-FILES_gnome-theme-crux = "${datadir}/themes/Crux ${datadir}/icons/Crux"
-FILES_gnome-theme-grand-canyon = "${datadir}/themes/Grand-Canyon ${datadir}/icons/Grand-Canyon"
-FILES_gnome-theme-highcontrast = "${datadir}/themes/HighContrast ${datadir}/icons/HighContrast"
-FILES_gnome-theme-highcontrastinverse = "${datadir}/themes/HighContrastInverse ${datadir}/icons/HighContrastInverse"
-FILES_gnome-theme-highcontrastlargeprint = "${datadir}/themes/HighContrastLargePrint ${datadir}/icons/HighContrastLargePrint"
-FILES_gnome-theme-highcontrastlargeprintinverse = "${datadir}/themes/HighContrastLargePrintInverse ${datadir}/icons/HighContrastLargePrintInverse"
-FILES_gnome-theme-largeprint = "${datadir}/themes/LargePrint ${datadir}/icons/LargePrint"
-FILES_gnome-theme-lighthouseblue = "${datadir}/themes/LighthouseBlue ${datadir}/icons/LighthouseBlue"
-FILES_gnome-theme-mist = "${datadir}/themes/Mist ${datadir}/icons/Mist"
-FILES_gnome-theme-traditional = "${datadir}/themes/Traditional ${datadir}/icons/Traditional"
-
-FILES_${PN} += "${datadir}/themes ${datadir}/icons"
diff --git a/recipes/gnome/gnome-themes_2.24.0.bb b/recipes/gnome/gnome-themes_2.24.0.bb
deleted file mode 100644
index 1b45ab4d05..0000000000
--- a/recipes/gnome/gnome-themes_2.24.0.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-LICENSE = "GPL"
-SECTION = "x11/gnome"
-DEPENDS = "gtk-engines icon-naming-utils-native glib-2.0 intltool-native"
-RDEPENDS = "gnome-icon-theme"
-
-EXTRA_OECONF = "--enable-all-themes --disable-hicolor-check"
-
-inherit gnome
-
-PACKAGE_ARCH = "all"
-
-PACKAGES =+ " gtk-engine-crux gtk-engine-hc gtk-engine-lighthouseblue gtk-engine-mist gtk-engine-thinice"
-FILES_gtk-engine-crux = "${libdir}/gtk-2.0/*/engines/libcrux-engine.so"
-FILES_gtk-engine-hc = "${libdir}/gtk-2.0/*/engines/libhcengine.so"
-FILES_gtk-engine-lighthouseblue = "${libdir}/gtk-2.0/*/engines/liblighthouseblue.so"
-FILES_gtk-engine-mist = "${libdir}/gtk-2.0/*/engines/libmist.so"
-FILES_gtk-engine-thinice = "${libdir}/gtk-2.0/*/engines/libthinice.so"
-
-PACKAGES =+ " gnome-theme-crux gnome-theme-grand-canyon gnome-theme-highcontrast gnome-theme-highcontrastinverse gnome-theme-highcontrastlargeprint gnome-theme-highcontrastlargeprintinverse gnome-theme-largeprint gnome-theme-lighthouseblue gnome-theme-mist gnome-theme-traditional"
-FILES_gnome-theme-crux = "${datadir}/themes/Crux ${datadir}/icons/Crux"
-FILES_gnome-theme-grand-canyon = "${datadir}/themes/Grand-Canyon ${datadir}/icons/Grand-Canyon"
-FILES_gnome-theme-highcontrast = "${datadir}/themes/HighContrast ${datadir}/icons/HighContrast"
-FILES_gnome-theme-highcontrastinverse = "${datadir}/themes/HighContrastInverse ${datadir}/icons/HighContrastInverse"
-FILES_gnome-theme-highcontrastlargeprint = "${datadir}/themes/HighContrastLargePrint ${datadir}/icons/HighContrastLargePrint"
-FILES_gnome-theme-highcontrastlargeprintinverse = "${datadir}/themes/HighContrastLargePrintInverse ${datadir}/icons/HighContrastLargePrintInverse"
-FILES_gnome-theme-largeprint = "${datadir}/themes/LargePrint ${datadir}/icons/LargePrint"
-FILES_gnome-theme-lighthouseblue = "${datadir}/themes/LighthouseBlue ${datadir}/icons/LighthouseBlue"
-FILES_gnome-theme-mist = "${datadir}/themes/Mist ${datadir}/icons/Mist"
-FILES_gnome-theme-traditional = "${datadir}/themes/Traditional ${datadir}/icons/Traditional"
-
-FILES_${PN} += "${datadir}/themes ${datadir}/icons"
diff --git a/recipes/gnome/gnome-themes_2.6.2.bb b/recipes/gnome/gnome-themes_2.6.2.bb
deleted file mode 100644
index 2c18b59654..0000000000
--- a/recipes/gnome/gnome-themes_2.6.2.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-SECTION = "x11/base"
-LICENSE = "LGPL"
-DESCRIPTION = "GNOME themes"
-
-DEPENDS = "gtk-engines intltool-native"
-
-PACKAGES += " gtk-engine-crux gtk-engine-hc gtk-engine-lighthouseblue gtk-engine-mist gtk-engine-thinice"
-FILES_gtk-engine-crux = "${libdir}/gtk-2.0/*/engines/libcrux-engine.so"
-FILES_gtk-engine-hc = "${libdir}/gtk-2.0/*/engines/libhcengine.so"
-FILES_gtk-engine-lighthouseblue = "${libdir}/gtk-2.0/*/engines/liblighthouseblue.so"
-FILES_gtk-engine-mist = "${libdir}/gtk-2.0/*/engines/libmist.so"
-FILES_gtk-engine-thinice = "${libdir}/gtk-2.0/*/engines/libthinice.so"
-
-PACKAGES += " gnome-theme-crux gnome-theme-grand-canyon gnome-theme-highcontrast gnome-theme-highcontrastinverse gnome-theme-highcontrastlargeprint gnome-theme-highcontrastlargeprintinverse gnome-theme-largeprint gnome-theme-lighthouseblue gnome-theme-mist gnome-theme-traditional"
-FILES_gnome-theme-crux = "${datadir}/themes/Crux"
-FILES_gnome-theme-grand-canyon = "${datadir}/themes/Grand-Canyon"
-FILES_gnome-theme-highcontrast = "${datadir}/themes/HighContrast"
-FILES_gnome-theme-highcontrastinverse = "${datadir}/themes/HighContrastInverse"
-FILES_gnome-theme-highcontrastlargeprint = "${datadir}/themes/HighContrastLargePrint"
-FILES_gnome-theme-highcontrastlargeprintinverse = "${datadir}/themes/HighContrastLargePrintInverse"
-FILES_gnome-theme-largeprint = "${datadir}/themes/LargePrint"
-FILES_gnome-theme-lighthouseblue = "${datadir}/themes/LighthouseBlue"
-FILES_gnome-theme-mist = "${datadir}/themes/Mist"
-FILES_gnome-theme-traditional = "${datadir}/themes/Traditional"
-
-SRC_URI = "${GNOME_MIRROR}/${PN}/2.6/${PN}-${PV}.tar.bz2"
-
-# gcc-3.4 blows up in gtktext with -frename-registers on arm-linux
-CFLAGS := "${@'${CFLAGS}'.replace('-frename-registers', '')}"
-
-inherit autotools
diff --git a/recipes/linux/linux-omap-2.6.29/2.6.29_relocation_1.patch b/recipes/linux/linux-omap-2.6.29/2.6.29_relocation_1.patch
new file mode 100644
index 0000000000..627f03c785
--- /dev/null
+++ b/recipes/linux/linux-omap-2.6.29/2.6.29_relocation_1.patch
@@ -0,0 +1,11 @@
+--- /tmp/elf.h 2009-11-03 20:29:16.000000000 +0100
++++ git/arch/arm/include/asm/elf.h 2009-11-03 20:29:40.000000000 +0100
+@@ -50,6 +50,8 @@
+ #define R_ARM_ABS32 2
+ #define R_ARM_CALL 28
+ #define R_ARM_JUMP24 29
++#define R_ARM_MOVW_ABS_NC 43
++#define R_ARM_MOVT_ABS 44
+
+ /*
+ * These are used to set parameters in the core dumps.
diff --git a/recipes/linux/linux-omap-2.6.29/2.6.29_relocation_2.patch b/recipes/linux/linux-omap-2.6.29/2.6.29_relocation_2.patch
new file mode 100644
index 0000000000..caa8dd533d
--- /dev/null
+++ b/recipes/linux/linux-omap-2.6.29/2.6.29_relocation_2.patch
@@ -0,0 +1,33 @@
+--- /tmp/module.c 2009-11-03 20:30:56.000000000 +0100
++++ git/arch/arm/kernel/module.c 2009-11-03 20:34:33.000000000 +0100
+@@ -83,6 +83,7 @@
+ unsigned long loc;
+ Elf32_Sym *sym;
+ s32 offset;
++ s32 addend;
+
+ offset = ELF32_R_SYM(rel->r_info);
+ if (offset < 0 || offset > (symsec->sh_size / sizeof(Elf32_Sym))) {
+@@ -132,6 +133,22 @@
+ *(u32 *)loc |= offset & 0x00ffffff;
+ break;
+
++ case R_ARM_MOVW_ABS_NC:
++ case R_ARM_MOVT_ABS:
++ offset = sym->st_value;
++
++ addend = ((*(u32 *)loc >> 4) & 0xf000) | (*(u32 *)loc &0xfff);
++ addend = (addend ^ 0x8000) - 0x8000;
++ offset += addend;
++
++ if (ELF32_R_TYPE(rel->r_info) == R_ARM_MOVT_ABS)
++ offset >>= 16;
++
++ *(u32 *)loc &= 0xfff0f000;
++ *(u32 *)loc |= offset & 0xfff;
++ *(u32 *)loc |= (offset & 0xf000) << 4;
++ break;
++
+ default:
+ printk(KERN_ERR "%s: unknown relocation: %u\n",
+ module->name, ELF32_R_TYPE(rel->r_info));
diff --git a/recipes/linux/linux-omap_2.6.29.bb b/recipes/linux/linux-omap_2.6.29.bb
index 465d5adc00..130f9a8f69 100644
--- a/recipes/linux/linux-omap_2.6.29.bb
+++ b/recipes/linux/linux-omap_2.6.29.bb
@@ -166,6 +166,8 @@ SRC_URI_append = " \
file://arch-has-holes.diff;patch=1 \
file://cache/l1cache-shift.patch;patch=1 \
file://cache/copy-page-tweak.patch;patch=1 \
+ file://2.6.29_relocation_1.patch;patch=1 \
+ file://2.6.29_relocation_2.patch;patch=1 \
"
diff --git a/recipes/opencv/opencv-samples_svn.bb b/recipes/opencv/opencv-samples_svn.bb
index 547e668491..2a56d0652c 100644
--- a/recipes/opencv/opencv-samples_svn.bb
+++ b/recipes/opencv/opencv-samples_svn.bb
@@ -9,8 +9,8 @@ DEPENDS = "opencv"
SRC_URI = "svn://opencvlibrary.svn.sourceforge.net/svnroot/opencvlibrary/trunk;module=opencv;proto=https \
"
-SRCREV = "2196"
-PV = "1.0.0+1.1pre1+svnr${SRCREV}"
+SRCREV = "2219"
+PV = "2.0.0+svnr${SRCREV}"
S = "${WORKDIR}/opencv"
diff --git a/recipes/opencv/opencv_svn.bb b/recipes/opencv/opencv_svn.bb
index ab14c58e43..3ed10bc3b1 100644
--- a/recipes/opencv/opencv_svn.bb
+++ b/recipes/opencv/opencv_svn.bb
@@ -11,8 +11,8 @@ DEPENDS = "ffmpeg gtk+ libtool swig swig-native python jpeg zlib libpng tiff gli
SRC_URI = "svn://opencvlibrary.svn.sourceforge.net/svnroot/opencvlibrary/trunk;module=opencv;proto=https \
file://acinclude.m4"
-SRCREV = "2196"
-PV = "1.0.0+1.1pre1+svnr${SRCREV}"
+SRCREV = "2219"
+PV = "2.0.0+svnr${SRCREV}"
S = "${WORKDIR}/opencv"
diff --git a/recipes/u-boot/files/beagleboard/fw_env.config b/recipes/u-boot/files/beagleboard/fw_env.config
index 8fc96f7572..d9112c2256 100644
--- a/recipes/u-boot/files/beagleboard/fw_env.config
+++ b/recipes/u-boot/files/beagleboard/fw_env.config
@@ -4,5 +4,5 @@
# Notice, that the "Number of sectors" is ignored on NOR.
# MTD device name Device offset Env. size Flash sector size Number of sectors
-/dev/mtd2 0x0000 0x20000 0x40000
+/dev/mtd2 0x0000 0x20000 0x20000
diff --git a/recipes/u-boot/u-boot-utils_1.2.0.bb b/recipes/u-boot/u-boot-utils_1.2.0.bb
index 076547eb84..f38ecbe572 100644
--- a/recipes/u-boot/u-boot-utils_1.2.0.bb
+++ b/recipes/u-boot/u-boot-utils_1.2.0.bb
@@ -3,7 +3,7 @@ SECTION = "bootloaders"
PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "mtd-utils"
-PR = "r8"
+PR = "r9"
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
file://fw_env.c.patch;patch=1 \
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 59c0598f97..39d6864a4d 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r33"
+PR ="r34"
FILESPATHPKG =. "u-boot-git:"