aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2010-03-17 14:05:14 -0400
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:26 +0200
commit8c3c49605693fb266418e22a067a2d5a55fbfdc4 (patch)
tree079409de49a876bd92c8e1832a48b9d75a66075c
parentcebcc0abfa75d4e66652b43bda9486d4954985cf (diff)
downloadopenembedded-8c3c49605693fb266418e22a067a2d5a55fbfdc4.tar.gz
ti-codecs-dm365: rework with the new version
Signed-off-by: Denys Dmytriyenko <denis@denix.org> Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/ti/ti-codecs-dm365.inc30
-rw-r--r--recipes/ti/ti-codecs-dm365_1.0.6.bb6
-rw-r--r--recipes/ti/ti-codecs-dm365_3.10.00.02.bb38
3 files changed, 38 insertions, 36 deletions
diff --git a/recipes/ti/ti-codecs-dm365.inc b/recipes/ti/ti-codecs-dm365.inc
deleted file mode 100644
index 88b8e7641f..0000000000
--- a/recipes/ti/ti-codecs-dm365.inc
+++ /dev/null
@@ -1,30 +0,0 @@
-DESCRIPTION = "DM365 Codecs"
-SECTION = "multimedia"
-LICENSE = "TI"
-
-BASE_SRC_URI = "http://install.source.dir.local"
-SRC_URI = "${BASE_SRC_URI}/dm365_codecs_${PV}.tar.gz"
-
-S = "${WORKDIR}/dm365_codecs_${PV}"
-
-require ti-paths.inc
-
-do_compile() {
- echo "Do nothing"
-}
-
-do_install () {
- # install mapdmaq on target
- install -d ${D}/${installdir}/codecs
-}
-
-do_stage() {
- install -d ${CODEC_INSTALL_DIR}
- cp -pPrf ${S}/* ${CODEC_INSTALL_DIR}
-}
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-FILES_${PN} = "${installdir}/codecs"
-INHIBIT_PACKAGE_STRIP = "1"
-INSANE_SKIP_${PN} = True
-
diff --git a/recipes/ti/ti-codecs-dm365_1.0.6.bb b/recipes/ti/ti-codecs-dm365_1.0.6.bb
deleted file mode 100644
index 59f57223a9..0000000000
--- a/recipes/ti/ti-codecs-dm365_1.0.6.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-
-PV = "01_00_06"
-
-require ti-codecs-dm365.inc
-
-
diff --git a/recipes/ti/ti-codecs-dm365_3.10.00.02.bb b/recipes/ti/ti-codecs-dm365_3.10.00.02.bb
new file mode 100644
index 0000000000..d977c10234
--- /dev/null
+++ b/recipes/ti/ti-codecs-dm365_3.10.00.02.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "DM365 Codecs"
+SECTION = "multimedia"
+LICENSE = "TI"
+
+PV = "03_10_00_02"
+
+BASE_SRC_URI = "http://install.source.dir.local"
+SRC_URI = "${BASE_SRC_URI}/dm365_codecs_${PV}.tar.gz;name=dm365codecs \
+ file://mapdmaq"
+
+SRC_URI[dm365codecs.md5sum] = "c6e8715d1a73f43ce4fbcda5c2597a6f"
+SRC_URI[dm365codecs.sha256sum] = "a34320d55cc7abaa8a2f4802db63188b71a15d97a7ca1bebc654be296c030fd9"
+
+S = "${WORKDIR}/dm365_codecs_${PV}"
+
+PROVIDES += "ti-codecs-dm365-server"
+
+require ti-paths.inc
+require ti-staging.inc
+
+do_compile() {
+ echo "Do nothing"
+}
+
+do_install () {
+ install -d ${D}/${installdir}/ti-codecs-server
+ cd ${S}
+
+ install -m 0755 ${WORKDIR}/mapdmaq ${D}/${installdir}/ti-codecs-server
+
+ install -d ${D}${CODEC_INSTALL_DIR_RECIPE}
+ cp -pPrf ${S}/* ${D}${CODEC_INSTALL_DIR_RECIPE}
+}
+
+PACKAGES += "ti-codecs-dm365-server"
+FILES_ti-codecs-dm365-server = "${installdir}/ti-codecs-server/*"
+
+INSANE_SKIP_ti-codecs-dm365-server = True