aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-25 12:45:42 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-25 12:45:42 +0200
commita8f0ed36b9c564f0e8d3ffa498ac4ef93a653c63 (patch)
tree5eca11cce1968c549500da4152e795ebcc825675
parenteba3242f63ea6f092b8bb3ba6a474b26997b99b1 (diff)
downloadopenembedded-a8f0ed36b9c564f0e8d3ffa498ac4ef93a653c63.tar.gz
ti-dmai: add omap3-touchbook support
-rw-r--r--recipes/ti/ti-dmai.inc2
-rw-r--r--recipes/ti/ti-dmai/touchbook-support.patch10
-rw-r--r--recipes/ti/ti-dmai_svn.bb2
3 files changed, 12 insertions, 2 deletions
diff --git a/recipes/ti/ti-dmai.inc b/recipes/ti/ti-dmai.inc
index 8e95cf1b46..e93e9975b5 100644
--- a/recipes/ti/ti-dmai.inc
+++ b/recipes/ti/ti-dmai.inc
@@ -7,10 +7,10 @@ SRC_URI = "svn://gforge.ti.com/svn/dmai/branches;module=BRANCH_BRIJESH_DMAI_DEV_
file://loadmodules-ti-dmai-dm355_al.sh \
file://loadmodules-ti-dmai-dm6446_al.sh \
file://loadmodules-ti-dmai-o3530_al.sh \
+ file://touchbook-support.patch;patch=1 \
"
S = "${WORKDIR}/BRANCH_BRIJESH_DMAI_DEV_2_xx/davinci_multimedia_application_interface"
# Yes, the xdc stuff still breaks with a '.' in PWD
PV = "svnr${SRCREV}"
-PR = "r33"
diff --git a/recipes/ti/ti-dmai/touchbook-support.patch b/recipes/ti/ti-dmai/touchbook-support.patch
new file mode 100644
index 0000000000..a63bb17e7a
--- /dev/null
+++ b/recipes/ti/ti-dmai/touchbook-support.patch
@@ -0,0 +1,10 @@
+--- /tmp/Cpu.c 2009-09-25 12:41:08.000000000 +0200
++++ davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/Cpu.c 2009-09-25 12:41:36.000000000 +0200
+@@ -107,6 +107,7 @@
+ }
+ else if ((strcmp(valBuf,"OMAP3EVM Board") == 0) ||
+ (strcmp(valBuf, "OMAP3 EVM") == 0) ||
++ (strcmp(valBuf, "OMAP3 Touch Book") == 0) ||
+ (strcmp(valBuf, "OMAP3 Beagle Board") == 0)) {
+ *device = Cpu_Device_OMAP3530;
+ }
diff --git a/recipes/ti/ti-dmai_svn.bb b/recipes/ti/ti-dmai_svn.bb
index d94dd61b21..83199e6fed 100644
--- a/recipes/ti/ti-dmai_svn.bb
+++ b/recipes/ti/ti-dmai_svn.bb
@@ -4,7 +4,7 @@ require ti-paths.inc
inherit module-base
#This is a kernel module, don't set PR directly
-MACHINE_KERNEL_PR_append = "a"
+MACHINE_KERNEL_PR_append = "b"
# compile time dependencies
DEPENDS_omap3evm += "alsa-lib ti-codec-engine ti-xdctools-native ti-dspbios-native ti-cgt6x-native ti-cs1-omap3530 virtual/kernel ti-dsplink-module"