aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustus Winter <4winter@informatik.uni-hamburg.de>2010-11-05 18:57:53 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-11-13 11:27:40 +0100
commita928bc53faf24a5a1ff47c1ec7a1c438cfedddd3 (patch)
tree7e4ffe4ef6f8ca43cd03f35794eb93cc6c480391
parent38c0aed8dc69384488f7cc87e15fc95a8daa6a6b (diff)
downloadopenembedded-a928bc53faf24a5a1ff47c1ec7a1c438cfedddd3.tar.gz
mg: new package for Micro GNU/emacs
* mg is Micro GNU/emacs, * this is a portable version of the mg maintained by the OpenBSD team. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/mg/mg_20090107.bb19
-rw-r--r--recipes/mg/patches/000-fix-Makefile.in.patch35
-rw-r--r--recipes/mg/patches/001-initialize-pointer-to-NULL.patch12
3 files changed, 66 insertions, 0 deletions
diff --git a/recipes/mg/mg_20090107.bb b/recipes/mg/mg_20090107.bb
new file mode 100644
index 0000000000..2340f1c4b3
--- /dev/null
+++ b/recipes/mg/mg_20090107.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "mg is Micro GNU/emacs, this is a portable version of the mg maintained by the OpenBSD team"
+HOMEPAGE = "http://homepage.boetes.org/software/mg/"
+LICENSE = "public domain"
+SECTION = "console/editors"
+DEPENDS = "ncurses"
+PR = "r0"
+
+SRC_URI = "http://homepage.boetes.org/software/mg/${PN}-${PV}.tar.gz \
+ file://patches/000-fix-Makefile.in.patch;striplevel=1 \
+ file://patches/001-initialize-pointer-to-NULL.patch;striplevel=1"
+
+SRC_URI[md5sum] = "f25a139da44c3a2f760ffec531bd996e"
+SRC_URI[sha256sum] = "a1702268b2607dacfcc22c5ffd80845113dff5f82b794139c801d875f87ff048"
+
+inherit autotools
+
+do_configure() {
+ ./configure
+}
diff --git a/recipes/mg/patches/000-fix-Makefile.in.patch b/recipes/mg/patches/000-fix-Makefile.in.patch
new file mode 100644
index 0000000000..75c73c4bd7
--- /dev/null
+++ b/recipes/mg/patches/000-fix-Makefile.in.patch
@@ -0,0 +1,35 @@
+diff -r 10f7754e3ab7 Makefile.in
+--- a/Makefile.in Sat Oct 16 02:00:48 2010 +0200
++++ b/Makefile.in Sat Oct 16 02:02:06 2010 +0200
+@@ -7,20 +7,20 @@
+
+ name= mg
+
+-prefix= /usr/local
+-bindir= $(prefix)/bin
+-libdir= $(prefix)/lib
+-includedir= $(prefix)/include
+-mandir= $(prefix)/man
++prefix?= /usr/local
++bindir?= $(prefix)/bin
++libdir?= $(prefix)/lib
++includedir?= $(prefix)/include
++mandir?= $(prefix)/man
+
+
+-CC= gcc
+-CFLAGS?= -O2 -pipe
+-CFLAGS+= -g -Wall -Werror
+-LDFLAGS= -lncurses
++CC?= gcc
++CFLAGS?= -O2 -pipe -g
++CFLAGS+= -Wall -Werror
++LDFLAGS+= -lncurses
+
+-INSTALL= /usr/bin/install
+-STRIP= /usr/bin/strip
++INSTALL?= /usr/bin/install
++STRIP?= /usr/bin/strip
+
+
+ OBJS= autoexec.o \
diff --git a/recipes/mg/patches/001-initialize-pointer-to-NULL.patch b/recipes/mg/patches/001-initialize-pointer-to-NULL.patch
new file mode 100644
index 0000000000..d92e99de17
--- /dev/null
+++ b/recipes/mg/patches/001-initialize-pointer-to-NULL.patch
@@ -0,0 +1,12 @@
+diff -r 245acecec991 extend.c
+--- a/extend.c Sat Oct 16 01:51:01 2010 +0200
++++ b/extend.c Sat Oct 16 01:54:45 2010 +0200
+@@ -707,7 +707,7 @@
+ long nl;
+ #ifdef FKEYS
+ int bind;
+- KEYMAP *curmap;
++ KEYMAP *curmap = NULL;
+ #define BINDARG 0 /* this arg is key to bind (local/global set key) */
+ #define BINDNO 1 /* not binding or non-quoted BINDARG */
+ #define BINDNEXT 2 /* next arg " (define-key) */