aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2010-07-20 08:44:54 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2010-08-16 15:51:55 +0200
commitaefe7a444c34231892653702b622e6e94760bd7b (patch)
treea000b14940dba68c0644cf2aa3d92b074ca8cf36
parent57f89c7392a5643c656321b65c1086534a1c80ec (diff)
downloadopenembedded-aefe7a444c34231892653702b622e6e94760bd7b.tar.gz
lvm2: rebase all recipes on a global lvm2.inc recipe
This rebases all specific versions of lvm2 on a global recipe lvm2.inc which defines the common parameters for building lvm2. Staging is overwritten as we don't need any of the executables or manpages the build of lvm2 produces for any related builds. Signed-off-by: Simon Busch <morphis@gravedo.de>
-rw-r--r--recipes/lvm2/files/crosscompile_fix.patch (renamed from recipes/lvm2/lvm2-2.01.15/crosscompile_fix.patch)0
-rw-r--r--recipes/lvm2/lvm2.inc20
-rw-r--r--recipes/lvm2/lvm2_2.01.09.bb11
-rw-r--r--recipes/lvm2/lvm2_2.01.15.bb17
4 files changed, 24 insertions, 24 deletions
diff --git a/recipes/lvm2/lvm2-2.01.15/crosscompile_fix.patch b/recipes/lvm2/files/crosscompile_fix.patch
index 7f54f80072..7f54f80072 100644
--- a/recipes/lvm2/lvm2-2.01.15/crosscompile_fix.patch
+++ b/recipes/lvm2/files/crosscompile_fix.patch
diff --git a/recipes/lvm2/lvm2.inc b/recipes/lvm2/lvm2.inc
new file mode 100644
index 0000000000..a7e37b5eb2
--- /dev/null
+++ b/recipes/lvm2/lvm2.inc
@@ -0,0 +1,20 @@
+SECTION = "utils"
+DESCRIPTION = "LVM2 is a set of utilities to manage logical volumes in Linux."
+LICENSE = "GPL"
+DEPENDS = "device-mapper"
+INC_PR = "r2"
+
+S = "${WORKDIR}/LVM2.${PV}"
+SRC_URI = "ftp://sources.redhat.com/pub/lvm2/old/LVM2.${PV}.tgz \
+ file://crosscompile_fix.patch"
+
+# Unset user/group to unbreak install.
+EXTRA_OECONF = "--with-user= --with-group= --disable-o_direct"
+EXTRA_OECONF_arm = "--with-user= --with-group= --disable-o_direct"
+
+inherit autotools
+
+# We don't need to stage anything (the executables are no needed at build time by any
+# other recipe)
+do_stage() {
+}
diff --git a/recipes/lvm2/lvm2_2.01.09.bb b/recipes/lvm2/lvm2_2.01.09.bb
index e708d10ee1..9682fa7d03 100644
--- a/recipes/lvm2/lvm2_2.01.09.bb
+++ b/recipes/lvm2/lvm2_2.01.09.bb
@@ -1,15 +1,8 @@
-SECTION = "utils"
-DESCRIPTION = "LVM2 is a set of utilities to manage logical volumes in Linux."
-LICENSE = "GPL"
-PR = "r1"
-DEPENDS = "device-mapper"
+require lvm2.inc
-S = "${WORKDIR}/LVM2.${PV}"
-
-SRC_URI = "ftp://sources.redhat.com/pub/lvm2/old/LVM2.${PV}.tgz"
+PR = "${INC_PR}.0"
SRC_URI[md5sum] = "ed6fe3b734d05c6497cfa4f9932046e6"
SRC_URI[sha256sum] = "f72b5868f8ab4c6d5ba4cd470e33ef8d916e9c6c1363a7ae48aefd9361e5fc90"
-inherit autotools
diff --git a/recipes/lvm2/lvm2_2.01.15.bb b/recipes/lvm2/lvm2_2.01.15.bb
index d66e355b27..0c4d0ea1a9 100644
--- a/recipes/lvm2/lvm2_2.01.15.bb
+++ b/recipes/lvm2/lvm2_2.01.15.bb
@@ -1,19 +1,6 @@
-SECTION = "utils"
-DESCRIPTION = "LVM2 is a set of utilities to manage logical volumes in Linux."
-LICENSE = "GPL"
-PR = "r1"
-DEPENDS = "device-mapper"
-
-S = "${WORKDIR}/LVM2.${PV}"
-
-SRC_URI = "ftp://sources.redhat.com/pub/lvm2/LVM2.${PV}.tgz \
- file://crosscompile_fix.patch"
-
-# Unset user/group to unbreak install.
-EXTRA_OECONF = "--with-user= --with-group= --disable-o_direct"
-EXTRA_OECONF_arm = "--with-user= --with-group= --disable-o_direct"
-inherit autotools
+require lvm2.inc
+PR = "${INC_PR}.0"
SRC_URI[md5sum] = "c71654baff263254fb5a226624ee8ef3"
SRC_URI[sha256sum] = "80b47604ace83db4450f43d94a99fdf2ca317323fde8a591f57290d28ece7d3b"