aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-11-26 08:45:58 +0000
committerKoen Kooi <koen@openembedded.org>2009-12-04 10:43:05 +0100
commitba9ab8c783d196ed16b1b4d64b04ec20845323eb (patch)
treed715e057691562b6b95bea9f519527845e9c75ca
parentc3316cf01d65cb6a41d43a878846ecbafa283685 (diff)
downloadopenembedded-ba9ab8c783d196ed16b1b4d64b04ec20845323eb.tar.gz
libpng: Add target and native recipes for 1.2.40 with checksums.
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/libpng/libpng-native_1.2.40.bb4
-rw-r--r--recipes/libpng/libpng_1.2.40.bb14
3 files changed, 22 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index ef7d82b46c..641632e0d1 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -16018,6 +16018,10 @@ sha256=24b354dcd8843274a20e1625e04d618d43f9851082254cb9dae6f33f15c2a5cd
md5=b8b8d09adf6bee2c5902c8e54c4f2e68
sha256=cafe6431f9e6d561fb7b396bf94ff73a9cd0f4279f3eea2fc714ab90e345eee6
+[http://downloads.sourceforge.net/libpng/libpng-1.2.40.tar.bz2]
+md5=29bbd1c3cbe54b04bfc2bda43067ccb5
+sha256=a6197352ad5b79a9a1ce0dd59f5e737cfbf909e0f3c5f64631cf0d93549e4e40
+
[http://downloads.sourceforge.net/libpng/libpng-1.2.8.tar.bz2]
md5=00cea4539bea4bd34cbf8b82ff9589cd
sha256=9bec729a1e77d8bbc5800b14aa81f09290aa18daa40f344103f2c0d1d681531b
diff --git a/recipes/libpng/libpng-native_1.2.40.bb b/recipes/libpng/libpng-native_1.2.40.bb
new file mode 100644
index 0000000000..52c92e9954
--- /dev/null
+++ b/recipes/libpng/libpng-native_1.2.40.bb
@@ -0,0 +1,4 @@
+require libpng_${PV}.bb
+require libpng-native.inc
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libpng-${PV}"
diff --git a/recipes/libpng/libpng_1.2.40.bb b/recipes/libpng/libpng_1.2.40.bb
new file mode 100644
index 0000000000..3ed02a7f17
--- /dev/null
+++ b/recipes/libpng/libpng_1.2.40.bb
@@ -0,0 +1,14 @@
+require libpng.inc
+
+PR = "r0"
+
+SRC_URI += "file://makefile_fix.patch;patch=1"
+
+do_stage() {
+ cp libpng.pc libpng12.pc
+ install -m 644 png.h ${STAGING_INCDIR}/png.h
+ install -m 644 pngconf.h ${STAGING_INCDIR}/pngconf.h
+ oe_libinstall -so libpng ${STAGING_LIBDIR}/
+ oe_libinstall -so libpng12 ${STAGING_LIBDIR}/
+ ln -sf libpng12.so ${STAGING_LIBDIR}/libpng.so
+}