aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2010-12-16 18:20:41 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2011-01-03 13:55:56 -0200
commitc9d0fef176189e431a2e13e5ff3387c060ff2dd1 (patch)
tree0b71bc5c9554fc7195299d5cc51ea4bc8485d9e6
parentf18bbc75bda8330850b2a3d4cdb828eb35b979fd (diff)
downloadopenembedded-c9d0fef176189e431a2e13e5ff3387c060ff2dd1.tar.gz
hotplug2 (svn): add
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes/hotplug2/hotplug2_svn.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/hotplug2/hotplug2_svn.bb b/recipes/hotplug2/hotplug2_svn.bb
new file mode 100644
index 0000000000..34a90baa51
--- /dev/null
+++ b/recipes/hotplug2/hotplug2_svn.bb
@@ -0,0 +1,31 @@
+# Copyright (C) 2010, O.S. Systems Software Ltda. All Rights Reserved
+# Released under the MIT license
+
+DESCRIPTION = "Hotplug2 is a lightweight udev replacement"
+HOMEPAGE = "http://code.google.com/p/hotplug2/"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+RRECOMMENDS += "udev-utils"
+RPROVIDES_${PN} = "hotplug"
+RREPLACES_${PN} = "udev"
+PV = "1.0+svnr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "svn://hotplug2.googlecode.com/svn;module=trunk;proto=http"
+
+SRCREV = "4"
+S = "${WORKDIR}/trunk"
+
+inherit autotools
+
+PACKAGES_DYNAMIC = "hotplug2-worker-*"
+
+FILES_${PN}-dbg += "${base_libdir}/hotplug2/.debug"
+
+python populate_packages_prepend() {
+ workers = bb.data.expand('${base_libdir}/hotplug2/', d)
+ do_split_packages(d, workers, 'worker_(.*).so$',
+ 'hotplug2-worker-%s', 'Hotplug2 %s worker support',
+ prepend=True)
+}