aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2008-06-03 02:37:09 +0000
committerKhem Raj <raj.khem@gmail.com>2008-06-03 02:37:09 +0000
commit2aa56756ba10e4e38ed5559dc0c9e3665e624ea7 (patch)
tree6c8a0f58de18b570680bf38179a00579bbdf2e74
parentc3ee7c6a2538fca0da2a7e3c3c5709ebcdaa0142 (diff)
downloadopenembedded-2aa56756ba10e4e38ed5559dc0c9e3665e624ea7.tar.gz
Fix an obvious typo in the patch. The variable exported was 'CCP' should have been 'CPP'. I have tested build for gcc-cross-4.2.2 recipe.
-rw-r--r--packages/gcc/gcc-3.4.3/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-3.4.4/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-3.4.6/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-4.0.2/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-4.1.2/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-4.2.1/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-4.2.2/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-4.2.3/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-4.2.4/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-4.3.0/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-cross-kernel-3.4.4_csl-arm-2005q3.bb2
-rw-r--r--packages/gcc/gcc-cross-sdk_3.4.3.bb2
-rw-r--r--packages/gcc/gcc-cross-sdk_4.1.1.bb4
-rw-r--r--packages/gcc/gcc-cross-sdk_4.1.2.bb2
-rw-r--r--packages/gcc/gcc-cross-sdk_4.2.2.bb2
-rw-r--r--packages/gcc/gcc-cross-sdk_4.2.3.bb2
-rw-r--r--packages/gcc/gcc-cross-sdk_4.2.4.bb2
-rw-r--r--packages/gcc/gcc-cross-sdk_4.3.0.bb2
-rw-r--r--packages/gcc/gcc-cross_3.4.3.bb2
-rw-r--r--packages/gcc/gcc-cross_3.4.4.bb2
-rw-r--r--packages/gcc/gcc-cross_4.0.0.bb2
-rw-r--r--packages/gcc/gcc-cross_4.0.2.bb2
-rw-r--r--packages/gcc/gcc-cross_4.1.1.bb2
-rw-r--r--packages/gcc/gcc-cross_4.1.2.bb2
-rw-r--r--packages/gcc/gcc-cross_4.2.1.bb2
-rw-r--r--packages/gcc/gcc-cross_4.2.2.bb2
-rw-r--r--packages/gcc/gcc-cross_4.2.3.bb2
-rw-r--r--packages/gcc/gcc-cross_4.2.4.bb2
-rw-r--r--packages/gcc/gcc-cross_4.3.0.bb2
-rw-r--r--packages/gcc/gcc-cross_csl-arm-2005q3.bb2
-rw-r--r--packages/gcc/gcc-cross_csl-arm-2006q1.bb2
-rw-r--r--packages/gcc/gcc-cross_csl-arm-2007q3.bb2
-rw-r--r--packages/gcc/gcc-cross_csl-arm-2008q1.bb2
-rw-r--r--packages/gcc/gcc-csl-arm/zecke-xgcc-cpp.patch2
-rw-r--r--packages/gcc/gcc-native_3.4.6.bb2
-rw-r--r--packages/gcc/gcc_3.4.3.bb2
-rw-r--r--packages/gcc/gcc_3.4.4.bb2
-rw-r--r--packages/gcc/gcc_4.0.0.bb2
-rw-r--r--packages/gcc/gcc_4.0.2.bb2
-rw-r--r--packages/gcc/gcc_4.1.1.bb2
-rw-r--r--packages/gcc/gcc_4.1.2.bb2
-rw-r--r--packages/gcc/gcc_4.2.1.bb2
-rw-r--r--packages/gcc/gcc_4.2.2.bb2
-rw-r--r--packages/gcc/gcc_4.2.3.bb2
-rw-r--r--packages/gcc/gcc_4.2.4.bb2
-rw-r--r--packages/gcc/gcc_4.3.0.bb2
-rw-r--r--packages/gcc/gcc_csl-arm-2005q3.bb2
-rw-r--r--packages/gcc/gcc_csl-arm-2006q1.bb2
-rw-r--r--packages/gcc/gcc_csl-arm-2007q3.bb2
-rw-r--r--packages/gcc/gcc_csl-arm-2008q1.bb2
52 files changed, 53 insertions, 53 deletions
diff --git a/packages/gcc/gcc-3.4.3/zecke-xgcc-cpp.patch b/packages/gcc/gcc-3.4.3/zecke-xgcc-cpp.patch
index 08e7a3124d..030bdfec96 100644
--- a/packages/gcc/gcc-3.4.3/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-3.4.3/zecke-xgcc-cpp.patch
@@ -9,7 +9,7 @@ Index: gcc-3.4.3/Makefile.in
AS="$(AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
+ CPPFLAGS=""; export CPPFLAGS; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CFLAGS_FOR_TARGET)"; export CPPFLAGS; \
diff --git a/packages/gcc/gcc-3.4.4/zecke-xgcc-cpp.patch b/packages/gcc/gcc-3.4.4/zecke-xgcc-cpp.patch
index ab6a3fd771..ea3dc5f4a0 100644
--- a/packages/gcc/gcc-3.4.4/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-3.4.4/zecke-xgcc-cpp.patch
@@ -6,7 +6,7 @@ Index: gcc-3.4.4/Makefile.in
AS="$(AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
+ CPPFLAGS=""; export CPPFLAGS; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CFLAGS_FOR_TARGET)"; export CPPFLAGS; \
diff --git a/packages/gcc/gcc-3.4.6/zecke-xgcc-cpp.patch b/packages/gcc/gcc-3.4.6/zecke-xgcc-cpp.patch
index ab6a3fd771..ea3dc5f4a0 100644
--- a/packages/gcc/gcc-3.4.6/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-3.4.6/zecke-xgcc-cpp.patch
@@ -6,7 +6,7 @@ Index: gcc-3.4.4/Makefile.in
AS="$(AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
+ CPPFLAGS=""; export CPPFLAGS; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CFLAGS_FOR_TARGET)"; export CPPFLAGS; \
diff --git a/packages/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch
index 436eff02ae..c6ee1577ec 100644
--- a/packages/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch
@@ -6,7 +6,7 @@ Index: gcc-4.0.0/Makefile.in
AS="$(AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.0.2/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.0.2/zecke-xgcc-cpp.patch
index ba7d7257d9..4ab5f43ddd 100644
--- a/packages/gcc/gcc-4.0.2/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.0.2/zecke-xgcc-cpp.patch
@@ -6,7 +6,7 @@ Index: gcc-4.0.2/Makefile.in
AS="$(AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch
index 921cab6e18..3ccd124764 100644
--- a/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch
@@ -10,7 +10,7 @@ Index: gcc-4.1.1/Makefile.in
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.1.2/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.1.2/zecke-xgcc-cpp.patch
index 921cab6e18..3ccd124764 100644
--- a/packages/gcc/gcc-4.1.2/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.1.2/zecke-xgcc-cpp.patch
@@ -10,7 +10,7 @@ Index: gcc-4.1.1/Makefile.in
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.2.1/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.2.1/zecke-xgcc-cpp.patch
index 921cab6e18..3ccd124764 100644
--- a/packages/gcc/gcc-4.2.1/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.2.1/zecke-xgcc-cpp.patch
@@ -10,7 +10,7 @@ Index: gcc-4.1.1/Makefile.in
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.2.2/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.2.2/zecke-xgcc-cpp.patch
index 921cab6e18..3ccd124764 100644
--- a/packages/gcc/gcc-4.2.2/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.2.2/zecke-xgcc-cpp.patch
@@ -10,7 +10,7 @@ Index: gcc-4.1.1/Makefile.in
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.2.3/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.2.3/zecke-xgcc-cpp.patch
index 921cab6e18..3ccd124764 100644
--- a/packages/gcc/gcc-4.2.3/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.2.3/zecke-xgcc-cpp.patch
@@ -10,7 +10,7 @@ Index: gcc-4.1.1/Makefile.in
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.2.4/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.2.4/zecke-xgcc-cpp.patch
index 921cab6e18..3ccd124764 100644
--- a/packages/gcc/gcc-4.2.4/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.2.4/zecke-xgcc-cpp.patch
@@ -10,7 +10,7 @@ Index: gcc-4.1.1/Makefile.in
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.3.0/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.3.0/zecke-xgcc-cpp.patch
index 921cab6e18..3ccd124764 100644
--- a/packages/gcc/gcc-4.3.0/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.3.0/zecke-xgcc-cpp.patch
@@ -10,7 +10,7 @@ Index: gcc-4.1.1/Makefile.in
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-cross-kernel-3.4.4_csl-arm-2005q3.bb b/packages/gcc/gcc-cross-kernel-3.4.4_csl-arm-2005q3.bb
index e4068cbeb4..9b5a2fed2c 100644
--- a/packages/gcc/gcc-cross-kernel-3.4.4_csl-arm-2005q3.bb
+++ b/packages/gcc/gcc-cross-kernel-3.4.4_csl-arm-2005q3.bb
@@ -7,7 +7,7 @@ DEFAULT_PREFERENCE = "-1"
require gcc-cross-initial_csl-arm-2005q3.bb
require gcc-cross-kernel.inc
-PR = "r1"
+PR = "r2"
SRC_URI += "file://gcc-3.4.4-makefile-fix.patch;patch=1"
diff --git a/packages/gcc/gcc-cross-sdk_3.4.3.bb b/packages/gcc/gcc-cross-sdk_3.4.3.bb
index d9f5880c17..1a7faa5b8c 100644
--- a/packages/gcc/gcc-cross-sdk_3.4.3.bb
+++ b/packages/gcc/gcc-cross-sdk_3.4.3.bb
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/packages/gcc/gcc-cross-sdk_4.1.1.bb b/packages/gcc/gcc-cross-sdk_4.1.1.bb
index ee769e034e..5caec0b5a5 100644
--- a/packages/gcc/gcc-cross-sdk_4.1.1.bb
+++ b/packages/gcc/gcc-cross-sdk_4.1.1.bb
@@ -1,8 +1,8 @@
-PR = "r4"
+PR = "r5"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
require gcc-configure-sdk.inc
require gcc-package-sdk.inc
-DEPENDS += "gmp-native mpfr-native" \ No newline at end of file
+DEPENDS += "gmp-native mpfr-native"
diff --git a/packages/gcc/gcc-cross-sdk_4.1.2.bb b/packages/gcc/gcc-cross-sdk_4.1.2.bb
index 616a5831d0..51b99f882a 100644
--- a/packages/gcc/gcc-cross-sdk_4.1.2.bb
+++ b/packages/gcc/gcc-cross-sdk_4.1.2.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/packages/gcc/gcc-cross-sdk_4.2.2.bb b/packages/gcc/gcc-cross-sdk_4.2.2.bb
index 54e7453e69..8057608e0d 100644
--- a/packages/gcc/gcc-cross-sdk_4.2.2.bb
+++ b/packages/gcc/gcc-cross-sdk_4.2.2.bb
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
inherit sdk
diff --git a/packages/gcc/gcc-cross-sdk_4.2.3.bb b/packages/gcc/gcc-cross-sdk_4.2.3.bb
index 7e3a459ea8..54e7453e69 100644
--- a/packages/gcc/gcc-cross-sdk_4.2.3.bb
+++ b/packages/gcc/gcc-cross-sdk_4.2.3.bb
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
inherit sdk
diff --git a/packages/gcc/gcc-cross-sdk_4.2.4.bb b/packages/gcc/gcc-cross-sdk_4.2.4.bb
index e4a1e41138..29ee187785 100644
--- a/packages/gcc/gcc-cross-sdk_4.2.4.bb
+++ b/packages/gcc/gcc-cross-sdk_4.2.4.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
inherit sdk
diff --git a/packages/gcc/gcc-cross-sdk_4.3.0.bb b/packages/gcc/gcc-cross-sdk_4.3.0.bb
index 54e7453e69..8057608e0d 100644
--- a/packages/gcc/gcc-cross-sdk_4.3.0.bb
+++ b/packages/gcc/gcc-cross-sdk_4.3.0.bb
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
inherit sdk
diff --git a/packages/gcc/gcc-cross_3.4.3.bb b/packages/gcc/gcc-cross_3.4.3.bb
index 43d4b76037..8a2aa6a2bd 100644
--- a/packages/gcc/gcc-cross_3.4.3.bb
+++ b/packages/gcc/gcc-cross_3.4.3.bb
@@ -1,4 +1,4 @@
-PR = "r14"
+PR = "r15"
require gcc-${PV}.inc
require gcc-cross.inc
diff --git a/packages/gcc/gcc-cross_3.4.4.bb b/packages/gcc/gcc-cross_3.4.4.bb
index c9b5cc9924..c7a4cfe857 100644
--- a/packages/gcc/gcc-cross_3.4.4.bb
+++ b/packages/gcc/gcc-cross_3.4.4.bb
@@ -1,4 +1,4 @@
-PR = "r9"
+PR = "r10"
require gcc-${PV}.inc
require gcc-cross.inc
diff --git a/packages/gcc/gcc-cross_4.0.0.bb b/packages/gcc/gcc-cross_4.0.0.bb
index 368c82a312..ab990e2f80 100644
--- a/packages/gcc/gcc-cross_4.0.0.bb
+++ b/packages/gcc/gcc-cross_4.0.0.bb
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "r6"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-cross_4.0.2.bb b/packages/gcc/gcc-cross_4.0.2.bb
index 9d035d927b..ddecddb34a 100644
--- a/packages/gcc/gcc-cross_4.0.2.bb
+++ b/packages/gcc/gcc-cross_4.0.2.bb
@@ -1,4 +1,4 @@
-PR = "r11"
+PR = "r12"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-cross_4.1.1.bb b/packages/gcc/gcc-cross_4.1.1.bb
index a40cbc8bef..dafa5fa79d 100644
--- a/packages/gcc/gcc-cross_4.1.1.bb
+++ b/packages/gcc/gcc-cross_4.1.1.bb
@@ -1,4 +1,4 @@
-PR = "r20"
+PR = "r21"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-cross_4.1.2.bb b/packages/gcc/gcc-cross_4.1.2.bb
index 43f21735e7..c9e3279ffc 100644
--- a/packages/gcc/gcc-cross_4.1.2.bb
+++ b/packages/gcc/gcc-cross_4.1.2.bb
@@ -1,4 +1,4 @@
-PR = "r16"
+PR = "r17"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-cross_4.2.1.bb b/packages/gcc/gcc-cross_4.2.1.bb
index daf42672dc..ece545b049 100644
--- a/packages/gcc/gcc-cross_4.2.1.bb
+++ b/packages/gcc/gcc-cross_4.2.1.bb
@@ -1,4 +1,4 @@
-PR = "r16"
+PR = "r17"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-cross_4.2.2.bb b/packages/gcc/gcc-cross_4.2.2.bb
index dc3ee94a52..816eddba19 100644
--- a/packages/gcc/gcc-cross_4.2.2.bb
+++ b/packages/gcc/gcc-cross_4.2.2.bb
@@ -1,4 +1,4 @@
-PR = "r9"
+PR = "r10"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-cross_4.2.3.bb b/packages/gcc/gcc-cross_4.2.3.bb
index 11e04594fc..72f72835c3 100644
--- a/packages/gcc/gcc-cross_4.2.3.bb
+++ b/packages/gcc/gcc-cross_4.2.3.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-cross_4.2.4.bb b/packages/gcc/gcc-cross_4.2.4.bb
index 68c4d70551..036ebd96b0 100644
--- a/packages/gcc/gcc-cross_4.2.4.bb
+++ b/packages/gcc/gcc-cross_4.2.4.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-cross_4.3.0.bb b/packages/gcc/gcc-cross_4.3.0.bb
index 11e04594fc..72f72835c3 100644
--- a/packages/gcc/gcc-cross_4.3.0.bb
+++ b/packages/gcc/gcc-cross_4.3.0.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-cross_csl-arm-2005q3.bb b/packages/gcc/gcc-cross_csl-arm-2005q3.bb
index 5085855010..8726500ce2 100644
--- a/packages/gcc/gcc-cross_csl-arm-2005q3.bb
+++ b/packages/gcc/gcc-cross_csl-arm-2005q3.bb
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
require gcc-csl-arm-2005q3.inc
require gcc-cross.inc
diff --git a/packages/gcc/gcc-cross_csl-arm-2006q1.bb b/packages/gcc/gcc-cross_csl-arm-2006q1.bb
index 29231920bb..45ace68af9 100644
--- a/packages/gcc/gcc-cross_csl-arm-2006q1.bb
+++ b/packages/gcc/gcc-cross_csl-arm-2006q1.bb
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
require gcc-csl-arm-2006q1.inc
require gcc-cross.inc
diff --git a/packages/gcc/gcc-cross_csl-arm-2007q3.bb b/packages/gcc/gcc-cross_csl-arm-2007q3.bb
index 4fde67b006..cd10cfbdef 100644
--- a/packages/gcc/gcc-cross_csl-arm-2007q3.bb
+++ b/packages/gcc/gcc-cross_csl-arm-2007q3.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
require gcc-csl-arm-2007q3.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-cross_csl-arm-2008q1.bb b/packages/gcc/gcc-cross_csl-arm-2008q1.bb
index 85fcaecec7..01b5bdacc4 100644
--- a/packages/gcc/gcc-cross_csl-arm-2008q1.bb
+++ b/packages/gcc/gcc-cross_csl-arm-2008q1.bb
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "r2"
require gcc-csl-arm-2008q1.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-csl-arm/zecke-xgcc-cpp.patch b/packages/gcc/gcc-csl-arm/zecke-xgcc-cpp.patch
index 921cab6e18..3ccd124764 100644
--- a/packages/gcc/gcc-csl-arm/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-csl-arm/zecke-xgcc-cpp.patch
@@ -10,7 +10,7 @@ Index: gcc-4.1.1/Makefile.in
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-native_3.4.6.bb b/packages/gcc/gcc-native_3.4.6.bb
index 6f74a1ea46..5f39f1bbb3 100644
--- a/packages/gcc/gcc-native_3.4.6.bb
+++ b/packages/gcc/gcc-native_3.4.6.bb
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_3.4.3.bb b/packages/gcc/gcc_3.4.3.bb
index 1e68af5d22..0f31362dc1 100644
--- a/packages/gcc/gcc_3.4.3.bb
+++ b/packages/gcc/gcc_3.4.3.bb
@@ -1,4 +1,4 @@
-PR = "r14"
+PR = "r15"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_3.4.4.bb b/packages/gcc/gcc_3.4.4.bb
index ff7cb7e57b..7ec84b6012 100644
--- a/packages/gcc/gcc_3.4.4.bb
+++ b/packages/gcc/gcc_3.4.4.bb
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "r9"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_4.0.0.bb b/packages/gcc/gcc_4.0.0.bb
index 2df12ef9ef..9fd2b0acc3 100644
--- a/packages/gcc/gcc_4.0.0.bb
+++ b/packages/gcc/gcc_4.0.0.bb
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_4.0.2.bb b/packages/gcc/gcc_4.0.2.bb
index ff7cb7e57b..7ec84b6012 100644
--- a/packages/gcc/gcc_4.0.2.bb
+++ b/packages/gcc/gcc_4.0.2.bb
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "r9"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_4.1.1.bb b/packages/gcc/gcc_4.1.1.bb
index 9dbfca57c0..9e23eb8af7 100644
--- a/packages/gcc/gcc_4.1.1.bb
+++ b/packages/gcc/gcc_4.1.1.bb
@@ -1,4 +1,4 @@
-PR = "r20"
+PR = "r21"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_4.1.2.bb b/packages/gcc/gcc_4.1.2.bb
index da1ecb9b17..a8c8b71648 100644
--- a/packages/gcc/gcc_4.1.2.bb
+++ b/packages/gcc/gcc_4.1.2.bb
@@ -1,4 +1,4 @@
-PR = "r12"
+PR = "r13"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_4.2.1.bb b/packages/gcc/gcc_4.2.1.bb
index c51eb23b05..da1ecb9b17 100644
--- a/packages/gcc/gcc_4.2.1.bb
+++ b/packages/gcc/gcc_4.2.1.bb
@@ -1,4 +1,4 @@
-PR = "r11"
+PR = "r12"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_4.2.2.bb b/packages/gcc/gcc_4.2.2.bb
index 556fc74267..a2ae0c0e92 100644
--- a/packages/gcc/gcc_4.2.2.bb
+++ b/packages/gcc/gcc_4.2.2.bb
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_4.2.3.bb b/packages/gcc/gcc_4.2.3.bb
index 7238aed4d7..556fc74267 100644
--- a/packages/gcc/gcc_4.2.3.bb
+++ b/packages/gcc/gcc_4.2.3.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_4.2.4.bb b/packages/gcc/gcc_4.2.4.bb
index f191a18f3a..ff100fd892 100644
--- a/packages/gcc/gcc_4.2.4.bb
+++ b/packages/gcc/gcc_4.2.4.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_4.3.0.bb b/packages/gcc/gcc_4.3.0.bb
index 033f33f8d3..318ccd3775 100644
--- a/packages/gcc/gcc_4.3.0.bb
+++ b/packages/gcc/gcc_4.3.0.bb
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_csl-arm-2005q3.bb b/packages/gcc/gcc_csl-arm-2005q3.bb
index 2df12ef9ef..9fd2b0acc3 100644
--- a/packages/gcc/gcc_csl-arm-2005q3.bb
+++ b/packages/gcc/gcc_csl-arm-2005q3.bb
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_csl-arm-2006q1.bb b/packages/gcc/gcc_csl-arm-2006q1.bb
index 4999c6a53e..cc7540af15 100644
--- a/packages/gcc/gcc_csl-arm-2006q1.bb
+++ b/packages/gcc/gcc_csl-arm-2006q1.bb
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_csl-arm-2007q3.bb b/packages/gcc/gcc_csl-arm-2007q3.bb
index d610713177..832167ca4e 100644
--- a/packages/gcc/gcc_csl-arm-2007q3.bb
+++ b/packages/gcc/gcc_csl-arm-2007q3.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_csl-arm-2008q1.bb b/packages/gcc/gcc_csl-arm-2008q1.bb
index d610713177..832167ca4e 100644
--- a/packages/gcc/gcc_csl-arm-2008q1.bb
+++ b/packages/gcc/gcc_csl-arm-2008q1.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
require gcc-${PV}.inc
require gcc-configure-target.inc