aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-01-28 17:30:18 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-01-28 17:30:18 +0000
commit93cab50a8ce6dfb50de1eab23ee3fc853ec1278e (patch)
tree6e33e19e4f39f402ef01ac09af99405944ae9eb5
parentda167524cbbf97a0d67b7f275bb95d44c4a2db54 (diff)
downloadopenembedded-93cab50a8ce6dfb50de1eab23ee3fc853ec1278e.tar.gz
mysql: Provide config cache for ps checks:
* Scripts need target ps, not build host ps. * It makes possible to build it on host chroots without /proc mounted.
-rw-r--r--packages/mysql/files/configure-ps-cache-check.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/mysql/files/configure-ps-cache-check.patch b/packages/mysql/files/configure-ps-cache-check.patch
new file mode 100644
index 0000000000..3b5b3fd063
--- /dev/null
+++ b/packages/mysql/files/configure-ps-cache-check.patch
@@ -0,0 +1,27 @@
+Index: mysql-4.1.22/configure.in
+===================================================================
+--- mysql-4.1.22.orig/configure.in 2009-01-28 16:33:28.000000000 +0000
++++ mysql-4.1.22/configure.in 2009-01-28 16:43:26.000000000 +0000
+@@ -471,8 +471,8 @@
+
+ # Lock for PS
+ AC_PATH_PROG(PS, ps, ps)
+-AC_MSG_CHECKING("how to check if pid exists")
+-PS=$ac_cv_path_PS
++AC_CACHE_CHECK([how to check if pid exists], [ac_cv_FIND_PROC],
++[
+ # Linux style
+ if $PS p $$ 2> /dev/null | grep $0 > /dev/null
+ then
+@@ -511,8 +511,9 @@
+ AC_MSG_ERROR([Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual.])
+ esac
+ fi
+-AC_SUBST(FIND_PROC)
+-AC_MSG_RESULT("$FIND_PROC")
++ac_cv_FIND_PROC="$FIND_PROC"
++])
++AC_SUBST([FIND_PROC], [$ac_cv_FIND_PROC])
+
+ # Check if a pid is valid
+ AC_PATH_PROG(KILL, kill, kill)