aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-12-11 13:11:16 +0000
committerKoen Kooi <koen@openembedded.org>2007-12-11 13:11:16 +0000
commitaf52482a8bb96828926d46cd5a6300b46d38cb88 (patch)
treea01697a12e7be97239f6703dd38b313c3c1790f2
parent53a0e5bd875136f23bbc08ae926d2bf9f91ea247 (diff)
downloadopenembedded-af52482a8bb96828926d46cd5a6300b46d38cb88.tar.gz
mysql: workaround two problems:
* mysql dislikes parallel compilation, so set PARALLEL_MAKE = "" * the mysql-native helper binaries reference ${WORKDIR}, so implement a custom, empty do_rm_work() method This will need further thought when packaged-staging(2) is used
-rw-r--r--packages/mysql/mysql-native_4.1.18.bb8
-rw-r--r--packages/mysql/mysql_4.1.18.bb1
2 files changed, 8 insertions, 1 deletions
diff --git a/packages/mysql/mysql-native_4.1.18.bb b/packages/mysql/mysql-native_4.1.18.bb
index 9a81bc8f00..83f9dac0e3 100644
--- a/packages/mysql/mysql-native_4.1.18.bb
+++ b/packages/mysql/mysql-native_4.1.18.bb
@@ -1,7 +1,7 @@
SECTION = "console/network"
require mysql_${PV}.bb
inherit native
-PR="r3"
+PR="r4"
RDEPENDS_${PN} = ""
@@ -17,3 +17,9 @@ do_stage_append() {
do_install() {
:
}
+
+
+# Mysql tries to access the ${WORKDIR} from this build..
+do_rm_work() {
+ :
+}
diff --git a/packages/mysql/mysql_4.1.18.bb b/packages/mysql/mysql_4.1.18.bb
index 17fa33ac1c..b509b81311 100644
--- a/packages/mysql/mysql_4.1.18.bb
+++ b/packages/mysql/mysql_4.1.18.bb
@@ -23,6 +23,7 @@ INITSCRIPT_PACKAGES = "mysql-server"
INITSCRIPT_NAME = "mysqld"
INITSCRIPT_PARAMS = "start 45 S . stop 45 0 6 1 ."
+PARALLEL_MAKE = " "
EXTRA_OEMAKE = "'GEN_LEX_HASH=${STAGING_BINDIR_NATIVE}/gen_lex_hash'"
EXTRA_OECONF = " --with-embedded-server --prefix=/usr --sysconfdir=/etc/mysql --localstatedir=/var/mysql --datadir=/var/mysql --disable-dependency-tracking --without-raid --without-debug --with-low-memory --without-query-cache --without-man --without-docs --without-innodb "