aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-02-22 22:15:02 +0100
committerJan Luebbe <jluebbe@debian.org>2009-03-25 15:58:53 +0100
commit1bde65f76497472b6c5efc03ee1b68fcbc9e98d9 (patch)
treeb3fcf821bc40e4c5c9f9f9ff5dba509ae58b333b
parent35c4ca47ee942ead5e6180926d6ac47929d73b94 (diff)
downloadopenembedded-1bde65f76497472b6c5efc03ee1b68fcbc9e98d9.tar.gz
cellhunter: Add new recipe. Game that collects GSM cell tower locations.
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/cellhunter/cellhunter_0.3.1.bb25
2 files changed, 29 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 9ade7dfd5b..2db3fb4fdb 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -3346,6 +3346,10 @@ sha256=f33cbb551e494747b76bfbeba3954b4839fe7c849f200746fd7dc21bd665aa56
md5=7b19b6f68d2c648296378b784d5f7681
sha256=73de81ea2de2eae64b888e1b2739ef643ccea13c79790569f8e6278369976a21
+[http://78.47.116.33/~hole/cellhunter/files/cellhunter-0.3.1.tar.gz]
+md5=b034b7ae3182794c57552a183d6f3542
+sha256=b8b6277b2f211666877b5022bed12809cc88e96a4a2138c0ff4bbf14167a6765
+
[http://pub.risujin.org/cellwriter/cellwriter-1.3.3.tar.gz]
md5=09b2019e926d5ef42d52edb2dd33ceae
sha256=3fb7c11ec5d802338a0bf522b11702c37820597c9a2c36f89b52872c6571e602
diff --git a/recipes/cellhunter/cellhunter_0.3.1.bb b/recipes/cellhunter/cellhunter_0.3.1.bb
new file mode 100644
index 0000000000..dd2d071846
--- /dev/null
+++ b/recipes/cellhunter/cellhunter_0.3.1.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "CellHunter - A game to collect information about mobile phone cells"
+SECTION = "x11/utils"
+DEPENDS = "python python-dbus python-pygobject python-pygtk"
+RDEPENDS = "python-subprocess python-netclient python-math python-core python-io"
+PR = "r0"
+
+SRC_URI = "http://78.47.116.33/~hole/cellhunter/files/cellhunter-${PV}.tar.gz"
+
+do_configure () {
+ :
+}
+
+do_compile () {
+ :
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 cellhunter.py ${D}${bindir}/
+ install -m 0755 cellhunter_upload.sh ${D}${bindir}/
+ install -d ${D}${datadir}/pixmaps
+ install -d ${D}${datadir}/applications
+ install -m 0644 cellhunter.desktop ${D}${datadir}/applications/cellhunter.desktop
+ install -m 0644 cellhunter.png ${D}${datadir}/pixmaps/cellhunter.png
+}