aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-03-03 19:47:44 +0100
committerJan Luebbe <jluebbe@debian.org>2009-03-25 15:59:02 +0100
commit68aa4c88819a22c97808fe9eefdba9e7497667bd (patch)
tree25a346dd8540c99a006e9c249dc52143dd857970
parentde3e82a1eed855e672595424e176b61bab4d49f1 (diff)
downloadopenembedded-68aa4c88819a22c97808fe9eefdba9e7497667bd.tar.gz
openbmap-logger: Logger for GSM celltowers.
Really ugly recipe. Need to poke the author using distutils or similar.
-rw-r--r--recipes/openbmap/openbmap-logger_0.1.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/openbmap/openbmap-logger_0.1.0.bb b/recipes/openbmap/openbmap-logger_0.1.0.bb
new file mode 100644
index 0000000000..cc83cf7740
--- /dev/null
+++ b/recipes/openbmap/openbmap-logger_0.1.0.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "openBmap logger and uploader of GPS/GSM data"
+SECTION = "x11/utils"
+DEPENDS = "python python-dbus python-pygobject python-pygtk libglade"
+RDEPENDS = "python-subprocess python-netclient python-math python-core python-io"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/myposition/openbmap-logger-${PV}.tar.gz"
+
+FILES_${PN} += "${datadir}/openBmap/* ${libdir}/python2.6/site-packages/openbmap/*"
+
+do_configure () {
+ :
+}
+
+do_compile () {
+ :
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 openBmapGTK ${D}${bindir}/
+ install -d ${D}${libdir}/python2.6/site-packages/openbmap/
+ install -m 0644 __init__.py ${D}${libdir}/python2.6/site-packages/openbmap/
+ install -m 0644 logger.py ${D}${libdir}/python2.6/site-packages/openbmap/
+ install -m 0644 Upload.py ${D}${libdir}/python2.6/site-packages/openbmap/
+ install -d ${D}${datadir}/pixmaps
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/openBmap
+ install -m 0644 openBmap.desktop ${D}${datadir}/applications/openBmap.desktop
+ install -m 0644 openBmap-desktop.png ${D}${datadir}/pixmaps/openBmap-desktop.png
+ install -m 0644 ExitButton.png ${D}${datadir}/openBmap/ExitButton.png
+ install -m 0644 GenerateButton.png ${D}${datadir}/openBmap/GenerateButton.png
+ install -m 0644 StopButton.png ${D}${datadir}/openBmap/StopButton.png
+ install -m 0644 UploadButton.png ${D}${datadir}/openBmap/UploadButton.png
+ install -m 0644 Main.glade ${D}${datadir}/openBmap/Main.glade
+}
+