aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Lübbe <jluebbe@debian.org>2009-02-23 14:28:39 +0000
committerJan Luebbe <jluebbe@debian.org>2009-03-25 15:58:56 +0100
commit85b5d8cc56341395578a71105e6b537d73076e10 (patch)
treec4b39384f5a99689fc4462aa6791cfd06c82c0b1
parentd466e6d3d60aee01632da7a2b10bf52bf3863d88 (diff)
downloadopenembedded-85b5d8cc56341395578a71105e6b537d73076e10.tar.gz
pycd: add recipe
-rw-r--r--conf/distro/include/fso-autorev.inc1
-rw-r--r--conf/distro/include/sane-srcrevs.inc1
-rw-r--r--recipes/freesmartphone/pycd_git.bb31
3 files changed, 33 insertions, 0 deletions
diff --git a/conf/distro/include/fso-autorev.inc b/conf/distro/include/fso-autorev.inc
index d0b3a77d08..fbad8fb891 100644
--- a/conf/distro/include/fso-autorev.inc
+++ b/conf/distro/include/fso-autorev.inc
@@ -20,4 +20,5 @@ SRCREV_pn-libgsm0710mux = "${AUTOREV}"
SRCREV_pn-mickeydbus = "${AUTOREV}"
SRCREV_pn-mickeyterm = "${AUTOREV}"
SRCREV_pn-python-pytrc = "${AUTOREV}"
+SRCREV_pn-pycd = "${AUTOREV}"
SRCREV_pn-zhone = "${AUTOREV}"
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index d23172a25d..b43170ecc1 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -195,6 +195,7 @@ SRCREV_pn-paroli ?= "7a2fdc16174258e9276e7c2d80f500b4dd624442"
SRCREV_pn-portaudio-v19 ?= "1387"
SRCREV_pn-psplash ?= "249"
SRCREV_pn-pty-forward-native ?= "4907"
+SRCREV_pn-pycd ?= "41bcdfdfa6087797026d1337e927ba2cc4d6763f"
SRCREV_pn-pyefl-sudoku ?= "49"
SRCREV_pn-pygsm ?= "976477f6b403f422b4ea730f71ebf409f6671141"
SRCREV_pn-pylgrim ?= "20"
diff --git a/recipes/freesmartphone/pycd_git.bb b/recipes/freesmartphone/pycd_git.bb
new file mode 100644
index 0000000000..3ed2b75292
--- /dev/null
+++ b/recipes/freesmartphone/pycd_git.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Python Clone Factory"
+AUTHOR = "Jan Luebbe <jluebbe@debian.org>"
+HOMEPAGE = "http://www.freesmartphone.org"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PV = "0.1+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+RDEPENDS_${PN} = "\
+ python-dbus \
+ python-misc \
+ python-pkgutil \
+ python-resource \
+"
+
+do_compile() {
+ ${CC} pyc.c -o pyc
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 pyc ${D}${bindir}/pyc
+ install -d ${D}${sbindir}
+ install -m 755 pycd.py ${D}${sbindir}/pycd
+ install -d ${D}${sysconfdir}/dbus-1
+ install -m 644 pycd.conf ${D}${sysconfdir}/dbus-1
+}
+