aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2009-08-10 13:09:16 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-11 03:11:50 +0200
commit16e1b32d6991d551c5f86c588669de4521dad4b9 (patch)
tree7ad478256f14f3179f4823c637d82a8f0838f8d0
parentd89b57a97535a8a8d7078754aa404a2d6b7fab05 (diff)
downloadopenembedded-16e1b32d6991d551c5f86c588669de4521dad4b9.tar.gz
qt4: Make it possible to set the QMAKE_QT_CONFIG variable
this way we will find the qconfig.pri and all library names will be set correctly. This means that the SDK is usable to compile Qt applications out of the box.
-rw-r--r--recipes/meta/meta-toolchain-qte.bb1
-rw-r--r--recipes/qt4/files/g++.conf3
2 files changed, 4 insertions, 0 deletions
diff --git a/recipes/meta/meta-toolchain-qte.bb b/recipes/meta/meta-toolchain-qte.bb
index 463b855ba6..52fd2795e2 100644
--- a/recipes/meta/meta-toolchain-qte.bb
+++ b/recipes/meta/meta-toolchain-qte.bb
@@ -23,6 +23,7 @@ do_populate_sdk_append() {
echo 'export OE_QMAKE_RCC=${prefix}/bin/rcc4' >> $script
echo 'export OE_QMAKE_QDBUSCPP2XML=${prefix}/bin/qdbuscpp2xml4' >> $script
echo 'export OE_QMAKE_QDBUSXML2CPP=${prefix}/bin/qdbusxml2cpp4' >> $script
+ echo 'export OE_QMAKE_QT_CONFIG=${prefix}/${TARGET_SYS}/${layout_datadir}/${QT_DIR_NAME}/mkspecs/qconfig.pri' >> $script
# Repack SDK with new environment-setup
cd ${SDK_OUTPUT}
diff --git a/recipes/qt4/files/g++.conf b/recipes/qt4/files/g++.conf
index f1be0adc75..4cd76e62ea 100644
--- a/recipes/qt4/files/g++.conf
+++ b/recipes/qt4/files/g++.conf
@@ -48,3 +48,6 @@ QMAKE_PCH_OUTPUT_EXT = .gch
# -Bsymbolic-functions (ld) support
QMAKE_LFLAGS_BSYMBOLIC_FUNC = -Wl,-Bsymbolic-functions
QMAKE_LFLAGS_DYNAMIC_LIST = -Wl,--dynamic-list,
+
+# for the SDK
+isEmpty(QMAKE_QT_CONFIG):QMAKE_QT_CONFIG = $(OE_QMAKE_QT_CONFIG)