aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-18 09:54:32 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-18 09:54:32 +0200
commit544b12de7343f1f56785d90b5201affe22e2ba8f (patch)
tree72e2a58d6a70ee7068461e71b57991711fa3b319
parent75a3dc0f45c6c6f402dad71e4e8c808c644ca63e (diff)
parente969734008bf6c558618dda87c07a03a27f3e76c (diff)
downloadopenembedded-544b12de7343f1f56785d90b5201affe22e2ba8f.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
-rw-r--r--recipes/linux/linux-2.6.29+2.6.30-rc4/tx25/stk5-baseboard_c_vesa640.patch40
-rw-r--r--recipes/linux/linux_2.6.29+2.6.30-rc4.bb6
-rw-r--r--recipes/opie-taskbar/opie-taskbar.inc1
-rw-r--r--recipes/opie-taskbar/opie-taskbar/server-pro-1.2.4.patch67
-rw-r--r--recipes/opie-taskbar/opie-taskbar/server-pro-old.patch76
-rw-r--r--recipes/opie-taskbar/opie-taskbar/server.pro84
-rw-r--r--recipes/opie-taskbar/opie-taskbar_1.2.2.bb4
-rw-r--r--recipes/opie-taskbar/opie-taskbar_1.2.3.bb4
-rw-r--r--recipes/opie-taskbar/opie-taskbar_1.2.4.bb4
-rw-r--r--recipes/opie-taskbar/opie-taskbar_cvs.bb3
10 files changed, 194 insertions, 95 deletions
diff --git a/recipes/linux/linux-2.6.29+2.6.30-rc4/tx25/stk5-baseboard_c_vesa640.patch b/recipes/linux/linux-2.6.29+2.6.30-rc4/tx25/stk5-baseboard_c_vesa640.patch
new file mode 100644
index 0000000000..c3eb357dda
--- /dev/null
+++ b/recipes/linux/linux-2.6.29+2.6.30-rc4/tx25/stk5-baseboard_c_vesa640.patch
@@ -0,0 +1,40 @@
+--- a/arch/arm/mach-mx2/stk5-baseboard.c.orig 2009-07-17 00:57:10.000000000 +0200
++++ b/arch/arm/mach-mx2/stk5-baseboard.c 2009-07-16 13:02:20.000000000 +0200
+@@ -613,6 +613,37 @@
+
+ static struct imx_fb_platform_data stk5_fb_data[] __initdata = {
+ {
++ /* VESA 640x480@60 */
++ .init = stk5_gpio_lcdc_active,
++ .exit = stk5_gpio_lcdc_inactive,
++ .lcd_power = NULL,
++ .backlight_power = NULL,
++
++ .pixclock = 39721,
++
++ .xres = 640,
++ .yres = 480,
++
++ .bpp = 16,
++
++ .hsync_len = 64,
++ .right_margin = 24,
++ .left_margin = 40,
++
++ .vsync_len = 2,
++ .lower_margin = 11,
++ .upper_margin = 32,
++
++ .pcr = PCR_TFT | PCR_COLOR | PCR_PBSIZ_8 |
++ PCR_BPIX_16 | PCR_FLMPOL | PCR_LPPOL | PCR_SCLK_SEL,
++ .dmacr = 0x80040060,
++
++ .cmap_greyscale = 0,
++ .cmap_inverse = 0,
++ .cmap_static = 0,
++
++ .fixed_screen_cpu = NULL,
++ }, {
+ #if 1
+ //.fb_mode = "Xenarc_700_Y-18",
+ .init = stk5_gpio_lcdc_active,
diff --git a/recipes/linux/linux_2.6.29+2.6.30-rc4.bb b/recipes/linux/linux_2.6.29+2.6.30-rc4.bb
index d014298dc2..0217587661 100644
--- a/recipes/linux/linux_2.6.29+2.6.30-rc4.bb
+++ b/recipes/linux/linux_2.6.29+2.6.30-rc4.bb
@@ -3,7 +3,7 @@ require linux.inc
KERNEL_RELEASE = "2.6.30-rc4"
OLD_KERNEL_RELEASE = "2.6.29"
PV = "${OLD_KERNEL_RELEASE}+${KERNEL_RELEASE}"
-PR = "r4"
+PR = "r5"
S = "${WORKDIR}/linux-${OLD_KERNEL_RELEASE}"
@@ -32,5 +32,5 @@ SRC_URI_append_afeb9260 = " \
"
SRC_URI_append_tx25 = " file://linux-2.6.30-rc4-git.patch;patch=1 \
- file://linux-2.6.30-rc4-karo3.diff;patch=1"
-
+ file://linux-2.6.30-rc4-karo3.diff;patch=1 \
+ file://stk5-baseboard_c_vesa640.patch;patch=1"
diff --git a/recipes/opie-taskbar/opie-taskbar.inc b/recipes/opie-taskbar/opie-taskbar.inc
index 4f43e550b9..3d8ca17b7f 100644
--- a/recipes/opie-taskbar/opie-taskbar.inc
+++ b/recipes/opie-taskbar/opie-taskbar.inc
@@ -17,7 +17,6 @@ inherit opie
do_configure_prepend() {
ln -s ${WORKDIR}/calibrate ${S}/calibrate
ln -s ${WORKDIR}/mediummount ${S}/mediummount
- install -m 0644 ${WORKDIR}/server.pro ${S}/server.pro
}
do_stage() {
diff --git a/recipes/opie-taskbar/opie-taskbar/server-pro-1.2.4.patch b/recipes/opie-taskbar/opie-taskbar/server-pro-1.2.4.patch
new file mode 100644
index 0000000000..ca7e4f50bc
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar/server-pro-1.2.4.patch
@@ -0,0 +1,67 @@
+--- launcher/server.pro 2009-07-17 21:10:14.000000000 +0100
++++ launcher/server.pro 2009-07-17 21:16:43.000000000 +0100
+@@ -2,7 +2,7 @@
+
+ CONFIG += qt warn_on
+
+-DESTDIR = $$(OPIEDIR)/bin
++DESTDIR =
+
+ HEADERS += server.h \
+ qrr.h \
+@@ -20,7 +20,7 @@
+ shutdownimpl.h \
+ launcher.h \
+ launcherview.h \
+- $$(OPIEDIR)/core/apps/calibrate/calibrate.h \
++ calibrate/calibrate.h \
+ startmenu.h \
+ transferserver.h \
+ qcopbridge.h \
+@@ -31,7 +31,7 @@
+ serverapp.h \
+ qprocess.h \
+ screensaver.h \
+- $$(OPIEDIR)/noncore/settings/mediummount/mediumwidget.h \
++ mediummount/mediumwidget.h \
+ mediadlg.h
+
+ SOURCES += server.cpp \
+@@ -50,7 +50,7 @@
+ shutdownimpl.cpp \
+ launcher.cpp \
+ launcherview.cpp \
+- $$(OPIEDIR)/core/apps/calibrate/calibrate.cpp \
++ calibrate/calibrate.cpp \
+ transferserver.cpp \
+ packageslave.cpp \
+ irserver.cpp \
+@@ -63,20 +63,20 @@
+ qprocess.cpp \
+ qprocess_unix.cpp \
+ screensaver.cpp \
+- $$(OPIEDIR)/noncore/settings/mediummount/mediumwidget.cc \
++ mediummount/mediumwidget.cc \
+ mediadlg.cpp
+
+
+-INCLUDEPATH += $(OPIEDIR)/core/apps/calibrate
+-DEPENDPATH += $(OPIEDIR)/core/apps/calibrate
++INCLUDEPATH += calibrate
++DEPENDPATH += calibrate
+
+-INCLUDEPATH += $(OPIEDIR)/include $(OPIEDIR)/rsync
+-DEPENDPATH += $(OPIEDIR)/rsync
++INCLUDEPATH += $(OPIEDIR)/include rsync
++DEPENDPATH += rsync
+
+-INCLUDEPATH += $(OPIEDIR)/noncore/settings/mediummount
+-DEPENDPATH += $(OPIEDIR)/noncore/settings/mediummount
++INCLUDEPATH += mediummount
++DEPENDPATH += mediummount
+
+-LIBS += -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync
++LIBS = -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync
+ TARGET = qpe
+
+ ## not ready for use yet
diff --git a/recipes/opie-taskbar/opie-taskbar/server-pro-old.patch b/recipes/opie-taskbar/opie-taskbar/server-pro-old.patch
new file mode 100644
index 0000000000..18aaeafa00
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar/server-pro-old.patch
@@ -0,0 +1,76 @@
+--- launcher/server.pro 2009-07-17 21:17:31.000000000 +0100
++++ launcher/server.pro 2009-07-17 21:16:43.000000000 +0100
+@@ -2,10 +2,10 @@
+
+ CONFIG += qt warn_on
+
+-DESTDIR = $$(OPIEDIR)/bin
++DESTDIR =
+
+ HEADERS += server.h \
+- qrr.h \
++ qrr.h \
+ serverinterface.h \
+ launchertab.h \
+ documentlist.h \
+@@ -20,7 +20,7 @@
+ shutdownimpl.h \
+ launcher.h \
+ launcherview.h \
+- $$(OPIEDIR)/core/apps/calibrate/calibrate.h \
++ calibrate/calibrate.h \
+ startmenu.h \
+ transferserver.h \
+ qcopbridge.h \
+@@ -31,11 +31,11 @@
+ serverapp.h \
+ qprocess.h \
+ screensaver.h \
+- $$(OPIEDIR)/noncore/settings/mediummount/mediumwidget.h \
++ mediummount/mediumwidget.h \
+ mediadlg.h
+
+ SOURCES += server.cpp \
+- qrr.cpp \
++ qrr.cpp \
+ serverinterface.cpp \
+ launchertab.cpp \
+ documentlist.cpp \
+@@ -50,7 +50,7 @@
+ shutdownimpl.cpp \
+ launcher.cpp \
+ launcherview.cpp \
+- $$(OPIEDIR)/core/apps/calibrate/calibrate.cpp \
++ calibrate/calibrate.cpp \
+ transferserver.cpp \
+ packageslave.cpp \
+ irserver.cpp \
+@@ -63,20 +63,20 @@
+ qprocess.cpp \
+ qprocess_unix.cpp \
+ screensaver.cpp \
+- $$(OPIEDIR)/noncore/settings/mediummount/mediumwidget.cc \
++ mediummount/mediumwidget.cc \
+ mediadlg.cpp
+
+
+-INCLUDEPATH += $(OPIEDIR)/core/apps/calibrate
+-DEPENDPATH += $(OPIEDIR)/core/apps/calibrate
++INCLUDEPATH += calibrate
++DEPENDPATH += calibrate
+
+-INCLUDEPATH += $(OPIEDIR)/include $(OPIEDIR)/rsync
+-DEPENDPATH += $(OPIEDIR)/rsync
++INCLUDEPATH += $(OPIEDIR)/include rsync
++DEPENDPATH += rsync
+
+-INCLUDEPATH += $(OPIEDIR)/noncore/settings/mediummount
+-DEPENDPATH += $(OPIEDIR)/noncore/settings/mediummount
++INCLUDEPATH += mediummount
++DEPENDPATH += mediummount
+
+-LIBS += -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync
++LIBS = -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync
+ TARGET = qpe
+
+ ## not ready for use yet
diff --git a/recipes/opie-taskbar/opie-taskbar/server.pro b/recipes/opie-taskbar/opie-taskbar/server.pro
deleted file mode 100644
index 2dee9a973a..0000000000
--- a/recipes/opie-taskbar/opie-taskbar/server.pro
+++ /dev/null
@@ -1,84 +0,0 @@
-TEMPLATE = app
-
-CONFIG += qt warn_on
-
-DESTDIR =
-
-HEADERS += server.h \
- qrr.h \
- serverinterface.h \
- launchertab.h \
- documentlist.h \
- appicons.h \
- taskbar.h \
- runningappbar.h \
- applauncher.h \
- stabmon.h \
- inputmethods.h \
- systray.h \
- wait.h \
- shutdownimpl.h \
- launcher.h \
- launcherview.h \
- calibrate/calibrate.h \
- startmenu.h \
- transferserver.h \
- qcopbridge.h \
- packageslave.h \
- irserver.h \
- firstuse.h \
- syncdialog.h \
- serverapp.h \
- qprocess.h \
- screensaver.h \
- mediummount/mediumwidget.h \
- mediadlg.h
-
-SOURCES += server.cpp \
- qrr.cpp \
- serverinterface.cpp \
- launchertab.cpp \
- documentlist.cpp \
- appicons.cpp \
- taskbar.cpp \
- runningappbar.cpp \
- applauncher.cpp \
- stabmon.cpp \
- inputmethods.cpp \
- systray.cpp \
- wait.cpp \
- shutdownimpl.cpp \
- launcher.cpp \
- launcherview.cpp \
- calibrate/calibrate.cpp \
- transferserver.cpp \
- packageslave.cpp \
- irserver.cpp \
- qcopbridge.cpp \
- startmenu.cpp \
- main.cpp \
- firstuse.cpp \
- syncdialog.cpp \
- serverapp.cpp \
- qprocess.cpp \
- qprocess_unix.cpp \
- screensaver.cpp \
- mediummount/mediumwidget.cc \
- mediadlg.cpp
-
-
-INCLUDEPATH += calibrate
-DEPENDPATH += calibrate
-
-INCLUDEPATH += $(OPIEDIR)/include rsync
-DEPENDPATH += rsync
-
-INCLUDEPATH += mediummount
-DEPENDPATH += mediummount
-
-
-TARGET = qpe
-
-LIBS = -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync
-
-include ( $(OPIEDIR)/include.pro )
diff --git a/recipes/opie-taskbar/opie-taskbar_1.2.2.bb b/recipes/opie-taskbar/opie-taskbar_1.2.2.bb
index 497bff0953..ad2952f3e2 100644
--- a/recipes/opie-taskbar/opie-taskbar_1.2.2.bb
+++ b/recipes/opie-taskbar/opie-taskbar_1.2.2.bb
@@ -1,5 +1,5 @@
require ${PN}.inc
-PR = "r7"
+PR = "r8"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/settings/mediummount \
@@ -9,5 +9,5 @@ SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
${HANDHELDS_CVS};tag=${TAG};module=opie/root \
${HANDHELDS_CVS};tag=${TAG};module=opie/etc \
file://nomax.patch;patch=1;pnum=3 \
- file://server.pro \
+ file://server-pro-old.patch;patch=1 \
"
diff --git a/recipes/opie-taskbar/opie-taskbar_1.2.3.bb b/recipes/opie-taskbar/opie-taskbar_1.2.3.bb
index c22e3bed5f..360e3f4c62 100644
--- a/recipes/opie-taskbar/opie-taskbar_1.2.3.bb
+++ b/recipes/opie-taskbar/opie-taskbar_1.2.3.bb
@@ -1,5 +1,5 @@
require ${PN}.inc
-PR = "r0"
+PR = "r1"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/settings/mediummount \
@@ -12,6 +12,6 @@ SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
file://no-builtin-qss-startup.patch;patch=1 \
file://kbdlocks-runtime.patch;patch=1 \
file://restart-from-bindir.patch;patch=1 \
- file://server.pro \
+ file://server-pro-old.patch;patch=1 \
file://firstuse-path.patch;patch=1 \
"
diff --git a/recipes/opie-taskbar/opie-taskbar_1.2.4.bb b/recipes/opie-taskbar/opie-taskbar_1.2.4.bb
index c22e3bed5f..aa6db3ca36 100644
--- a/recipes/opie-taskbar/opie-taskbar_1.2.4.bb
+++ b/recipes/opie-taskbar/opie-taskbar_1.2.4.bb
@@ -1,5 +1,5 @@
require ${PN}.inc
-PR = "r0"
+PR = "r1"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/settings/mediummount \
@@ -12,6 +12,6 @@ SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
file://no-builtin-qss-startup.patch;patch=1 \
file://kbdlocks-runtime.patch;patch=1 \
file://restart-from-bindir.patch;patch=1 \
- file://server.pro \
+ file://server-pro-1.2.4.patch;patch=1 \
file://firstuse-path.patch;patch=1 \
"
diff --git a/recipes/opie-taskbar/opie-taskbar_cvs.bb b/recipes/opie-taskbar/opie-taskbar_cvs.bb
index 08c4d3bbec..3422bbe180 100644
--- a/recipes/opie-taskbar/opie-taskbar_cvs.bb
+++ b/recipes/opie-taskbar/opie-taskbar_cvs.bb
@@ -1,6 +1,6 @@
require ${PN}.inc
PV = "${OPIE_CVS_PV}"
-PR = "r17"
+PR = "r18"
SRC_URI = "${HANDHELDS_CVS};module=opie/core/apps/calibrate \
${HANDHELDS_CVS};module=opie/noncore/settings/mediummount \
@@ -16,3 +16,4 @@ SRC_URI = "${HANDHELDS_CVS};module=opie/core/apps/calibrate \
file://server-pro-cvs.patch;patch=1 \
file://firstuse-path.patch;patch=1 \
"
+