aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-05 09:19:35 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-05 09:48:50 +0100
commit590b54897fcca0e8568cdc2acd50cf74002b50fb (patch)
tree9892dc45f10581d622cebf0983fde7bb52ce4264
parente7a640aa3d9288df15a3a5a8750fab4a8be276e9 (diff)
downloadopenembedded-590b54897fcca0e8568cdc2acd50cf74002b50fb.tar.gz
linux-openmoko: lower debug level for UBI in defconfigs
* requested by max_posedon, UBI works for him, but was too slow because of debug * applied to all ubi-enabled versions shr-devel, shr-drm-devel, 2.6.31, 2.6.32 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/linux/linux-openmoko-2.6.31/0005-gta02_defconfig-Enable-UBI-debug.patch12
-rw-r--r--recipes/linux/linux-openmoko-2.6.31_git.bb2
-rw-r--r--recipes/linux/linux-openmoko-2.6.32/om-gta02/defconfig18
-rw-r--r--recipes/linux/linux-openmoko-2.6.32_git.bb7
-rw-r--r--recipes/linux/linux-openmoko-shr-devel/0007-Enable-UBI-UBIFS.patch12
-rw-r--r--recipes/linux/linux-openmoko-shr-devel_git.bb2
-rw-r--r--recipes/linux/linux-openmoko-shr-drm-devel/0007-Enable-UBI-UBIFS.patch21
-rw-r--r--recipes/linux/linux-openmoko-shr-drm-devel_git.bb2
8 files changed, 33 insertions, 43 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.31/0005-gta02_defconfig-Enable-UBI-debug.patch b/recipes/linux/linux-openmoko-2.6.31/0005-gta02_defconfig-Enable-UBI-debug.patch
index 19c602a15c..9aecf64086 100644
--- a/recipes/linux/linux-openmoko-2.6.31/0005-gta02_defconfig-Enable-UBI-debug.patch
+++ b/recipes/linux/linux-openmoko-2.6.31/0005-gta02_defconfig-Enable-UBI-debug.patch
@@ -33,9 +33,9 @@ index 3f1b60b..0f53baf 100644
#
-# CONFIG_MTD_UBI_DEBUG is not set
+CONFIG_MTD_UBI_DEBUG=y
-+CONFIG_MTD_UBI_DEBUG_MSG=y
++# CONFIG_MTD_UBI_DEBUG_MSG is not set
+# CONFIG_MTD_UBI_DEBUG_PARANOID is not set
-+# CONFIG_MTD_UBI_DEBUG_DISABLE_BGT is not set
++CONFIG_MTD_UBI_DEBUG_DISABLE_BGT=y
+# CONFIG_MTD_UBI_DEBUG_EMULATE_BITFLIPS is not set
+# CONFIG_MTD_UBI_DEBUG_EMULATE_WRITE_FAILURES is not set
+# CONFIG_MTD_UBI_DEBUG_EMULATE_ERASE_FAILURES is not set
@@ -43,10 +43,10 @@ index 3f1b60b..0f53baf 100644
+#
+# Additional UBI debugging messages
+#
-+CONFIG_MTD_UBI_DEBUG_MSG_BLD=y
-+CONFIG_MTD_UBI_DEBUG_MSG_EBA=y
-+CONFIG_MTD_UBI_DEBUG_MSG_WL=y
-+CONFIG_MTD_UBI_DEBUG_MSG_IO=y
++# CONFIG_MTD_UBI_DEBUG_MSG_BLD is not set
++# CONFIG_MTD_UBI_DEBUG_MSG_EBA is not set
++# CONFIG_MTD_UBI_DEBUG_MSG_WL is not set
++# CONFIG_MTD_UBI_DEBUG_MSG_IO is not set
# CONFIG_PARPORT is not set
CONFIG_BLK_DEV=y
# CONFIG_BLK_DEV_COW_COMMON is not set
diff --git a/recipes/linux/linux-openmoko-2.6.31_git.bb b/recipes/linux/linux-openmoko-2.6.31_git.bb
index 301ac6b863..e801a5c07a 100644
--- a/recipes/linux/linux-openmoko-2.6.31_git.bb
+++ b/recipes/linux/linux-openmoko-2.6.31_git.bb
@@ -8,7 +8,7 @@ KERNEL_VERSION = "${KERNEL_RELEASE}"
OEV = "oe1"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
-PR = "r5"
+PR = "r6"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-2.6.31 \
diff --git a/recipes/linux/linux-openmoko-2.6.32/om-gta02/defconfig b/recipes/linux/linux-openmoko-2.6.32/om-gta02/defconfig
index e83981b3e2..02fd19d79c 100644
--- a/recipes/linux/linux-openmoko-2.6.32/om-gta02/defconfig
+++ b/recipes/linux/linux-openmoko-2.6.32/om-gta02/defconfig
@@ -670,20 +670,20 @@ CONFIG_MTD_UBI_GLUEBI=y
# UBI debugging options
#
CONFIG_MTD_UBI_DEBUG=y
-CONFIG_MTD_UBI_DEBUG_MSG=y
-CONFIG_MTD_UBI_DEBUG_PARANOID=y
+# CONFIG_MTD_UBI_DEBUG_MSG is not set
+# CONFIG_MTD_UBI_DEBUG_PARANOID is not set
CONFIG_MTD_UBI_DEBUG_DISABLE_BGT=y
-CONFIG_MTD_UBI_DEBUG_EMULATE_BITFLIPS=y
-CONFIG_MTD_UBI_DEBUG_EMULATE_WRITE_FAILURES=y
-CONFIG_MTD_UBI_DEBUG_EMULATE_ERASE_FAILURES=y
+# CONFIG_MTD_UBI_DEBUG_EMULATE_BITFLIPS is not set
+# CONFIG_MTD_UBI_DEBUG_EMULATE_WRITE_FAILURES is not set
+# CONFIG_MTD_UBI_DEBUG_EMULATE_ERASE_FAILURES is not set
#
# Additional UBI debugging messages
#
-CONFIG_MTD_UBI_DEBUG_MSG_BLD=y
-CONFIG_MTD_UBI_DEBUG_MSG_EBA=y
-CONFIG_MTD_UBI_DEBUG_MSG_WL=y
-CONFIG_MTD_UBI_DEBUG_MSG_IO=y
+# CONFIG_MTD_UBI_DEBUG_MSG_BLD is not set
+# CONFIG_MTD_UBI_DEBUG_MSG_EBA is not set
+# CONFIG_MTD_UBI_DEBUG_MSG_WL is not set
+# CONFIG_MTD_UBI_DEBUG_MSG_IO is not set
# CONFIG_PARPORT is not set
CONFIG_BLK_DEV=y
# CONFIG_BLK_DEV_COW_COMMON is not set
diff --git a/recipes/linux/linux-openmoko-2.6.32_git.bb b/recipes/linux/linux-openmoko-2.6.32_git.bb
index c4aa28f62c..63b049695a 100644
--- a/recipes/linux/linux-openmoko-2.6.32_git.bb
+++ b/recipes/linux/linux-openmoko-2.6.32_git.bb
@@ -1,14 +1,13 @@
require linux.inc
require linux-openmoko.inc
-DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
+DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
-KERNEL_RELEASE = "2.6.32"
-KERNEL_VERSION = "${KERNEL_RELEASE}"
+KERNEL_RELEASE="2.6.32"
OEV = "oe1"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
-PR = "r2"
+PR = "r4"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-gta02-2.6.32 \
diff --git a/recipes/linux/linux-openmoko-shr-devel/0007-Enable-UBI-UBIFS.patch b/recipes/linux/linux-openmoko-shr-devel/0007-Enable-UBI-UBIFS.patch
index 796a90ff27..43199667d5 100644
--- a/recipes/linux/linux-openmoko-shr-devel/0007-Enable-UBI-UBIFS.patch
+++ b/recipes/linux/linux-openmoko-shr-devel/0007-Enable-UBI-UBIFS.patch
@@ -25,9 +25,9 @@ index e17ddc3..7506963 100644
+# UBI debugging options
+#
+CONFIG_MTD_UBI_DEBUG=y
-+CONFIG_MTD_UBI_DEBUG_MSG=y
++# CONFIG_MTD_UBI_DEBUG_MSG is not set
+# CONFIG_MTD_UBI_DEBUG_PARANOID is not set
-+# CONFIG_MTD_UBI_DEBUG_DISABLE_BGT is not set
++CONFIG_MTD_UBI_DEBUG_DISABLE_BGT=y
+# CONFIG_MTD_UBI_DEBUG_USERSPACE_IO is not set
+# CONFIG_MTD_UBI_DEBUG_EMULATE_BITFLIPS is not set
+# CONFIG_MTD_UBI_DEBUG_EMULATE_WRITE_FAILURES is not set
@@ -36,10 +36,10 @@ index e17ddc3..7506963 100644
+#
+# Additional UBI debugging messages
+#
-+CONFIG_MTD_UBI_DEBUG_MSG_BLD=y
-+CONFIG_MTD_UBI_DEBUG_MSG_EBA=y
-+CONFIG_MTD_UBI_DEBUG_MSG_WL=y
-+CONFIG_MTD_UBI_DEBUG_MSG_IO=y
++# CONFIG_MTD_UBI_DEBUG_MSG_BLD is not set
++# CONFIG_MTD_UBI_DEBUG_MSG_EBA is not set
++# CONFIG_MTD_UBI_DEBUG_MSG_WL is not set
++# CONFIG_MTD_UBI_DEBUG_MSG_IO is not set
# CONFIG_PARPORT is not set
CONFIG_BLK_DEV=y
# CONFIG_BLK_DEV_COW_COMMON is not set
diff --git a/recipes/linux/linux-openmoko-shr-devel_git.bb b/recipes/linux/linux-openmoko-shr-devel_git.bb
index 2a61a95443..480dd4b652 100644
--- a/recipes/linux/linux-openmoko-shr-devel_git.bb
+++ b/recipes/linux/linux-openmoko-shr-devel_git.bb
@@ -8,7 +8,7 @@ KERNEL_VERSION = "2.6.29-rc3"
OMV = "oe11"
PV = "${KERNEL_RELEASE}-${OMV}+gitr${SRCREV}"
-PR = "r6"
+PR = "r7"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
diff --git a/recipes/linux/linux-openmoko-shr-drm-devel/0007-Enable-UBI-UBIFS.patch b/recipes/linux/linux-openmoko-shr-drm-devel/0007-Enable-UBI-UBIFS.patch
index f7dd7615af..b74e496b2b 100644
--- a/recipes/linux/linux-openmoko-shr-drm-devel/0007-Enable-UBI-UBIFS.patch
+++ b/recipes/linux/linux-openmoko-shr-drm-devel/0007-Enable-UBI-UBIFS.patch
@@ -11,15 +11,6 @@ diff --git a/arch/arm/configs/gta02_drm_defconfig b/arch/arm/configs/gta02_drm_d
index e17ddc3..7506963 100644
--- a/arch/arm/configs/gta02_drm_defconfig
+++ b/arch/arm/configs/gta02_drm_defconfig
-@@ -1,7 +1,7 @@
- #
- # Automatically generated make config: don't edit
- # Linux kernel version: 2.6.29-rc3
--# Sun Nov 8 10:53:31 2009
-+# Sun Nov 8 10:57:36 2009
- #
- CONFIG_ARM=y
- CONFIG_HAVE_PWM=y
@@ -806,7 +806,30 @@ CONFIG_MTD_NAND_S3C2410_HWECC=y
#
# UBI - Unsorted block images
@@ -34,9 +25,9 @@ index e17ddc3..7506963 100644
+# UBI debugging options
+#
+CONFIG_MTD_UBI_DEBUG=y
-+CONFIG_MTD_UBI_DEBUG_MSG=y
++# CONFIG_MTD_UBI_DEBUG_MSG is not set
+# CONFIG_MTD_UBI_DEBUG_PARANOID is not set
-+# CONFIG_MTD_UBI_DEBUG_DISABLE_BGT is not set
++CONFIG_MTD_UBI_DEBUG_DISABLE_BGT=y
+# CONFIG_MTD_UBI_DEBUG_USERSPACE_IO is not set
+# CONFIG_MTD_UBI_DEBUG_EMULATE_BITFLIPS is not set
+# CONFIG_MTD_UBI_DEBUG_EMULATE_WRITE_FAILURES is not set
@@ -45,10 +36,10 @@ index e17ddc3..7506963 100644
+#
+# Additional UBI debugging messages
+#
-+CONFIG_MTD_UBI_DEBUG_MSG_BLD=y
-+CONFIG_MTD_UBI_DEBUG_MSG_EBA=y
-+CONFIG_MTD_UBI_DEBUG_MSG_WL=y
-+CONFIG_MTD_UBI_DEBUG_MSG_IO=y
++# CONFIG_MTD_UBI_DEBUG_MSG_BLD is not set
++# CONFIG_MTD_UBI_DEBUG_MSG_EBA is not set
++# CONFIG_MTD_UBI_DEBUG_MSG_WL is not set
++# CONFIG_MTD_UBI_DEBUG_MSG_IO is not set
# CONFIG_PARPORT is not set
CONFIG_BLK_DEV=y
# CONFIG_BLK_DEV_COW_COMMON is not set
diff --git a/recipes/linux/linux-openmoko-shr-drm-devel_git.bb b/recipes/linux/linux-openmoko-shr-drm-devel_git.bb
index e02cc6f135..11838c6a1b 100644
--- a/recipes/linux/linux-openmoko-shr-drm-devel_git.bb
+++ b/recipes/linux/linux-openmoko-shr-drm-devel_git.bb
@@ -9,7 +9,7 @@ KERNEL_VERSION = "2.6.29-rc3-drm"
OMV = "oe15"
PV = "${KERNEL_RELEASE}-drm-${OMV}+gitr${SRCREV}"
-PR = "r4"
+PR = "r5"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=drm-tracking \