aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-06-21 00:25:46 +0200
committerAndrea Adami <andrea.adami@gmail.com>2009-06-21 00:26:39 +0200
commit0219e9fd2fdb945dcaa6e24c7ce3e07d269d9ecc (patch)
treebebecbf95086b20e49b8c7753a034f375d465d1d
parentcf1b579d5801f6e4b01a927fb3eb7277b4e1579c (diff)
downloadopenembedded-0219e9fd2fdb945dcaa6e24c7ce3e07d269d9ecc.tar.gz
kexec-tools: rename static recipes built against klibc
-rw-r--r--recipes/initrdscripts/initramfs-module-kexecboot_1.0.bb2
-rw-r--r--recipes/kexec/kexec-tools-klibc-static_1.101.bb (renamed from recipes/kexec/kexec-tools-static_1.101.bb)7
-rw-r--r--recipes/kexec/kexec-tools-klibc-static_2.0.0.bb (renamed from recipes/kexec/kexec-tools-static_2.0.0.bb)6
-rw-r--r--recipes/kexecboot/kexecboot.inc2
4 files changed, 8 insertions, 9 deletions
diff --git a/recipes/initrdscripts/initramfs-module-kexecboot_1.0.bb b/recipes/initrdscripts/initramfs-module-kexecboot_1.0.bb
index 3080269920..7f1e7cd5f9 100644
--- a/recipes/initrdscripts/initramfs-module-kexecboot_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-kexecboot_1.0.bb
@@ -1,7 +1,7 @@
SRC_URI = "file://87-kexecboot.sh"
PR = "r2"
DESCRIPTION = "An initramfs module for kexecing kernel from rootfs."
-RDEPENDS = "initramfs-uniboot kexec-static"
+RDEPENDS = "initramfs-uniboot kexec-klibc-static"
do_install() {
install -d ${D}/initrd.d
diff --git a/recipes/kexec/kexec-tools-static_1.101.bb b/recipes/kexec/kexec-tools-klibc-static_1.101.bb
index ea44b57cf1..4ad59ce257 100644
--- a/recipes/kexec/kexec-tools-static_1.101.bb
+++ b/recipes/kexec/kexec-tools-klibc-static_1.101.bb
@@ -16,8 +16,7 @@ export CFLAGS=""
export CPPFLAGS=""
export LDFLAGS=""
-PACKAGES =+ "kexec-static kdump-static"
-
-FILES_kexec-static = "${sbindir}/kexec"
-FILES_kdump-static = "${sbindir}/kdump"
+PACKAGES =+ "kexec-klibc-static kdump-klibc-static"
+FILES_kexec-klibc-static = "${sbindir}/kexec"
+FILES_kdump-klibc-static = "${sbindir}/kdump"
diff --git a/recipes/kexec/kexec-tools-static_2.0.0.bb b/recipes/kexec/kexec-tools-klibc-static_2.0.0.bb
index a0d02aa9ac..da12db185b 100644
--- a/recipes/kexec/kexec-tools-static_2.0.0.bb
+++ b/recipes/kexec/kexec-tools-klibc-static_2.0.0.bb
@@ -18,7 +18,7 @@ export CFLAGS=""
export CPPFLAGS=""
export LDFLAGS=""
-PACKAGES =+ "kexec-static kdump-static"
+PACKAGES =+ "kexec-klibc-static kdump-klibc-static"
-FILES_kexec-static = "${sbindir}/kexec"
-FILES_kdump-static = "${sbindir}/kdump"
+FILES_kexec-klibc-static = "${sbindir}/kexec"
+FILES_kdump-klibc-static = "${sbindir}/kdump"
diff --git a/recipes/kexecboot/kexecboot.inc b/recipes/kexecboot/kexecboot.inc
index fdcbf55621..ebd193beea 100644
--- a/recipes/kexecboot/kexecboot.inc
+++ b/recipes/kexecboot/kexecboot.inc
@@ -1,7 +1,7 @@
LICENSE = "GPL"
DEPENDS = "klibc"
-RDEPENDS_${PN} = "kexec-static"
+RDEPENDS_${PN} = "kexec-klibc-static"
inherit autotools