aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-22 16:49:19 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-22 16:50:17 +0200
commit1d3c3ec498743c059e103025ba1ef316ade8afb3 (patch)
tree2fcb3fba47149c297cc91301f93c9e88944c7f54
parent5486fa2cd69bfa0b395a4ec5d5f649bb361247d2 (diff)
downloadopenembedded-1d3c3ec498743c059e103025ba1ef316ade8afb3.tar.gz
elf2aout: merged native recipe, fixed QA hash issue
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
-rw-r--r--recipes/elftoaout/elftoaout-native_2.3.bb14
-rw-r--r--recipes/elftoaout/elftoaout_2.3.bb14
2 files changed, 10 insertions, 18 deletions
diff --git a/recipes/elftoaout/elftoaout-native_2.3.bb b/recipes/elftoaout/elftoaout-native_2.3.bb
deleted file mode 100644
index 9b43805687..0000000000
--- a/recipes/elftoaout/elftoaout-native_2.3.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SECTION = "console/utils"
-LICENSE = "GPL"
-SRC_URI = "http://www.uk.debian.org/debian/pool/main/s/sparc-utils/sparc-utils_1.9.orig.tar.gz"
-
-inherit native
-
-S = "${WORKDIR}/sparc-utils-1.9.orig/elftoaout-${PV}"
-
-do_stage() {
- install elftoaout ${STAGING_BINDIR}
-}
-
-SRC_URI[md5sum] = "08bf3f6d8433a1f4981a2afaa6b49a6c"
-SRC_URI[sha256sum] = "b652bc27f95dcf10a7626b1d2943a1084e1e0b7f9bd3a97f9a46b6688370fe4b"
diff --git a/recipes/elftoaout/elftoaout_2.3.bb b/recipes/elftoaout/elftoaout_2.3.bb
index d411d5dd42..256fcd2fdc 100644
--- a/recipes/elftoaout/elftoaout_2.3.bb
+++ b/recipes/elftoaout/elftoaout_2.3.bb
@@ -1,13 +1,19 @@
SECTION = "console/utils"
LICENSE = "GPL"
+PR = "r1"
+
SRC_URI = "http://www.uk.debian.org/debian/pool/main/s/sparc-utils/sparc-utils_1.9.orig.tar.gz"
+SRC_URI[md5sum] = "08bf3f6d8433a1f4981a2afaa6b49a6c"
+SRC_URI[sha256sum] = "b652bc27f95dcf10a7626b1d2943a1084e1e0b7f9bd3a97f9a46b6688370fe4b"
S = "${WORKDIR}/sparc-utils-1.9.orig/elftoaout-${PV}"
do_install() {
- install -d ${D}${bindir}
- install elftoaout ${D}${bindir}/
+ install -d ${D}${bindir}
+ install elftoaout ${D}${bindir}/
}
-SRC_URI[md5sum] = "08bf3f6d8433a1f4981a2afaa6b49a6c"
-SRC_URI[sha256sum] = "b652bc27f95dcf10a7626b1d2943a1084e1e0b7f9bd3a97f9a46b6688370fe4b"
+BBCLASSEXTEND = "native"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+NATIVE_INSTALL_WORKS = "1"