aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2009-05-28 08:24:11 +0000
committerTom Rini <trini@embeddedalley.com>2009-05-30 15:09:33 -0400
commit2d3750e3dae84c89c9c749f95cf6b3b6cca3e8ce (patch)
treeebcf33e13ca95e0c2791c168c2470039fb634f49
parent89136d9a18ab516424305b660b620867fb432d67 (diff)
downloadopenembedded-2d3750e3dae84c89c9c749f95cf6b3b6cca3e8ce.tar.gz
vim: be an alternative to /bin/vi; switch to INC_PR
Signed-off-by: Michael Smith <msmith@cbnco.com> Acked-by: Tom Rini <trini@embeddedalley.com>
-rw-r--r--recipes/vim/gvim_7.0.bb2
-rw-r--r--recipes/vim/vim.inc9
-rw-r--r--recipes/vim/vim_6.4.bb2
-rw-r--r--recipes/vim/vim_7.0.bb2
4 files changed, 12 insertions, 3 deletions
diff --git a/recipes/vim/gvim_7.0.bb b/recipes/vim/gvim_7.0.bb
index a073e656a7..60aa04127e 100644
--- a/recipes/vim/gvim_7.0.bb
+++ b/recipes/vim/gvim_7.0.bb
@@ -3,7 +3,7 @@ VIMVER = "70"
require vim.inc
DEPENDS += "gtk+ xt"
-PR = "r1"
+PR = "${INC_PR}.1"
FILESPATHPKG =. "vim-${PV}:vim:"
EXTRA_OECONF = "--enable-gui=gtk2 --enable-gtk2-test --disable-gtktest \
diff --git a/recipes/vim/vim.inc b/recipes/vim/vim.inc
index f675ce839f..a766acc34d 100644
--- a/recipes/vim/vim.inc
+++ b/recipes/vim/vim.inc
@@ -3,12 +3,14 @@ SECTION = "console/utils"
DEPENDS = "ncurses"
LICENSE = "vim"
+INC_PR = "r2"
+
SRC_URI = "ftp://ftp.vim.org/pub/vim/unix/vim-${PV}.tar.bz2 \
file://configure.patch;patch=1"
S = "${WORKDIR}/vim${VIMVER}/src"
-inherit autotools
+inherit autotools update-alternatives
do_configure () {
rm -f auto/*
@@ -28,3 +30,8 @@ FILES_vim-tutor = "${datadir}/vim/vim${VIMVER}/tutor ${bindir}/vimtutor"
#FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
# ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
# /bin /sbin /lib/*/ /lib/*.so* ${datadir}/vim"
+
+ALTERNATIVE_NAME = "vi"
+ALTERNATIVE_PATH = "vim"
+ALTERNATIVE_LINK = "${base_bindir}/vi"
+ALTERNATIVE_PRIORITY = "100"
diff --git a/recipes/vim/vim_6.4.bb b/recipes/vim/vim_6.4.bb
index 4cf6591a66..d062bc5236 100644
--- a/recipes/vim/vim_6.4.bb
+++ b/recipes/vim/vim_6.4.bb
@@ -2,6 +2,8 @@ VIMVER = "64"
require vim.inc
+PR = "${INC_PR}.1"
+
EXTRA_OECONF = "--enable-gui=none --disable-gtktest \
--disable-xim --with-features=normal \
--disable-gpm --without-x --disable-netbeans \
diff --git a/recipes/vim/vim_7.0.bb b/recipes/vim/vim_7.0.bb
index c821f6e974..e3fa7ab1e9 100644
--- a/recipes/vim/vim_7.0.bb
+++ b/recipes/vim/vim_7.0.bb
@@ -2,7 +2,7 @@ VIMVER = "70"
require vim.inc
-PR = "r1"
+PR = "${INC_PR}.1"
EXTRA_OECONF = "--enable-gui=none --disable-gtktest \
--disable-xim --with-features=big \