aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2009-06-13 19:41:40 +0100
committerPhil Blundell <philb@gnu.org>2009-06-13 19:41:40 +0100
commit430f94204eaf874d13218c088f8507b5c1b8818e (patch)
tree6c6c15168e41411557daa2af3e707ddbe6d9fa40
parentae823d80c94865dc07745b52c89ce487317d7428 (diff)
downloadopenembedded-430f94204eaf874d13218c088f8507b5c1b8818e.tar.gz
gpe-dm: update to 0.52
xserver-common: update to 1.25
-rw-r--r--conf/checksums.ini12
-rw-r--r--recipes/gpe-dm/gpe-dm_0.52.bb13
-rw-r--r--recipes/xserver-common/xserver-common_1.25.bb20
3 files changed, 45 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 45e47af6ed..8f3179d9da 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -6062,6 +6062,10 @@ sha256=ceaa67f19a1c5462f5e739fcd3b53dd42b0173d9deee579c55e5088801559e43
md5=e20c642ffe7c8a492c0ddc7ee3016f44
sha256=39fcbdea0c1e31338bca4ae60db700a3f0fce7b6cb75087abd559022e22a2927
+[http://ftp.sh.cvut.cz/MIRRORS/rock/ROCK-2.0/gnome2/figment/figment-0.3.5.tar.bz2]
+md5=4b317749c7a75c4f283c6ef5aaad4146
+sha256=ebafecd9a34dbcb83bcbf69db3e9655e92af2eb0ede33d9f92d13ed5f2e7d8b2
+
[ftp://ftp.astron.com/pub/file/file-4.18.tar.gz]
md5=ce1aa9b0316feb57d40a48cfe6b606e4
sha256=5090d5123ea642842d04d3f93a821e1372e5d9e434c74c08ee2483cc150a6273
@@ -8854,6 +8858,10 @@ sha256=bc656eb1846509539bbfaf9269f07588f6f3c05c847b41b351a7571a252f6fee
md5=8064121d3b13ea34c5fb77d2907c78f1
sha256=4f7546bc5f8df7eb9511b919e34eb08945db4359fd3db07c555b83959923a1cf
+[http://gpe.linuxtogo.org/download/source/gpe-dm-0.52.tar.bz2]
+md5=ea157a2b47d932cea9738882df887ae1
+sha256=b2ef45fbe57bdc73a6a5fb244da782fc912c105453bf120128c93284fc05c4ce
+
[http://gpe.linuxtogo.org/download/source/gpe-edit-0.29.tar.gz]
md5=108d1739f06678d45d1529301de6a7c8
sha256=ec3805a8d7b1577f30379f8b3bd59f5f1e1786aa574f75aa254a30bc19b6b79e
@@ -27350,6 +27358,10 @@ sha256=70a767f1109bf70353c58b0fb54626a1300fd0724017196bfd17d13a582ddd62
md5=6d7aaa9c267427ddb78faf008cf78187
sha256=8109646b77c08a0f269531ad42475782101a88681c2590453f4a5c9fe4681932
+[http://gpe.linuxtogo.org/download/source/xserver-common-1.25.tar.gz]
+md5=95faf3cc8c0a70352e9580fc873ca693
+sha256=f0391d08a6763598066e21d83460493973fe24fc65e3f0d2b534ef2497946a34
+
[http://gpe.linuxtogo.org/download/source/xserver-common-1.3.tar.gz]
md5=b55e9347b9aed725cc7baf91701cdd83
sha256=177b5a3e65d7a64b5a0fbbf1b10f8e3d020a20c823b1bb9f3269dc835df213e1
diff --git a/recipes/gpe-dm/gpe-dm_0.52.bb b/recipes/gpe-dm/gpe-dm_0.52.bb
new file mode 100644
index 0000000000..6cf1f002a0
--- /dev/null
+++ b/recipes/gpe-dm/gpe-dm_0.52.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "GPE Display Manager"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0 xserver-common"
+RDEPENDS_${PN} += " xserver-common"
+
+GPE_TARBALL_SUFFIX ?= "bz2"
+
+inherit gpe autotools update-rc.d
+
+INITSCRIPT_NAME = "gpe-dm"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
diff --git a/recipes/xserver-common/xserver-common_1.25.bb b/recipes/xserver-common/xserver-common_1.25.bb
new file mode 100644
index 0000000000..e0a12319b8
--- /dev/null
+++ b/recipes/xserver-common/xserver-common_1.25.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
+PR = "r0"
+
+PACKAGE_ARCH = "all"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
+SRC_URI_append = " file://setDPI.sh \
+ file://89xdgautostart.sh \
+"
+
+do_install_append() {
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+ install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
+ sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/Xserver
+}