aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-06-13 16:13:32 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-06-13 16:27:56 +0200
commit4a2af9d82d4dea4e9f8c2b66fc4f8bcc0f32db69 (patch)
tree4e421c7516e187b7b61283a1079b14d959d3e6a2
parentc64f785ed956416367a3dbbce240c8aa0c2277a2 (diff)
downloadopenembedded-4a2af9d82d4dea4e9f8c2b66fc4f8bcc0f32db69.tar.gz
linux-leviathan: fix the "empty.gz already exists" message
if we don't check if empty and empty.gz already exist, The fist time empty.gz is copied to the deploy dir, then the second build we have: gzip: empty.gz already exists; not overwritten And it fails. so we need to touch and gzip only if empty.gz not already present.
-rw-r--r--recipes/linux/linux-leviathan_git.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes/linux/linux-leviathan_git.bb b/recipes/linux/linux-leviathan_git.bb
index bc8a477410..f5a7d21e0e 100644
--- a/recipes/linux/linux-leviathan_git.bb
+++ b/recipes/linux/linux-leviathan_git.bb
@@ -2,7 +2,7 @@ require linux.inc
DEPENDS += "android-image-utils-native"
PV = "2.6.32+${PR}+gitr${SRCREV}"
-PR = "r18"
+PR = "r19"
COMPATIBLE_MACHINE = "htcdream"
CMDLINE = "console=tty1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M"
@@ -17,8 +17,12 @@ SRC_URI = "\
S = "${WORKDIR}/git"
do_deploy_append() {
- touch -f empty
- gzip empty
+ if [ ! -e empty.gz ];then
+ if [ ! -e empty ];then
+ touch empty
+ fi
+ gzip empty
+ fi
mkbootimg --kernel ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.bin \
--ramdisk empty.gz \
--cmdline "${CMDLINE}" \