aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-06-07 20:39:41 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-06-10 23:33:17 +0200
commit5a67c1d1daeb9016270cd514bb3eab179cd298b8 (patch)
treef1e7f64de3f5a4ef9c627d2e7cd4df5264b72181
parentdce51c1b4ea37b62b953e1b719c8468e14d2f5ca (diff)
downloadopenembedded-5a67c1d1daeb9016270cd514bb3eab179cd298b8.tar.gz
netbase: add support for htcdream
If we don't add a custom file containing auto usb0, usb0 is not configured at boot and we can't ssh into the phone Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Michael 'Mickey' Lauer <mlauer@vanille-media.de>
-rw-r--r--recipes/netbase/netbase/htcdream/interfaces17
-rw-r--r--recipes/netbase/netbase_4.21.bb2
2 files changed, 18 insertions, 1 deletions
diff --git a/recipes/netbase/netbase/htcdream/interfaces b/recipes/netbase/netbase/htcdream/interfaces
new file mode 100644
index 0000000000..a75f25957e
--- /dev/null
+++ b/recipes/netbase/netbase/htcdream/interfaces
@@ -0,0 +1,17 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+
+# The loopback interface
+auto lo
+iface lo inet loopback
+
+# Ethernet/RNDIS gadget (g_ether)
+# ... or on host side, usbnet and random hwaddr
+auto usb0
+iface usb0 inet static
+ address 192.168.0.202
+ netmask 255.255.255.0
+ network 192.168.0.0
+ up route add default gw 192.168.0.200 metric 8
+ up echo nameserver 208.67.222.222 > /etc/resolv.conf
+ up echo nameserver 208.67.220.220 >> /etc/resolv.conf
+ down route del default gw 192.168.0.200 metric 8
diff --git a/recipes/netbase/netbase_4.21.bb b/recipes/netbase/netbase_4.21.bb
index 4e1d39f1cc..baec44bafc 100644
--- a/recipes/netbase/netbase_4.21.bb
+++ b/recipes/netbase/netbase_4.21.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "This package provides the necessary \
infrastructure for basic TCP/IP based networking."
SECTION = "base"
LICENSE = "GPLv2"
-PR = "r41"
+PR = "r42"
inherit update-rc.d