aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-23 10:50:43 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:29 +0200
commit8f62a0571dd89b6b4e5ce3181c1c3c3916857df5 (patch)
tree64ae7969e66729ffc161e0d11a1ed2d62bd6605e
parent44e0e4880ba5754f079adb4ceb01625fb9822150 (diff)
downloadopenembedded-8f62a0571dd89b6b4e5ce3181c1c3c3916857df5.tar.gz
linux-omap-psp 2.6.32: update omap3-touchbook patches and defconfig
Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0001-ARM-OMAP-add-spi-platform-devices.patch2
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0002-MMA7455L-accelerometer-driver.patch15
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0010-Touch-Book-turn-on-off-the-class-D-amplifier-dependi.patch39
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/defconfig63
4 files changed, 42 insertions, 77 deletions
diff --git a/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0001-ARM-OMAP-add-spi-platform-devices.patch b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0001-ARM-OMAP-add-spi-platform-devices.patch
index ddc1cf3e58..f44abc3077 100644
--- a/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0001-ARM-OMAP-add-spi-platform-devices.patch
+++ b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0001-ARM-OMAP-add-spi-platform-devices.patch
@@ -1,4 +1,4 @@
-From e17eb2539ff4bcd3704fcdf3f9a950706adee769 Mon Sep 17 00:00:00 2001
+From 45e62c073f088072ea131e5eda1446f63fc97acf Mon Sep 17 00:00:00 2001
From: Tim Yamin <plasm@roo.me.uk>
Date: Sat, 11 Apr 2009 13:05:21 -0700
Subject: [PATCH 01/14] ARM: OMAP: add spi platform devices
diff --git a/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0002-MMA7455L-accelerometer-driver.patch b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0002-MMA7455L-accelerometer-driver.patch
index e6f6769799..6a19217541 100644
--- a/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0002-MMA7455L-accelerometer-driver.patch
+++ b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0002-MMA7455L-accelerometer-driver.patch
@@ -1,14 +1,14 @@
-From cf0a1f6cecfb04240c284012a29c479adc39bbf6 Mon Sep 17 00:00:00 2001
+From dce7f7b177775843b843dcc147ac04e9a99bb60a Mon Sep 17 00:00:00 2001
From: Tim Yamin <plasm@roo.me.uk>
-Date: Fri, 12 Mar 2010 11:39:01 +0100
+Date: Tue, 23 Mar 2010 09:52:10 +0100
Subject: [PATCH 02/14] MMA7455L accelerometer driver
---
drivers/input/misc/Kconfig | 9 +
drivers/input/misc/Makefile | 1 +
- drivers/input/misc/mma7455l.c | 614 +++++++++++++++++++++++++++++++++++++++++
+ drivers/input/misc/mma7455l.c | 615 +++++++++++++++++++++++++++++++++++++++++
include/linux/mma7455l.h | 11 +
- 4 files changed, 635 insertions(+), 0 deletions(-)
+ 4 files changed, 636 insertions(+), 0 deletions(-)
create mode 100644 drivers/input/misc/mma7455l.c
create mode 100644 include/linux/mma7455l.h
@@ -42,10 +42,10 @@ index a8b8485..75b8baa 100644
diff --git a/drivers/input/misc/mma7455l.c b/drivers/input/misc/mma7455l.c
new file mode 100644
-index 0000000..3ca29ff
+index 0000000..b907cc6
--- /dev/null
+++ b/drivers/input/misc/mma7455l.c
-@@ -0,0 +1,614 @@
+@@ -0,0 +1,615 @@
+/* Linux kernel driver for the Freescale MMA7455L 3-axis accelerometer
+ *
+ * Copyright (C) 2009 by Always Innovating, Inc.
@@ -285,11 +285,12 @@ index 0000000..3ca29ff
+static irqreturn_t mma7455l_interrupt(int irq, void *_mma)
+{
+ struct mma7455l_info *mma = _mma;
-+ mma7455l_schedule_work(mma);
+
+ /* Disable any further interrupts until we have processed
+ * the current one */
+ disable_irq_nosync(mma->spi_dev->irq);
++
++ mma7455l_schedule_work(mma);
+ return IRQ_HANDLED;
+}
+
diff --git a/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0010-Touch-Book-turn-on-off-the-class-D-amplifier-dependi.patch b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0010-Touch-Book-turn-on-off-the-class-D-amplifier-dependi.patch
index 67d2b18907..1edce7b7c4 100644
--- a/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0010-Touch-Book-turn-on-off-the-class-D-amplifier-dependi.patch
+++ b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0010-Touch-Book-turn-on-off-the-class-D-amplifier-dependi.patch
@@ -1,15 +1,15 @@
-From 98b1f1df855ead7eec5f8c9032736046752e5593 Mon Sep 17 00:00:00 2001
+From db8f1eba9154789c45c6a92413bbbd94f5d9c7f5 Mon Sep 17 00:00:00 2001
From: Tim Yamin <plasm@roo.me.uk>
Date: Wed, 29 Apr 2009 17:30:25 -0700
-Subject: [PATCH 10/14] Touch Book: turn on/off the class D amplifier depending on whether the headphones are plugged into the jack or not.
+Subject: [PATCH] Touch Book: turn on/off the class D amplifier depending on whether the headphones are plugged into the jack or not.
Signed-off-by: Tim Yamin <plasm@roo.me.uk>
---
- sound/soc/omap/omap3beagle.c | 45 ++++++++++++++++++++++++++++++++++++++++++
- 1 files changed, 45 insertions(+), 0 deletions(-)
+ sound/soc/omap/omap3beagle.c | 33 +++++++++++++++++++++++++++++++++
+ 1 files changed, 33 insertions(+), 0 deletions(-)
diff --git a/sound/soc/omap/omap3beagle.c b/sound/soc/omap/omap3beagle.c
-index 248b789..8b2d9e4 100644
+index fd24a4a..1236638 100644
--- a/sound/soc/omap/omap3beagle.c
+++ b/sound/soc/omap/omap3beagle.c
@@ -20,7 +20,10 @@
@@ -33,22 +33,14 @@ index 248b789..8b2d9e4 100644
static int omap3beagle_hw_params(struct snd_pcm_substream *substream,
struct snd_pcm_hw_params *params)
{
-@@ -113,6 +119,33 @@ static struct snd_soc_device omap3beagle_snd_devdata = {
+@@ -103,6 +109,34 @@ static struct snd_soc_device omap3beagle_snd_devdata = {
static struct platform_device *omap3beagle_snd_device;
+static void jack_work_func(struct work_struct *wq)
+{
-+ struct snd_soc_device *socdev = platform_get_drvdata(omap3beagle_snd_device);
-+ struct snd_soc_codec *codec = socdev->card->codec;
-+
-+ snd_soc_dapm_sync(codec);
-+}
-+DECLARE_WORK(jack_work, jack_work_func);
-+
-+static irqreturn_t touchbook_headphone_event(int irq, void *snd)
-+{
+ int status = gpio_get_value(TB_HEADPHONE_GPIO);
++
+ struct snd_soc_device *socdev = platform_get_drvdata(omap3beagle_snd_device);
+ struct snd_soc_codec *codec = socdev->card->codec;
+
@@ -60,6 +52,15 @@ index 248b789..8b2d9e4 100644
+ snd_soc_dapm_enable_pin(codec, "HFR");
+ }
+
++ enable_irq(TB_HEADPHONE_IRQ);
++
++ //snd_soc_dapm_sync(codec);
++}
++DECLARE_WORK(jack_work, jack_work_func);
++
++static irqreturn_t touchbook_headphone_event(int irq, void *snd)
++{
++ disable_irq_nosync(irq);
+ schedule_work(&jack_work);
+ return IRQ_HANDLED;
+}
@@ -67,14 +68,11 @@ index 248b789..8b2d9e4 100644
static int __init omap3beagle_soc_init(void)
{
int ret;
-@@ -133,10 +166,22 @@ static int __init omap3beagle_soc_init(void)
+@@ -123,10 +156,19 @@ static int __init omap3beagle_soc_init(void)
omap3beagle_snd_devdata.dev = &omap3beagle_snd_device->dev;
*(unsigned int *)omap3beagle_dai.cpu_dai->private_data = 1; /* McBSP2 */
+ /* Touch Book -- headphone jack sensor */
-+ omap_set_gpio_debounce(TB_HEADPHONE_GPIO, 1);
-+ omap_set_gpio_debounce_time(TB_HEADPHONE_GPIO, 0xff);
-+
+ ret = request_irq(TB_HEADPHONE_IRQ, touchbook_headphone_event, IRQF_TRIGGER_RISING |
+ IRQF_TRIGGER_FALLING, "touchbook_headphone", omap3beagle_snd_device);
+ if (ret < 0)
@@ -90,6 +88,3 @@ index 248b789..8b2d9e4 100644
return 0;
err1:
---
-1.6.6.1
-
diff --git a/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/defconfig b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/defconfig
index 8efccecc11..cfb89daba3 100644
--- a/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/defconfig
+++ b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.32
-# Sat Jan 30 16:34:11 2010
+# Tue Mar 23 10:33:49 2010
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -30,6 +30,7 @@ CONFIG_CONSTRUCTORS=y
#
CONFIG_EXPERIMENTAL=y
CONFIG_BROKEN_ON_SMP=y
+CONFIG_LOCK_KERNEL=y
CONFIG_INIT_ENV_ARG_LIMIT=32
CONFIG_LOCALVERSION=""
# CONFIG_LOCALVERSION_AUTO is not set
@@ -148,27 +149,27 @@ CONFIG_DEFAULT_IOSCHED="cfq"
# CONFIG_INLINE_SPIN_LOCK_BH is not set
# CONFIG_INLINE_SPIN_LOCK_IRQ is not set
# CONFIG_INLINE_SPIN_LOCK_IRQSAVE is not set
-CONFIG_INLINE_SPIN_UNLOCK=y
+# CONFIG_INLINE_SPIN_UNLOCK is not set
# CONFIG_INLINE_SPIN_UNLOCK_BH is not set
-CONFIG_INLINE_SPIN_UNLOCK_IRQ=y
+# CONFIG_INLINE_SPIN_UNLOCK_IRQ is not set
# CONFIG_INLINE_SPIN_UNLOCK_IRQRESTORE is not set
# CONFIG_INLINE_READ_TRYLOCK is not set
# CONFIG_INLINE_READ_LOCK is not set
# CONFIG_INLINE_READ_LOCK_BH is not set
# CONFIG_INLINE_READ_LOCK_IRQ is not set
# CONFIG_INLINE_READ_LOCK_IRQSAVE is not set
-CONFIG_INLINE_READ_UNLOCK=y
+# CONFIG_INLINE_READ_UNLOCK is not set
# CONFIG_INLINE_READ_UNLOCK_BH is not set
-CONFIG_INLINE_READ_UNLOCK_IRQ=y
+# CONFIG_INLINE_READ_UNLOCK_IRQ is not set
# CONFIG_INLINE_READ_UNLOCK_IRQRESTORE is not set
# CONFIG_INLINE_WRITE_TRYLOCK is not set
# CONFIG_INLINE_WRITE_LOCK is not set
# CONFIG_INLINE_WRITE_LOCK_BH is not set
# CONFIG_INLINE_WRITE_LOCK_IRQ is not set
# CONFIG_INLINE_WRITE_LOCK_IRQSAVE is not set
-CONFIG_INLINE_WRITE_UNLOCK=y
+# CONFIG_INLINE_WRITE_UNLOCK is not set
# CONFIG_INLINE_WRITE_UNLOCK_BH is not set
-CONFIG_INLINE_WRITE_UNLOCK_IRQ=y
+# CONFIG_INLINE_WRITE_UNLOCK_IRQ is not set
# CONFIG_INLINE_WRITE_UNLOCK_IRQRESTORE is not set
# CONFIG_MUTEX_SPIN_ON_OWNER is not set
CONFIG_FREEZER=y
@@ -329,9 +330,9 @@ CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
CONFIG_VMSPLIT_2G=y
# CONFIG_VMSPLIT_1G is not set
CONFIG_PAGE_OFFSET=0x80000000
-CONFIG_PREEMPT_NONE=y
+# CONFIG_PREEMPT_NONE is not set
# CONFIG_PREEMPT_VOLUNTARY is not set
-# CONFIG_PREEMPT is not set
+CONFIG_PREEMPT=y
CONFIG_HZ=128
# CONFIG_THUMB2_KERNEL is not set
CONFIG_AEABI=y
@@ -910,7 +911,7 @@ CONFIG_NET_9P=m
#
# Generic Driver Options
#
-CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug"
+CONFIG_UEVENT_HELPER_PATH=""
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y
CONFIG_STANDALONE=y
@@ -2496,23 +2497,12 @@ CONFIG_W35UND=m
CONFIG_PRISM2_USB=m
# CONFIG_ECHO is not set
CONFIG_OTUS=m
-CONFIG_RT2870=y
# CONFIG_COMEDI is not set
# CONFIG_ASUS_OLED is not set
# CONFIG_INPUT_MIMIO is not set
# CONFIG_TRANZPORT is not set
#
-# Android
-#
-CONFIG_ANDROID=y
-CONFIG_ANDROID_BINDER_IPC=y
-CONFIG_ANDROID_LOGGER=y
-# CONFIG_ANDROID_RAM_CONSOLE is not set
-# CONFIG_ANDROID_TIMED_OUTPUT is not set
-# CONFIG_ANDROID_LOW_MEMORY_KILLER is not set
-
-#
# Qualcomm MSM Camera And Video
#
@@ -2537,15 +2527,6 @@ CONFIG_ANDROID_LOGGER=y
# CONFIG_RAMZSWAP is not set
# CONFIG_BATMAN_ADV is not set
# CONFIG_STRIP is not set
-CONFIG_MPU_BRIDGE=m
-# CONFIG_BRIDGE_DVFS is not set
-CONFIG_BRIDGE_MEMPOOL_SIZE=0x600000
-# CONFIG_BRIDGE_DEBUG is not set
-
-#
-# Bridge Notifications
-#
-# CONFIG_BRIDGE_NTFY_PWRERR is not set
#
# CBUS support
@@ -2617,6 +2598,7 @@ CONFIG_QUOTACTL=y
CONFIG_AUTOFS4_FS=m
CONFIG_FUSE_FS=y
# CONFIG_CUSE is not set
+CONFIG_GENERIC_ACL=y
#
# Caches
@@ -2652,7 +2634,7 @@ CONFIG_PROC_SYSCTL=y
CONFIG_PROC_PAGE_MONITOR=y
CONFIG_SYSFS=y
CONFIG_TMPFS=y
-# CONFIG_TMPFS_POSIX_ACL is not set
+CONFIG_TMPFS_POSIX_ACL=y
# CONFIG_HUGETLB_PAGE is not set
CONFIG_CONFIGFS_FS=m
CONFIG_MISC_FILESYSTEMS=y
@@ -2707,21 +2689,6 @@ CONFIG_SYSV_FS=m
CONFIG_UFS_FS=m
# CONFIG_UFS_FS_WRITE is not set
# CONFIG_UFS_DEBUG is not set
-CONFIG_AUFS_FS=y
-CONFIG_AUFS_BRANCH_MAX_127=y
-# CONFIG_AUFS_BRANCH_MAX_511 is not set
-# CONFIG_AUFS_BRANCH_MAX_1023 is not set
-# CONFIG_AUFS_BRANCH_MAX_32767 is not set
-# CONFIG_AUFS_HINOTIFY is not set
-# CONFIG_AUFS_RDU is not set
-# CONFIG_AUFS_SP_IATTR is not set
-# CONFIG_AUFS_SHWH is not set
-# CONFIG_AUFS_BR_RAMFS is not set
-# CONFIG_AUFS_BR_FUSE is not set
-# CONFIG_AUFS_BR_HFSPLUS is not set
-CONFIG_AUFS_BDEV_LOOP=y
-CONFIG_AUFS_DEBUG=y
-CONFIG_AUFS_MAGIC_SYSRQ=y
CONFIG_NETWORK_FILESYSTEMS=y
CONFIG_NFS_FS=y
CONFIG_NFS_V3=y
@@ -2781,7 +2748,7 @@ CONFIG_MSDOS_PARTITION=y
CONFIG_BSD_DISKLABEL=y
CONFIG_MINIX_SUBPARTITION=y
CONFIG_SOLARIS_X86_PARTITION=y
-CONFIG_UNIXWARE_DISKLABEL=y
+# CONFIG_UNIXWARE_DISKLABEL is not set
CONFIG_LDM_PARTITION=y
CONFIG_LDM_DEBUG=y
# CONFIG_SGI_PARTITION is not set
@@ -2859,6 +2826,7 @@ CONFIG_TIMER_STATS=y
# CONFIG_DEBUG_OBJECTS is not set
# CONFIG_DEBUG_SLAB is not set
# CONFIG_DEBUG_KMEMLEAK is not set
+CONFIG_DEBUG_PREEMPT=y
# CONFIG_DEBUG_RT_MUTEXES is not set
# CONFIG_RT_MUTEX_TESTER is not set
# CONFIG_DEBUG_SPINLOCK is not set
@@ -2900,6 +2868,7 @@ CONFIG_TRACING_SUPPORT=y
CONFIG_FTRACE=y
# CONFIG_FUNCTION_TRACER is not set
# CONFIG_IRQSOFF_TRACER is not set
+# CONFIG_PREEMPT_TRACER is not set
# CONFIG_SCHED_TRACER is not set
# CONFIG_ENABLE_DEFAULT_TRACERS is not set
# CONFIG_BOOT_TRACER is not set