aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-05-31 00:50:23 +0200
committerAndrea Adami <andrea.adami@gmail.com>2009-05-31 01:23:02 +0200
commita90701a8b544ce809c137ad44395c18a116466c4 (patch)
tree44775ab94c7423b567637e8ffe545b0e7b7805b1
parent2747ae6c34231fdb5efed4b11f064caadd24214e (diff)
downloadopenembedded-a90701a8b544ce809c137ad44395c18a116466c4.tar.gz
linux-rp-2.6.23: fix compilation with gcc-4.3
Since some architectures don't support __udivdi3(). Signed-off-by: Segher Boessenkool <segher@kernel.crashing.org> Cc: john stultz <johnstul@us.ibm.com> Cc: Ingo Molnar <mingo@elte.hu> Signed-off-by: Andrew Morton <akpm@linux-foundation.org> Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
-rw-r--r--recipes/linux/linux-rp-2.6.23/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch15
-rw-r--r--recipes/linux/linux-rp_2.6.23.bb3
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/linux/linux-rp-2.6.23/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch b/recipes/linux/linux-rp-2.6.23/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch
new file mode 100644
index 0000000000..7e847d6a05
--- /dev/null
+++ b/recipes/linux/linux-rp-2.6.23/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch
@@ -0,0 +1,15 @@
+Index: linux-2.6.23/include/linux/time.h
+===================================================================
+--- a/include/linux/time.h
++++ b/include/linux/time.h
+@@ -172,6 +172,10 @@ static inline void timespec_add_ns(struct timespec *a, u64 ns)
+ {
+ ns += a->tv_nsec;
+ while(unlikely(ns >= NSEC_PER_SEC)) {
++ /* The following asm() prevents the compiler from
++ * optimising this loop into a modulo operation. */
++ asm("" : "+r"(ns));
++
+ ns -= NSEC_PER_SEC;
+ a->tv_sec++;
+ }
diff --git a/recipes/linux/linux-rp_2.6.23.bb b/recipes/linux/linux-rp_2.6.23.bb
index 2293eea80e..460ac53012 100644
--- a/recipes/linux/linux-rp_2.6.23.bb
+++ b/recipes/linux/linux-rp_2.6.23.bb
@@ -1,6 +1,6 @@
require linux-rp.inc
-PR = "r35"
+PR = "r36"
# Handy URLs
# git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=ef7d1b244fa6c94fb76d5f787b8629df64ea4046
@@ -14,6 +14,7 @@ PR = "r35"
# Patches submitted upstream are towards top of this list
# Hacks should clearly named and at the bottom
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2 \
+ file://0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch;patch=1 \
${RPSRC}/pxa25x_suspend_fixes-r0.patch;patch=1;status=merged \
${RPSRC}/lzo_jffs2-r3.patch;patch=1;status=merged \
${RPSRC}/lzo_jffs2_lzomode-r1.patch;patch=1;status=merged \