aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2009-05-26 23:14:03 +0200
committerDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2009-05-27 00:08:31 +0200
commitcbf539f8e7431241e28b77394d33b764f7b0463b (patch)
tree671a47bd7a9c79e19775050e729ba2be8384baae
parent17b4ebefba0e3ba22cc59a2532c1c190b10fa7ca (diff)
downloadopenembedded-cbf539f8e7431241e28b77394d33b764f7b0463b.tar.gz
emacs 22.3: Fixed compilation,bump PR
(I have asked for review but no one reviewed,even after a ping so hrw told me to commit) *fixed "emacs: error while loading shared libraries: libgcc_s.so.1: cannot open shared object file: No such file or directory" with the code that is under "copy STAGING_DIR_TARGET and libgcc_s.so* to WORKDIR/qemu-treedir" here how it looked like: | emacs: error while loading shared libraries: libgcc_s.so.1: cannot open shared object file: No such file or directory | make[1]: *** [blessmail] Error 127 | make[1]: Leaving directory `/home/embedded/oetmp_openmoko/work/armv4t-angstrom-linux-gnueabi/emacs-22.3-r0/emacs-22.3/lib-src' | make: *** [blessmail] Error 2 | FATAL: oe_runmake failed *fixed the check of liblockfile: | checking for liblockfile.so... yes | configure: error: Shared liblockfile found but can't link against it. | This probably means that movemail could lose mail. | There may be a `development' package to install containing liblockfile. | FATAL: oe_runconf failed *also compiles fines thanks to the new qemu (0.10.3) that integrated some qemu-arm patches
-rw-r--r--recipes/emacs/emacs.inc21
-rw-r--r--recipes/emacs/emacs_22.3.bb2
2 files changed, 22 insertions, 1 deletions
diff --git a/recipes/emacs/emacs.inc b/recipes/emacs/emacs.inc
index 05acd828dc..0464a26706 100644
--- a/recipes/emacs/emacs.inc
+++ b/recipes/emacs/emacs.inc
@@ -5,6 +5,8 @@ SECTION = "editor"
# and it needs to run some generated binaries..
DEPENDS += "qemu-native"
+DEPENDS +=" liblockfile"
+
inherit autotools
PACKAGES =+ "${PN}-el"
@@ -16,8 +18,12 @@ FILES_${PN} += "${datadir}/emacs"
FILES_${PN}-dbg += "${libexecdir}/emacs/*/*/.debug ${datadir}/emacs/*/*/.debug"
+TREEDIR = "${WORKDIR}/qemu-treedir"
+
# Large stack is required at least on x86_64 host, otherwise random segfaults appear:
-QEMU = "qemu-${TARGET_ARCH} ${QEMU_OPTIONS} -s 1048576 -L ${STAGING_DIR_TARGET}"
+QEMU = "qemu-${TARGET_ARCH} ${QEMU_OPTIONS} -s 1048576 -L ${TREEDIR}"
+
+export LOGNAME = "$(whoami)"
do_compile_prepend() {
sed -i ':1;s:\(START.* \|LIB_STANDARD.* \|LIBES.* \)/usr/lib:\1${STAGING_LIBDIR}:;t1' ${S}/src/s/gnu-linux.h `find "${S}" -name Makefile`
@@ -26,6 +32,19 @@ do_compile_prepend() {
ln -sf ../src/emacs lisp/emacs
ln -sf ../src/emacs lib-src/emacs
ln -sf ../src/emacs leim/emacs
+#copy STAGING_DIR_TARGET and libgcc_s.so* to WORKDIR/qemu-treedir #copied code from glibc-package.bbclass
+ treedir=${TREEDIR}
+ if [ -e $treedir ];then
+ rm -rf $treedir
+ fi
+ mkdir $treedir
+ cp -pPR ${STAGING_DIR_TARGET}/* $treedir
+ if [ -f ${CROSS_DIR}/${TARGET_SYS}/lib/libgcc_s.so ]; then
+ cp -pPR ${CROSS_DIR}/${TARGET_SYS}/lib/libgcc_s.so $treedir/lib
+ fi
+ if [ -f ${CROSS_DIR}/${TARGET_SYS}/lib/libgcc_s.so.* ]; then
+ cp -pPR ${CROSS_DIR}/${TARGET_SYS}/lib/libgcc_s.so.* $treedir/lib
+ fi
}
EXTRA_OEMAKE += 'QEMU="${QEMU}"'
diff --git a/recipes/emacs/emacs_22.3.bb b/recipes/emacs/emacs_22.3.bb
index da8de39eec..4eeff7b567 100644
--- a/recipes/emacs/emacs_22.3.bb
+++ b/recipes/emacs/emacs_22.3.bb
@@ -1,5 +1,7 @@
require emacs.inc
+PR="r1"
+
EXTRA_OECONF = "--without-sound --without-x"
SRC_URI = "${GNU_MIRROR}/emacs/emacs-${PV}.tar.gz \