aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-07 13:16:14 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-07 13:16:14 +0200
commitce7274c16f0b94bb2ccf623ee7e4be6043e80a43 (patch)
tree65dc32005e42f0b4112fe8f13a43e4e34cfd9961
parent6332b2842a983f72de62ad8c2e8abf1c067845a1 (diff)
downloadopenembedded-ce7274c16f0b94bb2ccf623ee7e4be6043e80a43.tar.gz
bluez4: update to 4.41
-rw-r--r--conf/checksums.ini8
-rw-r--r--recipes/bluez/bluez4_4.41.bb67
2 files changed, 75 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 754b80c086..c3c83c310b 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -2782,6 +2782,10 @@ sha256=924dc4b8ae78da2c8f3af9c36ab85d08ee7f8ec0ae4dfe58840ae70041580063
md5=a25fa37c97c309338649f6a5fd4cea76
sha256=1208d8e986f8b545659db21c8220ec28b48979627158123dd9018f9733d858d2
+[http://www.kernel.org/pub/linux/bluetooth/bluez-4.41.tar.gz]
+md5=4629236517df280be321f009917a52be
+sha256=0b22f518085528b71aa9eab8bbc44d2696458c85d902c6a6686076ae10d64549
+
[http://www.kernel.org/pub/linux/bluetooth/bluez-4.7.tar.gz]
md5=2aa806940d2c841e57a9b2ab7302b750
sha256=ed384dea4f5f21157758fcd7db64db19ce0b410509c26630706e4a3c779287a0
@@ -17638,6 +17642,10 @@ sha256=aa567d986c74a4c8b4abb1cc454c099f67ab01b049b4c69aa6e703c7f18b594d
md5=b9fbc1386b24f59b36aeb9d764c11fb5
sha256=8ed452371010117e183ade4e1e3ae4b489485b792722bf3b97b817cf0ed66ac8
+[http://www.kernel.org/pub/linux/bluetooth/obexd-0.13.tar.gz]
+md5=8764dcbcd7b5ed80e17b1279a82701b0
+sha256=c986121e520897af6c326ece8a26eca87bdb4641a93913b63a5c29521cefaf66
+
[http://downloads.sourceforge.net/openobex/obexftp-0.20.tar.gz]
md5=085b9edc0504c0d79e7479a54e2018c5
sha256=7246fc75257afcd30ff16dc70185057157bcefc12fa9fba111b3b201577cc40e
diff --git a/recipes/bluez/bluez4_4.41.bb b/recipes/bluez/bluez4_4.41.bb
new file mode 100644
index 0000000000..74dc9bcddc
--- /dev/null
+++ b/recipes/bluez/bluez4_4.41.bb
@@ -0,0 +1,67 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland V4"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+
+# For angstrom we want this to replace at least bluez-libs
+PROVIDES_append_angstrom = " bluez-utils bluez-libs"
+
+SRC_URI = "\
+ http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
+ file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
+ file://sbc-thumb.patch;patch=1 \
+ file://bluetooth.conf \
+"
+S = "${WORKDIR}/bluez-${PV}"
+
+inherit autotools_stage update-rc.d
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+EXTRA_OECONF = "\
+ --enable-gstreamer \
+ --enable-alsa \
+ --enable-usb \
+ --enable-netlink \
+ --enable-tools \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-dfutool \
+ --enable-hidd \
+ --enable-pandd \
+ --enable-dund \
+ --disable-cups \
+ --enable-test \
+ --enable-manpages \
+ --enable-configfiles \
+ --enable-initscripts \
+ --disable-pcmciarules \
+"
+
+do_install_append() {
+ install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
+ # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
+ install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
+}
+
+INITSCRIPT_NAME = "bluetooth"
+INITSCRIPT_PARAMS = "defaults 23 19"
+
+PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
+
+FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
+FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
+FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
+FILES_${PN}-dev += "\
+ ${libdir}/bluetooth/plugins/*.la \
+ ${libdir}/alsa-lib/*.la \
+ ${libdir}/gstreamer-0.10/*.la \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/bluetooth/plugins/.debug \
+ ${libdir}/*/.debug \
+"