aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-13 17:17:36 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-13 17:17:36 +0200
commite0ea8fd0f401601b356b77dee159da641b0c83a9 (patch)
tree3df1f00b1a49a97ed960751c4fa83b70f79bf223
parentad7c3aa1f56198b04964f34b0ca71542894768d7 (diff)
downloadopenembedded-e0ea8fd0f401601b356b77dee159da641b0c83a9.tar.gz
bluez: add 4.39
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/bluez/bluez4_4.39.bb64
2 files changed, 68 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 3639659a70..e42c704bd5 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -2742,6 +2742,10 @@ sha256=e5e592de95f50a1569d3e4a95c8b955a2535e265e24869e3ce30e19b0949b465
md5=c1106f56f8e5562cf7c49d3455d2c5f7
sha256=2bfc5db7703cbcaaa4be2576609136450e1dac5d4782707dd0dc81754e3c2489
+[http://www.kernel.org/pub/linux/bluetooth/bluez-4.39.tar.gz]
+md5=ba06291b737077332e914d6d653501c6
+sha256=924dc4b8ae78da2c8f3af9c36ab85d08ee7f8ec0ae4dfe58840ae70041580063
+
[http://www.kernel.org/pub/linux/bluetooth/bluez-4.7.tar.gz]
md5=2aa806940d2c841e57a9b2ab7302b750
sha256=ed384dea4f5f21157758fcd7db64db19ce0b410509c26630706e4a3c779287a0
diff --git a/recipes/bluez/bluez4_4.39.bb b/recipes/bluez/bluez4_4.39.bb
new file mode 100644
index 0000000000..c28f260761
--- /dev/null
+++ b/recipes/bluez/bluez4_4.39.bb
@@ -0,0 +1,64 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland V4"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+
+# For angstrom we want this to replace at least bluez-libs
+PROVIDES_append_angstrom = " bluez-utils bluez-libs"
+
+SRC_URI = "\
+ http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
+ file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
+ file://sbc-thumb.patch;patch=1 \
+ file://bluetooth.conf \
+"
+S = "${WORKDIR}/bluez-${PV}"
+
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+EXTRA_OECONF = "\
+ --enable-gstreamer \
+ --enable-alsa \
+ --enable-usb \
+ --enable-netlink \
+ --enable-tools \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-dfutool \
+ --enable-hidd \
+ --enable-pandd \
+ --enable-dund \
+ --disable-cups \
+ --enable-test \
+ --enable-manpages \
+ --enable-configfiles \
+ --enable-initscripts \
+ --disable-pcmciarules \
+"
+
+do_install_append() {
+ install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
+ # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
+ install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
+}
+
+PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
+
+FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
+FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
+FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
+FILES_${PN}-dev += "\
+ ${libdir}/bluetooth/plugins/*.la \
+ ${libdir}/alsa-lib/*.la \
+ ${libdir}/gstreamer-0.10/*.la \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/bluetooth/plugins/.debug \
+ ${libdir}/*/.debug \
+"