aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-16 21:31:46 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-18 05:25:50 +0100
commitdf43057ec096586d255dc56ad371221f568934e9 (patch)
treedde6b120833e7df0ed91a6be7484fad65797add3
parentc36054c47512bfd46f81618a1b7c20301d0ccd48 (diff)
downloadopenembedded-df43057ec096586d255dc56ad371221f568934e9.tar.gz
gnome-dvb-daemon: add 0.1.14
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/gnome/gnome-dvb-daemon_0.1.14.bb26
2 files changed, 30 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 1db119cde4..cce202729e 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -9566,6 +9566,10 @@ sha256=6bb8ec068558e380aff1e3f0aa130b52161ad68f8d495fce45c55783bbba9076
md5=21fe881ab473fdc9246c36bd8ef929b0
sha256=5b51e0dfae64e7f48883fce6657fcf47a03f6429e2c67024203e31cc29032a22
+[http://launchpad.net/gnome-dvb-daemon/trunk/0.1.14/+download/gnome-dvb-daemon-0.1.14.tar.bz2]
+md5=f7a840620f10e5ecf86516c5cb721eb2
+sha256=fc8d5d3918cae739d86718b6e9124dae2ca5ea033a7d3b4e71fc16b2b6463288
+
[http://ftp.gnome.org/pub/GNOME/sources/gnome-games/2.23/gnome-games-2.23.6.tar.bz2]
md5=9f13ed34427d4c19d423464cd59dba08
sha256=af2ebf32fe93817e06333b94d3fabcf72fa5675f402c1bbdb7bed3be0b3b3a3e
diff --git a/recipes/gnome/gnome-dvb-daemon_0.1.14.bb b/recipes/gnome/gnome-dvb-daemon_0.1.14.bb
new file mode 100644
index 0000000000..d038bf3e90
--- /dev/null
+++ b/recipes/gnome/gnome-dvb-daemon_0.1.14.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GNOME DVB Daemon is a daemon written in Vala based on GStreamer to setup your DVB devices, record and watch TV shows and browse EPG. It can be controlled by any application via its D-Bus interface."
+LICENSE = "GPLv3"
+
+DEPENDS = "libxml2 python-dbus python-gst python-pygtk libgee vala-native gstreamer gst-plugins-good gst-plugins-bad glib-2.0 dbus-glib sqlite3 gst-rtsp"
+RDEPENDS = "python-dbus python-gst python-pygtk gst-plugin-dvb gst-fluendo-mpegdemux dvb-apps dvb-scan dvb-tzap dvb-czap dvbstream"
+
+inherit gnome
+
+SRC_URI = "http://launchpad.net/gnome-dvb-daemon/trunk/0.1.14/+download/gnome-dvb-daemon-0.1.14.tar.bz2"
+
+# We have no use for checking using gst-inspect when crosscompiling, so sed out the check
+do_configure_prepend() {
+ sed -i -e /AG_GST_CHECK_GST_INSPECT/d \
+ -e /G_GST_CHECK_MODULE/d \
+ -e /AM_CHECK_PYMOD/d \
+ ${S}/configure.ac
+ sed -i -e 's:PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}":PYTHON_INCLUDES="-I${STAGING_INCDIR}/python$PYTHON_VERSION":g' \
+ -e 's:PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}":PYTHON_INCLUDES="-I${STAGING_INCDIR}/python$PYTHON_VERSION":g' \
+ ${S}/m4/python.m4
+}
+
+# TODO: split out UI and python stuff
+FILES_${PN} += "${datadir}/dbus-1 ${libdir}/python*"
+FILES_${PN}-dbg += "${libdir}/python*/*/*/*/.debug"
+
+